Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

MPLS LDP Neighbor problem

I cannot establish simple LDP session between P and PE2. LDP neighbor is up between PE1 and P router fine but not between P and PE2. when i use mpls ldp discovery, i get no route on PE2. Does anyone know what the problem is.

PE1

mpls label protocol ldp

interface Ethernet0/0

ip address 192.168.1.1 255.255.255.0

half-duplex

mpls ip

P Router

ip cef

mpls label protocol ldp

interface Ethernet0/0

ip address 192.168.1.2 255.255.255.0

half-duplex

mpls ip

interface Ethernet0/1

ip address 192.168.2.2 255.255.255.0

half-duplex

mpls ip

PE2

mpls label protocol ldp

interface Ethernet0/0

ip address 192.168.2.1 255.255.255.0

half-duplex

mpls ip

PE2#sh mpls ldp discovery

Local LDP Identifier:

192.168.2.1:0

Discovery Sources:

Interfaces:

Ethernet0/0 (ldp): xmit/recv

LDP Id: 192.168.1.2:0; no route

is MBGP needed between P and PE's? Also do i need to setup anything else between P and PE's?

8 REPLIES

Re: MPLS LDP Neighbor problem

Hi,

This is simply because the LDP ID of the P router (192.168.1.2) is not reachable on PE2 (this is what is meant by the "no route" in "LDP Id: 192.168.1.2:0; no route" from your output), this should be simply resolved after you enable a routing protocol in your network. As a recommendation always set the LDP ID manually via the "mpls ldp router-id" command in order not to leave it to the coincidence.

I hope that I've been informative.

BR,

Mohammed Mahmoud.

Cisco Employee

Re: MPLS LDP Neighbor problem

Just to add to what Mohammed is saying, it is usually consider best practice to create a loopback interface on all routers and set this loopback interface as the LDP RID.

mpls ldp router-id loopback0

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Re: MPLS LDP Neighbor problem

thanks guys.

Working now. Apart from setting up ldp neighbor relationships using LDP for label distribution across the MPLS backbone and MBGP between the PE's , What other configs is done within the MPLS backbone between PE's and P routers in a real MPLS network?

Cisco Employee

Re: MPLS LDP Neighbor problem

Francisco,

It can be really simple or really complicated but normally you would have an IGP, LDP (and/or RSVP for MPLS TE), BGP VPNv4, Route Reflectors.

In addition, you can also do label filtering to force LDP to only advertise labels for loopback interface addresses (a label is advertised for all routes except BGP routes by default) as follow.

no mpls ldp advertise-labels

mpls ldp advertise-labels for 1

!

access-list 1 permit 192.168.100.0 0.0.0.255 /* assuming all loopback interface ip addresses are in the 192.168.100.0-255 range */

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Re: MPLS LDP Neighbor problem

Hi,

Absolutely you mean MP-BGP, not MBGP , The two terms has totally different meaning and concept.

The MBGP is multicast BGP used to route Multicast across domaains (Across AS).

The Multiprotocol BGP is used to carry labeled VPNv4 , Multicast, IPv6, labeled IPv6 and exended community attribute.

You dont need MP-BGP to have your LDP session activated. as denoted, its recommended to force the Loopback0 to be ur LDP session identifier and have your IGP correctly setup and MPLS enabled on that link.

HTH

Mohamed

Re: MPLS LDP Neighbor problem

Harold,Mohammed,Mohamed,

Thanks for your imput to this discussion. I have rated your comments.

Francisco.

New Member

Hi,

Hi,

My name is Miguel Angel Mamani Chanuara from Peru,

Well, I also had almost the problem, in your case it is that your PE2 router does not know how to get to the router-ID (192.168.1.2) of P, because PE2 does not find that address (192.168.1.2) in its routing table , Ie you need to distribute that router-ID (192.168.1.2) from the router P by IGP (for example OSPF) to the other routers, in the same way you must distribute the router ID PE2 router to the other routers in the area to That others know how to get to that router-ID.

For example ROUTER P

#router ospf process-ID

#network 192.168.1.2 wildcard-mask area area-ID

Already with that the NO ROUTE should not appear

Regards

New Member

Hi,

          

4372
Views
10
Helpful
8
Replies