Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

MPLS LDP Session not coming up

I have an LDP session configured over my P2P interface and it is not coming up . What can be the reason ? I can ping the P2P IP adddress

*************************

interface FastEthernet4/1

ip address 10.10.0.46 255.255.255.252

ip ospf network non-broadcast

ip ospf cost 10

mpls ip

Router #sh mpls ldp neighbor

*****************************************

interface GigabitEthernet3/4.1254

encapsulation dot1Q 1254

ip address 10.10.0.45 255.255.255.252

ip ospf network non-broadcast

ip ospf cost 10

mpls ip

Regards

Haris P

21 REPLIES

MPLS LDP Session not coming up

Hi Haris,

what do you have in

sh mpls ldp disc

?

Bronze

Re: MPLS LDP Session not coming up

Router2#sh mpls ldp discovery

Local LDP Identifier:

172.16.12.6:0

Discovery Sources:

Interfaces:

GigabitEthernet3/4.326 (ldp): xmit

Router1#sh mpls ldp discovery

Local LDP Identifier:

172.16.22.137:0

Discovery Sources:

Interfaces:

FastEthernet4/1 (ldp): xmit

Re: MPLS LDP Session not coming up

Hi Haris,

thanks, I guess these IPs - 172.16.12.6 and 172.16.22.137 are assigned to the loopback interfaces? do you advertise 'em in OSPF, i.e can R1 reach 172.16.12.6 and vice versa?

you can also enable these debugs, assuming you're in a lab that'll not cause any issues:

debug mpls ldp messages received all

debug mpls ldp messages sent all

HTH,

Ivan.

Bronze

Re: MPLS LDP Session not coming up

Yes ,IP's 172.16.12.6 and 172.16.22.137 are for loopbacks and im advertising

this thru OSPF and ping each other loopback IP's (also from lookpack to

loopback ip by specifying source IP)

During the below debug , I saw some messages going to some other neighbors

but not to the one we want . The message are going to loopback while in my

case the P2P ldp session itself not coming up

debug mpls ldp messages received all

0 messages

debug mpls ldp messages sent all

0 messages

New Member

Re: MPLS LDP Session not coming up

Harris,

  Issue show mpls ldp

Craig

Bronze

Re: MPLS LDP Session not coming up

Router1#sh mpls interfaces

nterface IP Tunnel Operational

FastEthernet4/1 Yes (ldp) No Yes

Router1#sh mpls ldp bindings

tib entry: 0.0.0.0/0, rev 1106706

local binding: tag: imp-null

tib entry: 10.10.10.0/30, rev 62

local binding: tag: imp-null

tib entry: 10.10.10.4/30, rev 64

local binding: tag: imp-null

tib entry: 10.10.10.12/30, rev 60

Router1#sh mpls ldp parameters

Protocol version: 1

Downstream label generic region: min label: 16; max label: 100000

Session hold time: 180 sec; keep alive interval: 60 sec

Discovery hello: holdtime: 15 sec; interval: 5 sec

Discovery targeted hello: holdtime: 90 sec; interval: 10 sec

Downstream on Demand max hop count: 255

LDP for targeted sessions

LDP initial/maximum backoff: 15/120 sec

LDP loop detection: off

Rouetr2#sh mpls ldp parameters

Protocol version: 1

Session hold time: 180 sec; keep alive interval: 60 sec

Discovery hello: holdtime: 15 sec; interval: 5 sec

Discovery targeted hello: holdtime: 90 sec; interval: 10 sec

Downstream on Demand max hop count: 255

LDP for targeted sessions

LDP initial/maximum backoff: 15/120 sec

LDP loop detection: off

Re: MPLS LDP Session not coming up

Haris,

what is in between, some sort of a switch I guess? is that capable of multicast forwarding, for example can you ping 224.0.0.2 from both routers?

please issue 'sh ip int' for respective interfaces.

Bronze

MPLS LDP Session not coming up

Router1#ping 224.0.0.2

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.2, timeout is 2 seconds:

Reply to request 0 from 10.10.0.45, 16 ms

On the Router 2 ,im not receiving any reply for this host (it is configured as ospf network non-broadcast )whether this will effect >?

Router2#ping 224.0.0.2

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.2, timeout is 2 seconds:

Router2#sh mpls ldp discovery

Local LDP Identifier:

    172.16.12.6:0

    Discovery Sources:

    Interfaces:

GigabitEthernet3/4.326 (ldp): xmit

Router1#sh mpls ldp discovery

Local LDP Identifier:

    172.16.22.137:0

    Discovery Sources:

    Interfaces:

        FastEthernet4/1 (ldp): xmit

interface FastEthernet4/1

ip address 10.10.0.46 255.255.255.252

ip ospf network non-broadcast

ip ospf cost 10

mpls ip

*****************************************

interface GigabitEthernet3/4.1254

encapsulation dot1Q 1254

ip address 10.10.0.45 255.255.255.252

ip ospf network non-broadcast

ip ospf cost 10

mpls ip

Bronze

Re: MPLS LDP Session not coming up

In between it is a telco network , OSPF is coming up

I just remove the " ip ospf network non-broadcast " and removed the static neighbor statements and i was able to establish the ospf neighbor relationship

Regards

New Member

HiI had same issue and i did

Hi

I had same issue and i did remove ospf command from interface.

I did reverify all other neighbor router ospf and interface ip.

I did check mpls ip on all the interface connected on this route, but no luck.

 

in sh mpls ldp disc all it was showing xmit. but unable to get exact issue.

all loopback ip were advertised to ospf.

Resetted ospf but no luck.

So decided to reboot router, and it does work.

Prior to reboot, below output I was getting.

R3#
*Sep 24 14:46:12.087: %LDP-5-CLEAR_NBRS: Clear LDP neighbors (*) by console
R3#sh mpls ldp discovery all
 Local LDP Identifier:
    53.0.0.1:0
    Discovery Sources:
    Interfaces:
        FastEthernet0/0 (ldp): xmit
        FastEthernet0/1 (ldp): xmit
R3#sh mpl ld nei

R3#sh mpl ld nei

After reboot I could see mpls neighbors.

 

 

New Member

Re: MPLS LDP Session not coming up

Harris,

  In your setup can you add mpls ldp router-id Loopback force

Also, do you have mpls label protocol ldp

Craig

Bronze

Re: MPLS LDP Session not coming up

Yes , I enter this manually on router

mpls label protocol ldp

no mpls ip propagate-ttl

mpls ldp router-id Loopback1

interface Loopback1

ip address 172.16.22.137 255.255.255.255

end

New Member

Re: MPLS LDP Session not coming up

Harris,

Would you reconfigure the mpls ldp router-id X.X.X.X with a /32 network

mask

Craig

New Member

Re: MPLS LDP Session not coming up

Harris,

Would you reconfigure the mpls ldp router-id to X.X.X.X with a /32 network mask

Craig

Bronze

Re: MPLS LDP Session not coming up

i reconfigure mpls ldp id ,but nothing happened !!!!!!!!!

no mpls ldp router-id Loopback1

mpls ldp router-id Loopback1

Regards

New Member

Re: MPLS LDP Session not coming up

Harris,

  Replace the word Loopback1 with the IP Address /32 mask

Craig

Bronze

Re: MPLS LDP Session not coming up

there is no option to mpls ldp router-id to X.X.X.X with a /32 network mask , i have onkly the options below

Router1(config)#mpls ldp router-id ?

ATM ATM interface

Async Async interface

BVI Bridge-Group Virtual Interface

CDMA-Ix CDMA Ix interface

CTunnel CTunnel interface

Dialer Dialer interface

FastEthernet FastEthernet IEEE 802.3

Group-Async Async Group interface

Lex Lex interface

Loopback Loopback interface

MFR Multilink Frame Relay bundle interface

Multilink Multilink-group interface

Null Null interface

Port-channel Ethernet Channel of interfaces

Tunnel Tunnel interface

Vif PGM Multicast Host interface

Virtual-PPP Virtual PPP interface

Virtual-Template Virtual Template interface

Virtual-TokenRing Virtual TokenRing

XTagATM Extended Tag ATM interface

New Member

Re: MPLS LDP Session not coming up

Harris,

Thanks, would you also issue sh mpls ldp discovery ?

Craig

New Member

Re: MPLS LDP Session not coming up

Harris,

  Please enter sh mpls interface

Craig

Bronze

Re: MPLS LDP Session not coming up

#sh mpls interfaces

Interface IP Tunnel Operational

FastEthernet4/1 Yes (ldp) No Yes

#sh mpls interfaces

GigabitEthernet3/4.325 Yes (ldp) No No No Yes

Bronze

Re: MPLS LDP Session not coming up

While pinging from R1 with 224.0.0.2 ,from R2 im getting reply but not vice versa

R1#ping 224.0.0.2

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.2, timeout is 2 seconds:

Reply to request 0 from 10.10.0.45, 20 ms

SHDSL_GEF3#ping 224.0.0.2

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.2, timeout is 2 seconds:

5621
Views
0
Helpful
21
Replies
CreatePlease to create content