Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPLS on 2610XM via FR question

I have installed an IOS image that supports MPLS on my 3 2610XM routers. I have them connected to a 2520 FR switch via serial

R2 - R1 - R3

OSPF is running between them advertising lo0 which is 1.1.1.1, 2.2.2.2 and 3.3.3.3

I believe that I have configured MPLS and LDP correctly,

show mpls ldp neighbor shows all 3 routers talking.

My Question is this, why does the "BYTES TAG SWITCHED" show as "0" on all 3 routers ?

Here is the output of show mpls on R1

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

16 Untagged 3.3.3.3/32 0 Se0/0 172.12.123.3

17 Pop tag 2.2.2.2/32 0 Se0/0 172.12.123.2

I had to add a line on R1 to get LDP working to R3 as follows,

mpls ldp neighbor 172.12.123.3 targeted ldp

I am very new to this and just want to understand the basic concepts in a small lab environment so forgive me if this one is obvious !!

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: MPLS on 2610XM via FR question

Hi,

use point-to-point subinterfaces. There might be NBMA issues.

In my test labs I always used p2p subinterfaces and it always worked well.

Regards, Martin

5 REPLIES

Re: MPLS on 2610XM via FR question

Hi,

An LSR will use the implicit-null label for directly connected networks. This means basically in your case: if you create the traffic on R1 there will nothing be tagswitched. The respective entry is "Pop tag".

Second: your output shows "untagged" on R1. This usually means MPLS is not up and running between R1 and R3. Make sure the config looks like this:

ip cef

mpls ldp router-id Loopback0

interface Serial0/0

encapsulation frame-relay

interface Serial0/0.100

ip address 10.1.1.1 255.255.255.252

frame-relay interface-dlci 100

mpls ip

mpls label protocol ldp

mpls MTU 1508

The "mpls" commands might be translated to "tag-switching", which does not modify the functionality. Also adjust the FR config and IPs etc. to your environment.

The relevant commands are:

show mpls ldp discovery

show mpls interfaces

Make sure all (sub-)interfaces interconnecting R1, R2 and R3 are MPLS enabled. Otherwise there will no labels be used. Finally it should look like this on R1:

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

16 Pop tag 3.3.3.3/32 0 Se0/0 172.12.123.3

17 Pop tag 2.2.2.2/32 0 Se0/0 172.12.123.2

If no "untagged" shows up, you should ping Loopback to Loopback from R2 to R3 and get tagswitched Bytes in R1.

And last:

mpls ldp neighbor 172.12.123.3 targeted ldp

will start an LDP session even if no MPLS enabled interfaces exist. LDP might be up and running, but the interface settings decide whether labels can be used or not.

Hope this helps! Please use the rating system.

Regards, Martin

New Member

Re: MPLS on 2610XM via FR question

Martin, thanks so much for your response. I have a feeling that this is something to do with my frame-relay configuration.

R1

ip cef

mpls ldp neighbor 172.x.123.3 targeted ldp

tag-switching tdp router-id Loopback0

interface Loopback0

ip address 1.x.x.1 255.255.255.255

interface Serial0/0

ip address 172.x.123.1 255.255.255.0

encapsulation frame-relay

ip ospf hello-interval 5

mpls label protocol ldp

tag-switching ip

no clns route-cache

frame-relay map ip 172.x.123.2 122 broadcast

frame-relay map ip 172.x.123.3 123 broadcast

no frame-relay inverse-arp

R1,R2 and R3 are connected to a c2520 which I am using as a FR switch.

I cannot seem to get R1 to ldp peer with both R2 and R3 unless I use the targeted and when I do that, mpls does not run on one of the connections.

Any ideas ?

Thanks !

Darren

New Member

Re: MPLS on 2610XM via FR question

Martin,

I tried shutting down the FR link from R1 to R3 and using an ethernet connection instead.

That way I can have ldp sessions from R1 to both R2 and R3 and it seems to work.

R1

R1#show mpls forwarding-table

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

16 Pop tag 2.2.2.2/32 12429 Se0/0 172.12.123.2

17 Pop tag 3.3.3.3/32 1140 Fa0/0 10.10.10.3

Sorry for the formatting!!

I don't really understand why it doesn't work with the FR but at least I have something running now, thanks !

D

Re: MPLS on 2610XM via FR question

Hi,

use point-to-point subinterfaces. There might be NBMA issues.

In my test labs I always used p2p subinterfaces and it always worked well.

Regards, Martin

New Member

Re: MPLS on 2610XM via FR question

Yes your are right, I will try that next time.

Thanks again.

Darren

209
Views
3
Helpful
5
Replies