Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

MPLS over GRE tunnel on a 6500

Hi.

Can anyone help me understand why this is happening, please?

Got a 6500 running MPLS in the core; one PE router connecting via gigabit ethernet and another PE via GRE tunnel (MPLS is running over the tunnel).

Inbound traffic from the 'tunnel PE' is switched to the 'gig PE' but not vice versa. The config works fine using a router instead of the 6500.

Here are the interface configs. Apart from ip addressing, config is kept basic and is similar on either side.

interface Tunnel2

ip address 10.1.44.5 255.255.255.252

mpls label protocol ldp

mpls ip

tunnel source GigabitEthernet0/1

tunnel destination 10.1.40.1

interface GigabitEthernet0/0

ip address 10.1.32.2 255.255.255.252

mpls label protocol ldp

mpls ip

Thx

3 REPLIES
Community Member

Re: MPLS over GRE tunnel on a 6500

This is not supported on the 6500 plattform. I maybe say som in the Future Navigator but I belive you need the OSM module or SIP 600 blade.

Re: MPLS over GRE tunnel on a 6500

Can you try to configure this in the global mode and probably update us back what is the effect for your mpls tunnel.

Router(config)# mls mpls tunnel-recir

Router(config)#

Command Reference:

http://www.cisco.com/en/US/products/hw/switches/ps708/products_command_reference_chapter09186a00801ea88c.html#wp1836503

HTH-Cheers,

Swaroop

Community Member

Re: MPLS over GRE tunnel on a 6500

Yes, I'm beginning to see that it's not supported. I've got my workarounds & solutions, I just don't understand what I'm fixing.

Can anyone elaborate on what exactly is breaking in the 6500?

In the meantime I'll try the 'recir' cmd.

Many Thx!

664
Views
0
Helpful
3
Replies
CreatePlease to create content