Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPLS over PPP protcol

Dear All,

I have MPLS network, the routers are being used cisco ASR9000 you are planning  to build a backup link between these router,  the existing link sis fiber link,

The satellite modem has serial interface V.35, we are using cisco router(2921) with smart serial (Hwic) to connect it, this router is necessary   needed to bring the satellite link up, the initial communication between the router and the modem the is  V.25bis to trigger the modem and initiate a link between the other modem at the other end  after the satellite link established , the router build   PPP link between the other end.

This is the configuration on 2921

interface FastEthernet0/0

ip address 192.168.11.99 255.255.255.0

duplex auto

speed auto

1nterface serial0/0

ip address 10.10.100.2 255.255.255.0

encapsulation ppp

ip tcp header-compression iphc-format

no ip mroute-cache

dialer in-band

dialer idle-timeout 30

dialer wait-for-carrier-time 30

dialer map ip 192.168.10.101 name HUB_ HSCU_ 1 101

dialer map  ip 192.168.10.102 name  HUB_ HSCU_ 2 101

dia1er·group 1

fair -Queue 64 256 36

pulse-time 2

IP rtp header-compression iphc-format

!

ip classless

ip route 192.168.10.0 255.255.255.0 ser1a10/0

no ip http server

Since we are using MPLS which is layer 2.5, the 2921 will modify the whole packet and rebuild it and lose the MPLS information 24 bytes then we will the connectivity between the MPLS routers.

My question is there a way to solve the puzzle

Thanks

Everyone's tags (4)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

MPLS over PPP protcol

Abdallah,

Those IOS versions are first IOS versions in which this command was implemented or modified. From those versions and going forward, the command should be available in all newer IOS versions.

What IOS Feature Set or license are you running? It is possible that you need additional license to unlock the necessary functionality.

Best regards,

Peter

New Member

MPLS over PPP protcol

Hi Abdallah,

You'll need 'data' license to use this feature.

You can try to evaluate this license to test your configuration (if not evaluated before):

http://www.cisco.com/en/US/docs/routers/access/sw_activation/SA_on_ISR.html#wp1155619

Sergey

14 REPLIES
New Member

MPLS over PPP protcol

Hi,

You can build L2TPv3 tunnel between 2921 over satellite link and xconnect ethernet interfaces facing MPLS routers.

Check this thread:

https://supportforums.cisco.com/thread/2100801

New Member

Re: MPLS over PPP protcol

Thanks Sergey

My understand about L2TP is supporting Point to point session and not supporting point-to-multipoint or multipoint-to-point sessions.

My situation is point to multipoint; Hub with 6 remotes , but on the other hand the technology we are using on satellite allow only on link between the hub and one of the remote on other word we can’t establish to more than one  connection in one time, we using technology named  DAMA (demand assigned multiple access )to save bandwidth on satellite you only assign the 2 Mb only for one remote at a time based on demand .

Attached draw for the current setup,

Any suggestions help

Regards

New Member

Re: MPLS over PPP protcol

Any suggestions ??

New Member

Re: MPLS over PPP protcol

As I see there should be 2 ways:

- build l2tp tunnels between your hub and remote sites (terminate in different vlans on your hub)

  one of the tunnel will come up and you'll get l2 connectivity between hub and remote site, while 2921 will remain transparent to the network

- As I see in docs 2921 supports MPLS and you should be able to configure it over PPP interface

Re: MPLS over PPP protcol

As sergey suggested, you can run L2TPv3 PW between the 2921 in a hub and spoke manner but in a point to point fashion.

and you can run PPPoL2TPv3. you dont need to run MPLS as L2TPv3 supports PPP,HDLC,ATM,Ethernet, frame relay etc

HTH

Kishore

New Member

Re: MPLS over PPP protcol

Thanks  Kishore and sergey,

My question is how can I determine the destinations for MPLS traffic coming to my 2921router on  fast Ethernet port? I have different destination and according the above configurations  I need to know which site should traffic goes then dial up the interface as command does

dialer map ip 192.168.10.101 name HUB_ HSCU_ 1 101

By the way there are VLAN tags with MPLS traffic coming to my port

Thanks

New Member

Re: MPLS over PPP protcol

For example you have Fa0/0 facing your mpls router, then you have 3 sub-interfaces:

pseudowire-class pwc_l2tp

encapsulation l2tpv3

ip local interface Loopback0

int Fa0/0

no ip address

mtu ...

int Fa0/0.10

encapsulation dot1q 10

xconect [remote_ip_10] 10 pw-class pwc_l2tp

int Fa0/0.11

encapsulation dot1q 11

xconect [remote_ip_11] 11 pw-class pwc_l2tp

int Fa0/0.12

encapsulation dot1q 12

xconect [remote_ip_12] 12 pw-class pwc_l2tp

You should have routes to remote_ip_xx which are remote loopback ip addresses.

You can then use this remote_ip_xx in your dialer map. L2TPv3 traffic will trigger your dialer...

New Member

Re: MPLS over PPP protcol

Hi

One more thing i am trying to configure 2921 but i found it dosent support

pseudowire-class command i am trying to look for suitable IOS, can guid me for the right one?

Thanks

New Member

MPLS over PPP protcol

Something strange i tried many of IOS nothing helped, the IOSs released for 2900 starting 15.0 and link below

http://www.cisco.com/en/US/docs/ios/wan/command/reference/wan_m1.html#wp1013715

states that the supported  IOSs are 12.0(23)S , 12.3(2)T , 12.2(25)S  and 12.2(27)SBC.

Where can I find such IOS release.

Thanks

Cisco Employee

MPLS over PPP protcol

Abdallah,

Those IOS versions are first IOS versions in which this command was implemented or modified. From those versions and going forward, the command should be available in all newer IOS versions.

What IOS Feature Set or license are you running? It is possible that you need additional license to unlock the necessary functionality.

Best regards,

Peter

New Member

MPLS over PPP protcol

Hi Peter,

I tried these IOS:

c2900-universalk9-mz.SPA.151-1.T

c2900-universalk9-mz.SPA.151-2.GC1

c2900-universalk9-mz.SPA.150-1.M7

with show version command shows that I have only IP base no security or Voice license,

what do you think I need to be able to run this command?, on other hand while I am suing GNS3 I able to run the command on 3725 with c3725-adventerprisek9-mz.124-15.T10.bin IOS.

Regards,

Abdallah

New Member

MPLS over PPP protcol

Hi Abdallah,

You'll need 'data' license to use this feature.

You can try to evaluate this license to test your configuration (if not evaluated before):

http://www.cisco.com/en/US/docs/routers/access/sw_activation/SA_on_ISR.html#wp1155619

Sergey

New Member

MPLS over PPP protcol

Hi

I have implemented this configuration on the VSAT routers

When i checked the L2TPv3 configuration, show l2tun session all

Shows me everything is fine and the tunnel established  

Before I bring the MPLS traffic, is there way to check the if L2TPv3 configuration fine? Like using laptop to ping the other side

Regards

Abdallah

New Member

MPLS over PPP protcol

HI Sergey

Actually the L2TPv3 always attempts to build the tunnel between the two  routers, regardless if the customer send data or not, the point is WAN  should go up only if there is traffic coming from the customers  (MPLS)routers , since the satellite is backup  link and are charged based on the usage.

Is there way to build access list based on the traffic coming from customer side?

The Traffic has VLAN tag based on the VLAN tag, the L2TPv3 Build the tunnel for specific destination?

Thanks

3117
Views
10
Helpful
14
Replies
CreatePlease login to create content