cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
464
Views
0
Helpful
2
Replies

MPLS QoS at PE Edge on Subinterface

maher
Level 1
Level 1

Hi there,

Currently, Im using below configuration for PE router for hub and spoke:

class-map match-any P1

match ip dscp ef

class-map match-any P3

match ip dscp default

class-map match-any P2

match ip dscp af31

!

!

policy-map QoS

class P1

priority percent 35

class P2

bandwidth percent 40

random-detect

class P3

bandwidth percent 25

random-detect

However, for the internet access, I configured PE-Internet into VLAN because of managed internet access plus with managed firewall.

I tried to applied on subinterface but, I got this error msg on my PE-Internet running on c7200 series:

CBWFQ : Not supported on subinterfaces

Any ideas?

Thanks in advanced.

1 Accepted Solution

Accepted Solutions

mheusinger
Level 10
Level 10

Hi,

a VLAN subinterface is a software interface and thus has no hardware queue. So CBWFQ is not supported directly. What you can do is to apply a nested policy:

policy-map shapeX

class class-default

shape average X !specify bandwidth

service-policy output MyPolicy

interface FastEthernet0/0.100

encapsulation dot1q 100

ip address ...

service-policy output shapeX

The policy-map MyPolicy would be the one you tried to apply directly.

Hope this helps! please rate all posts.

Regards, Martin

View solution in original post

2 Replies 2

mheusinger
Level 10
Level 10

Hi,

a VLAN subinterface is a software interface and thus has no hardware queue. So CBWFQ is not supported directly. What you can do is to apply a nested policy:

policy-map shapeX

class class-default

shape average X !specify bandwidth

service-policy output MyPolicy

interface FastEthernet0/0.100

encapsulation dot1q 100

ip address ...

service-policy output shapeX

The policy-map MyPolicy would be the one you tried to apply directly.

Hope this helps! please rate all posts.

Regards, Martin

Martin, Thanks!