Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MPLS QoS with Uniform tunnel mode

Hi, I am trying to test all mode of MPLS QoS tunnle mode like uniform,etc.

My diagram is as below:

CE01 --access--> ME4900 --trunk--> PE01 --ldp--> P01 --ldp--> P02 --ldp--> PE02 --access--> CE02

All traffic from CE01 are marked with DSCP AF31 an send to PE01. But PE01 can not see packet with AF31.

On ME4900, i just config access port and trunk port only. Nothing else were config on ME4900.

What should be the problem? or Does ME4900 reset DSCP value to 0 by default? if yes, how to fix it?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

Can you try enabling the below command under ME4900 Gi1/7 interface and check

mls qos trust dscp

Regards

Varma

31 REPLIES

Re: MPLS QoS with Uniform tunnel mode

Hi Chan

Are you providing L3 VPN or L2 VPN services between CE01 and CE02..If its L2VPN then in my understanding we would not be able to see the DSCP marking at PE01 trunk interface towards ME4900.

If we send an AF31 packet from CE01 and don't alter anything in the MPLS Backbone and egress PE02 then on CE02 we should receive the same AF31 marking..

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

Thanks for reply.

I am doing L3 VPN and PE01 is not able to see AF31 when i sent the packet with AF31 from CE01.

I check on ME4900 and i got below result:

ME4900#sh qos

QoS is disabled globally

IP header DSCP rewrite is enabled

Is that could the problem that PE01 can not see AF31 as ME is rewriting the IP DSCP value?

Regards,

chanty

Re: MPLS QoS with Uniform tunnel mode

Hi Chan

Can you check the cos-dscp mutation map for the default rewrite happening on the ME4900..On the Uplink trunk interface to PE01 are you trusting cos or dscp ?

On PE01 are you doing a dot1q subinterface config or VLAN SVI based config..Where did you check for the AF31 marking at PE01 on the L2 Trunk Interface or L3-dot1q subbinterface or L3 SVI ?

Note:Edited: And how about checking at CE02 whether the AF31 marking is received or not ?

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

1. I am not quite sure how to check cos-dscp mutation map. could you advise the command or doc? note: QoS is disable on ME4900 and there is not QoS config at all on ME4900. Eveything is kept at it default config.

2. I am doing subinterface as gateway for CE01. I am verifying the marking on subinterface with policy-map. I just create class to match with AF31 and apply to the interface.

Re: MPLS QoS with Uniform tunnel mode

Hi Chan

Please check for below commands on ME4900

show mls qos

show mls qos maps

Also please share the uplink trunk interface config for ME4900 to PE01

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

Below are the result:

interface GigabitEthernet1/7

description CONNECT-TO-PE-01

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 76,88,89,94,101,1346,1370,1414,1503

switchport mode trunk

end

ME4900#sh mls qos

QoS is disabled globally

IP header DSCP rewrite is enabled

ME4900#sh mls qos maps

DSCP-TxQueue Mapping Table (dscp = d1d2)

d1 : d2  0  1  2  3  4  5  6  7  8  9

-------------------------------------

0 :    01 01 01 01 01 01 01 01 01 01

1 :    01 01 01 01 01 01 02 02 02 02

2 :    02 02 02 02 02 02 02 02 02 02

3 :    02 02 03 03 03 03 03 03 03 03

4 :    03 03 03 03 03 03 03 03 04 04

5 :    04 04 04 04 04 04 04 04 04 04

6 :    04 04 04 04

Policed DSCP Mapping Table (dscp = d1d2)

d1 : d2  0  1  2  3  4  5  6  7  8  9

-------------------------------------

0 :    00 01 02 03 04 05 06 07 08 09

1 :    10 11 12 13 14 15 16 17 18 19

2 :    20 21 22 23 24 25 26 27 28 29

3 :    30 31 32 33 34 35 36 37 38 39

4 :    40 41 42 43 44 45 46 47 48 49

5 :    50 51 52 53 54 55 56 57 58 59

6 :    60 61 62 63

DSCP-CoS Mapping Table (dscp = d1d2)

d1 : d2  0  1  2  3  4  5  6  7  8  9

-------------------------------------

0 :    00 00 00 00 00 00 00 00 01 01

1 :    01 01 01 01 01 01 02 02 02 02

2 :    02 02 02 02 03 03 03 03 03 03

3 :    03 03 04 04 04 04 04 04 04 04

4 :    05 05 05 05 05 05 05 05 06 06

5 :    06 06 06 06 06 06 07 07 07 07

6 :    07 07 07 07

CoS-DSCP Mapping Table

   CoS:   0  1  2  3  4  5  6  7

--------------------------------

  DSCP:   0  8 16 24 32 40 48 56

Regards,

chanty

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty (sorry I was using wrong name till now..)

Since the MLS QoS is disabled globally everyhting should be passed unalteredly. Can you check and share for the trust state of the uplink interface Gi1/7 on ME4900 using

show mls qos interface Gi1/7

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

ME4900#sh mls qos int g1/7

QoS is disabled globally

Port QoS is enabled

Administrative Port Trust State: 'untrusted'

Operational Port Trust State: 'dscp'

Trust device: none

Default DSCP: 0 Default CoS: 0

Appliance trust: none

Tx-Queue   Bandwidth   ShapeRate   Priority   QueueSize

             (bps)       (bps)                (packets)

  1        250000000   disabled    N/A        2080    

  2        250000000   disabled    N/A        2080    

  3        250000000   disabled    normal     2080    

  4        250000000   disabled    N/A        2080    

ME4900#

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

Can you try enabling the below command under ME4900 Gi1/7 interface and check

mls qos trust dscp

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

Any performance impact when turn it on? How about access port, do i need to turn it on too?

Regards,

chanty

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

If on the access port we are not doing any trust device or trust cisco-phone which is typical of an enterprise scenario then we would need to trust dscp on Access Link ( we can't use cos as its Access Port and no VLAN Info)

Please see below link for same which gives a nice explaination.

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml

Regarding the impact of introducing this command in a production network, I can say from my personal experience and understanding this should not create any issue untill unless there is congestion as QoS is needed for avoiding congestion.Hope I make myself clear on this point..

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

Wow, many thanks for great advise and kindly help.

I will get back to you after i get the result.

Regards,

chanty

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

Another strang output:

ME4900#sh mls ?  

% Unrecognized command

ME4900#sh mls qos ?

% Unrecognized command

ME4900#sh mls qos

QoS is disabled globally

IP header DSCP rewrite is enabled

It looks like mls command is not available but it work when i just enter it??

Regards,

chanty

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

Can you check for the IOS Code of the ME4900 in the Cisco-Feature Navigator and see for MLS feature there..

I have see this a couple of times before same behaviour due to IOS..

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

It work now. I can see DSCP AF31 on PE01 and also on CE02 after enable "mls qos trust dscp" on all related switch ports like trunk port connecting to PE and access port connecting to CE. Many thanks.

But without implementing Unform mode (copy EXP to QoS group on Ingress interface of PE02 facing to Core and copy QoS group to IPP on egress interface of PE02 facing to CE), i still can see DSCP is passing from end-to-end. Why??

Regards,

chanty

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

Glad to hear that it works now

As I have said in initial replies the default nature of MPLS VPN is to work in Short PIPE mode in a way such that the DSCP value of the IP Packet arriving at the Ingress Interfcae of Ingress PE (PE01) is preserved all across the MPLS Backbone and the IP Packet is sent out via the Egress PE's (Here PE02) egress interface unchanged..

This is becuase in the MPLS domain QoS is applied based on EXP bits of MPLS Label which by default works as below:

IP2MPLS Transition

The DSCP value of incoming packet is copied to the MPLS EXP

MPLS2MPLS

The Top MPLS Label is swapped preserving the MPLS EXP value

MPLS2IP Transition

The MPLS Lable is popped and the underlying IP Packet with original DSCP is transmitted. The EXP value is not copied down to the IP DSCP..Can be done optionally via QoS groups though during MPLS2IP Transition in Uniform Mode to preserve the PHB of the IP Packet in accordance with the treatement given in the Service Provider's MPLS Backbone.

Hope this helps to answer your query.

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

As i read in a Cisco document, Uniform mode is the default operation of MPLS VPN to preserver QoS value and the EXP bit is actually copied to IPP at the far end PE as below flow. Any idea?

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

I don't think Uniform Mode can be the default mode of operation in MPLS_VPN_QoS as explained before duirng MPLS2IP Transition the EXP is not carried down to the IPP. That needs to be done manually via QoS Groups..

You can test the same by setting the EXP of the MPLS Packet during IP2MPLS Transition to anything other than the IPP of the incoming Packet at the ingress and observe at the egress interface that the original IPP is being transmitted irrespective of the fact the the MPLS EXP was altered towards the core.

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

I am doing it now and will feed back.

Regards,

chanty

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

I try to change but not allow as below:

policy-map CHANGE_EXP

  class class-default

   set mpls experimental topmost 6

P02(config-if)#service-policy input CHANGE_EXP

set mpls exp topmost cannot be configured on input direction for this interface

Configuration failed!

P02(config-if)#service-policy out CHANGE_EXP 

set mpls exp topmost cannot be configured on output direction for this interface

Configuration failed!

Any idea?

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

Is this the Core-MPLS enabled interface where you are trying to alter the EXP or CE-Facing Interface ?

We need to set the EXP on the CE-Facing Interface in Incoming Direction or set the EXP on the Core-Facing Interface in Outgoing direction.

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

Let see the diagram again to better understand:

CE01 --access--> ME4900 --trunk--> PE01 --ldp--> P01 --ldp--> P02 --ldp--> PE02 --access--> CE02

Below policy applied to interface on PE02 facing to P02:

policy-map CHANGE_EXP

class class-default

  set mpls experimental topmost 4

interface GigabitEthernet0/0

desc CONNECT P02

mtu 1600

ip address 111.90.180.106 255.255.255.252

ip mtu 1500

duplex auto

speed auto

media-type rj45

mpls ip

service-policy output CHANGE_EXP

To verify whether EXP was changed by the policy, I did as below on PE01:

policy-map QOSGROUP2IPP

class class-default

  set precedence qos-group

policy-map EXP2QOSGROUP

class class-default

  set qos-group mpls experimental topmost

interface GigabitEthernet0/1

description CONNECT P01

mtu 1600

ip address 111.90.180.93 255.255.255.252

ip mtu 1500

duplex full

speed 1000

media-type sfp

negotiation auto

mpls ip

!

service-policy input EXP2QOSGROUP

interface GigabitEthernet0/3.1414

description CONNECT CE01

encapsulation dot1Q 1414

ip vrf forwarding Customer_A

ip address 10.10.10.1 255.255.255.0

service-policy output QOSGROUP2IPP

end

And then i turn on wireshark on a PC under CE01 to capture the packet. But I still DSCP AF31 which set by CE02.

Am i doing something wrong?

Regards,

chanty


Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

The config seems all correct..What is the EXP value showing on PE01 int Gi0/1 coming from Core Side

What is the IPP value on the egress interface of PE01 towards CE01 int Gi0/3.1414

show policy-map int gi0/1

show policy-map int gi0/3/1414

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

Below is the result:

PE01#sh policy-map interface g0/1

GigabitEthernet0/1

  Service-policy input: EXP2QOSGROUP

    Class-map: class-default (match-any)

      7823573 packets, 5157126670 bytes

      5 minute offered rate 11345000 bps, drop rate 0 bps

      Match: any

      QoS Set

        qos-group mpls experimental topmost

          Packets marked 2235494

PE01#sh policy-map interface g0/3.1414

GigabitEthernet0/3.1414

  Service-policy output: QOSGROUP2IPP

    Class-map: class-default (match-any)

      3200 packets, 1589971 bytes

      5 minute offered rate 1000 bps, drop rate 0 bps

      Match: any

      QoS Set

        precedence qos-group

          Packets marked 2886

How to check for below questions:

1. What is the EXP value showing on PE01 int Gi0/1 coming from Core Side

2. What is the IPP value on the egress interface of PE01 towards CE01 int Gi0/3.1414

Regards,

chanty

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

Can you try using simple policy-maps without using QoS_Groups on the PE02 Ingress Interface and PE01 Egress Interface ie

On PE02 CE02-Facing Interface just set the mpls exp to 4 . On PE02 towards Core-Facing Interface apply Policy-Map to match EXP4 using Class Map EXP4. On PE01 use Policy-Map outwards towards CE01 to match IPP4 and IPP3 and see whether now you see IPP4 or IPP3 outwards towards CE01..

PE02

class-map match-all EXP4

match mpls experimental topmost 4

!

policy-map CHANGE_EXP

class class-default

  set mpls experimental topmost 4

!

policy-map MATCH_EXP

class EXP4

  !

interface GigabitEthernetX/Y

desc CONNECT CE02

service-policy input CHANGE_EXP

!

interface GigabitEthernet0/0

desc CONNECT P02

service-policy output MATCH_EXP

PE01

class-map match-all IPP3

match ip dscp af31

class-map match-all IPP4

match ip dscp af41

!

policy-map MATCH_IPP

class IPP4

class IPP3

!

interface GigabitEthernet0/3.1414

description CONNECT CE01

service-policy output MATCH_IPP

Then on PE02 take snapshot for

show policy-map interface Gi0/0

show policy-map intercae "CE02_Interface"

Then on PE01 take snapshot for

show policy-map interface Gi0/3.1414

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

Traceroute from PE02 to the PC shows that EXP is set but is changed after it reachs PE01. It looks like topmost label was popped by PHP on P01. I think to resolve the issue i need to "mpls ldp explicit-null" on PE01. any idea?

Regards,

chanty

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

Disabling PHP on PE01 will not change the default behaviour of MPLS2IP Transition ( ie EXP being not carried down to IPP)

UHP is  being used in scenarios whereby we need to determine the PHB of the Egress Interface as derived from the changes made in the MPLS EXP bit within MPLS Core..e.g Carrer Supporting Carrer Scenarios.

Regards

Varma

New Member

Re: MPLS QoS with Uniform tunnel mode

Hi Varma,

Below are the result on PE02 (G0/0 facing to Core, G0/1 facing to CE02).

PE02#sh policy-map interface g0/0

GigabitEthernet0/0

  Service-policy output: MATCH_EXP

    Class-map: EXP4 (match-all)

      0 packets, 0 bytes

      5 minute offered rate 0 bps

      Match: mpls experimental topmost 4

    Class-map: class-default (match-any)

      5287 packets, 1906540 bytes

      5 minute offered rate 8000 bps, drop rate 0 bps

      Match: any

PE02#sh policy-map int g0/1

GigabitEthernet0/1

  Service-policy input: CHANGE_EXP

    Class-map: class-default (match-any)

      2921 packets, 1447278 bytes

      5 minute offered rate 4000 bps, drop rate 0 bps

      Match: any

      QoS Set

        mpls experimental topmost 4

          Packets marked 0

==================================================

Below is the result on PE01

PE01#sh policy-map interface g0/3.1414

GigabitEthernet0/3.1414

  Service-policy output: MATCH_IPP

    Class-map: IPP4 (match-all)

      0 packets, 0 bytes

      5 minute offered rate 0 bps

      Match: ip dscp af41 (34)

    Class-map: IPP3 (match-all)

      2194 packets, 1197924 bytes

      5 minute offered rate 4000 bps

      Match: ip dscp af31 (26)

    Class-map: class-default (match-any)

      237 packets, 18395 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

Regards,

chanty

Re: MPLS QoS with Uniform tunnel mode

Hi Chanty

I see that we are unable to set the MPLS EXP to 4 at the PE02 router ..Now I realize that we are setting the mpls experimental topmost which is not working as label is being imposed here.

Can you change the CHANGE_EXP policy map as below and check

PE02

policy-map CHANGE_EXP

class class-default

  set mpls experimental imposition 4

Regards

Varma

1055
Views
5
Helpful
31
Replies