Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MPLS RIP V2

Hello to All,

I have the following configuration;

CE1 ---->PE1

LAN: 172.21.0.0/16

CE2---->PE2

I have 2 CE (CE1 & CE2) which is connected on the same LAN (running HSRP). The CE's are connected to two different PE (PE1 & PE2). The routing protocol is RIPv2. My question is;

1. Do I need to enable SOO in the PE1 and PE2 router? (i.e. ip vrf sitemap)

2. When I redistribute BGP into RIP and vice versa, Do I need to filter the RIP in the PE routers (there might be some loop in the network)

3. Do you have sample configuration for this kind of setup?

Thanks.

4 REPLIES

Re: MPLS RIP V2

Hello,

with RIP there are some potential routing loop issues.

A route learned from a second site will be sent through f.e. PE1 to the CEs and learned again by PE2, which will consider this preferable over the iBGP route (RIP AD 120, iBGP AD 200). So you have to make sure that this does not happen.

Second, a route learned by one PE might be reinserted into RIP once the network is withdrawn by RIP (BGP table entry still in place).

So you should implement SOO and some filter for redistribution. One possible config - assuming IP addresses from 10.0.0.0/8 - would be:

CE1

router rip

version 2

network 10.0.0.0

no auto-summary

CE2

router rip

version 2

network 10.0.0.0

no auto-summary

PE1

interface Serial0/0

description to CE1

ip vrf forwarding Site1

ip vrf sitemap SOOSite1

ip address 10.1.0.1 255.255.255.252

router rip

address-family ipv4 vrf Stite1

version 2

redistribute bgp 65000 metric 14

!or whatever hopcount is needed in your topology, that the update does make it to CE2, but not to PE2

network 10.0.0.0

no auto-summary

router bgp 65000

address-family ipv4 vrf Stite1

redistribute rip

route-map SOOSite1 permit 10

set extcommunity soo 65000:1

PE2

interface Serial0/0

description to CE2

ip vrf forwarding Site1

ip vrf sitemap SOOSite1

ip address 10.2.0.1 255.255.255.252

router rip

address-family ipv4 vrf Stite1

version 2

redistribute bgp 65000 metric 14

!or whatever hopcount is needed in your topology, that the update does make it to CE2, but not to PE2

network 10.0.0.0

no auto-summary

router bgp 65000

address-family ipv4 vrf Stite1

redistribute rip

route-map SOOSite1 permit 10

set extcommunity soo 65000:1

This should ensure to avoid possible routing loops.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: MPLS RIP V2

Hello Martin,

You mentioned about implementing filter for redistribution. Does it mean that I have to do it on the rip routes (distribute-list) or in BGP or both?

If you dont mind, can you give a configuration example?

Thanks for the help.

Re: MPLS RIP V2

Hello,

you can filter the routes during redistribution like this:

router rip

redistribute bgp 65000 route-map RIP2BGP

route-map RIP2BGP permit 10

match ip address prefix-list 123

ip prefix-list 123 seq 5 permit 10.1.0.0/16 ge 16

The prefix-list defines the allowed (or disallowed using deny) networks.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: MPLS RIP V2

Hello Martin,

Thanks for your help.

288
Views
10
Helpful
4
Replies
CreatePlease to create content