Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPLS route leaking issue

Hi all,

I have a problem in MPLS route leaking. First let me describe my network.

I have a network which includes 3 7609s and two 2800 series routers. Two 7609s act as PE/P and one 7609 work as PE and the 2800 series work in normal situation.(see attached diagram)

I have three E1s between 7609-1 to the 7609-PE, because of the hardware limitation I couldn't bundle them with PPP Multilink. So I used IP Unnumbered on the both side of each E1. So the configuration is like below:

interface Serial8/0/0.1/1/2/1:0
description TO: 7609-PE

ip unnumbered Loopback2
encapsulation ppp
ip ospf network point-to-point
ip ospf hello-interval 1
logging event link-status
load-interval 30
mpls ip
no fair-queue

Basicly I have one VPN on the 7609-PE, to connect this VPN to global routing table I have configured MPLS route leaking, the configuration is :

ip vrf OMU
rd 65500:100
route-target export 65500:100
route-target import 65500:100

*** VRF configuration ***

interface Loopback5
description VPN_OMU
ip vrf forwarding OMU
ip address 10.131.0.105 255.255.255.255

*** To point static route inside VPN ***

ip route vrf OMU 0.0.0.0 0.0.0.0 10.131.0.6 global

*** this is default route from inside VPN to global routing table and the 10.131.0.6 is the IP Address of neighbor router- 7609-2 ***

ip route 10.131.89.0 255.255.255.224 Loopback5 10.131.80.3

*** 10.131.89.0 is direcly connected to 7609-PE under VPN OMU and loopback is under VRF OMU and the 10.131.80.3 is the BGP address of 7609-PE ***

The IGP is simple OSPF. but under OSPF there are some commands that related to traffic engineering.

On the 2800 to 7609-1 and 7609-2 there is a OSPF.

My CEF load-sharing algorithm is universal.

I'm able to ping evey clinets inside VPN from outside and able to ping all the network from inside of VPN. It means that the configuration is okey!.

My problem is if I ftp from a client that connected to 2800 to a client which is connected to 7609-PE and ping from same clinet , firts FTP is too slow and  ICMP packets starting to lost !!!!

I would be grateful if you could help me in this regard. It's drive me crazy!!!!!!!

2 REPLIES
New Member

Re: MPLS route leaking issue

Hi,

A few things are required to help us solve your issue:

1. Could you please attached all configurations of each device.

2. Please perform a traceroute from the client end to the ftp server where you are having the latency and packet loss issues. Also, please perform "show ip route" commands globally and under the vrf so we can confirm all routing is correct. (just becasue you can ping one end doesn't mean its routing properly).

3. Are you running TE (you said under the OSPF configuration there is some TE configurations)? Being able to view the full configurations will answer this.

Once you answer the above, we can help further.

Thanks.

Joe.

Cisco Employee

Re: MPLS route leaking issue

Hi Amir,

If you want 10.131.89.0 to be visible directly from the GRT (and avoid your hack via the loopback), you can use the vrf select feature which allows you to have an interface in both a VRF and the GRT

http://www.cisco.com/en/US/docs/ios/12_0s/feature/guide/vrfselec.html

https://supportforums.cisco.com/message/972563#972563

I don't know if it's related to your issue but it should at least simplify your configuration. Other things you can check is any drops on any interface, MTU issue, congestion on any interface,..

HTH

Laurent.

1697
Views
0
Helpful
2
Replies
CreatePlease to create content