Cisco Support Community
Community Member

MPLS - route missing from mpls forwarding table


I have got a weird problems with one route being present in the VRF however it is not present int the mpls forwarding table:

Below are the outputs:

sh ip route vrf cust

U [1/0] via

C is directly connected, Virtual-Access175

cust5#sh mpls forwarding-table vrf cust

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop

tag    tag or VC   or Tunnel Id      switched   interface

1208   Untagged[V]   \

                                     0          Vi175      point2point

Route for is missing from the mpls forwarding-table

This is a VPDN user and I send the following RADIUS attributes:

lcp:interface-config#1=ip policy route-map cust

lcp:interface-config#2=ip vrf receive cust

ip:route=vrf cust

VRF/MPLS configured as following:

ip vrf cust

rd 11:102

vpn id 11:102

route-target export 11:102

route-target import 11:102


address-family vpnv4

  neighbor x.x.x.x activate

  neighbor x.x.x.x send-community extended


address-family ipv4 vrf cust

  redistribute eigrp 102

  no synchronization



address-family ipv4 vrf cust

  redistribute connected metric 2500 1000 255 1 1500

  redistribute static metric 2500 1000 255 1 1500


  no auto-summary

  autonomous-system 102




Cisco Employee

MPLS - route missing from mpls forwarding table

Hi Michal,

which IOS are you running?

Is the route in CEF table? (show ip cef vrf cust

what happens if you clear it, does it get a label assigned?

how often do you see the issue? on how many routers? Is that VPDN prefix stable or does it flap every now and then?

Is learned only via VPDN or can be learned from some other location (i.e. the MPLS VPNv4 core) and radius is just a backup means?



Community Member

MPLS - route missing from mpls forwarding table

Cisco IOS: c7301-js-mz.124-23.bin

cust5#sh ip cef vrf cust, version 114, epoch 0, cached adjacency to Virtual-Access480

0 packets, 0 bytes

  tag information set

    local tag: VPN-route-head

  via, 0 dependencies, recursive

    next hop, Virtual-Access480

    valid cached adjacency

    tag rewrite with Vi480, point2point, tags imposed: {}

I haven't tried to clear it. I have also tried configuring static route however that didn't make any difference.

VPDN prefix is stable and it doesn't flap. is only learned via static route assigned by Cisco AV-Pair. There is no other means for learning that route. I have also tried to configure static route within VRF directly no the router however that didn't mae any difference.

I am wondering whether ip vrf receive is the key thing here. When I change radius attributes to #ip vrf forwarding cust then the routing works. When I set it to #ip vrf receive cust I can get access to the outside but internal routing doesn't work.

Cisco Employee

MPLS - route missing from mpls forwarding table

honestly i am not very familair with RADIUS configuration and issue related to it to be able to give a conclusive answer.

I would only try to clear the route to see if it makes any difference (hence identifying an IOS bug).

You'd better open a TAC case for thourough investigation anyway.


Community Member

Re: MPLS - route missing from mpls forwarding table

Hi there,

I think the problem is that you are not redistributing the static route into BGP, and as it is a VRF route BGP is responsible for generating/advertising the label.

You redis static into EIGRP but it won't go from EIGRP to BGP because neither criteria is met;

- redis from same source protocol as route is installed in RIB

- connected in RIB but referenced by network command

Try redis static under BGP and let us know if this fixes it

PS radius static behaves like a normal static in every way I can think of.. It goes away if the Vi comes down but that's about it.



CreatePlease to create content