Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

MPLS TE RSVP explicit problem

I have two routers connected in a lab via MPLS TE using RSVP. When i setup the tunnel to use explicit path-option

for example " tunnel mpls traffic-eng path-option 2 explicit identifier 2", the tunnel goes down and doesnt come up until i change it to use" tunnel mpls traffic-eng path-option 2 dynamic". Any ideas why this is not working?

R1

ip cef

mpls traffic-eng tunnels

interface Loopback0

ip address 150.1.1.1 255.255.255.255

!

interface Loopback1

description MPLS Traffic Eng

ip address 172.25.1.1 255.255.255.0

!

interface Tunnel0

ip unnumbered Loopback1

load-interval 30

tunnel destination 172.25.2.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng bandwidth 100

tunnel mpls traffic-eng path-option 1 dynamic

interface Serial1/0

ip address 192.168.1.1 255.255.255.0

mpls traffic-eng tunnels

serial restart-delay 0

ip rsvp bandwidth 100

router ospf 1

mpls traffic-eng router-id Loopback1

mpls traffic-eng area 0

router-id 150.1.1.1

log-adjacency-changes

network 150.1.1.1 0.0.0.0 area 0

network 172.25.1.0 0.0.0.255 area 0

network 172.25.80.1 0.0.0.0 area 0

network 192.168.1.0 0.0.0.255 area 0

network 192.168.2.0 0.0.0.255 area 0

!

R2

ip cef

mpls traffic-eng tunnels

interface Loopback0

ip address 150.2.2.2 255.255.255.255

!

interface Loopback1

description MPLS Traffic Eng

ip address 172.25.2.1 255.255.255.0

interface Tunnel0

ip unnumbered Loopback1

tunnel destination 172.25.1.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 2 2

tunnel mpls traffic-eng bandwidth 200

tunnel mpls traffic-eng path-option 2 dynamic

interface Serial1/1

ip address 192.168.1.2 255.255.255.0

ip ospf priority 0

mpls traffic-eng tunnels

serial restart-delay 0

ip rsvp bandwidth 200

router ospf 1

mpls traffic-eng router-id Loopback1

mpls traffic-eng area 0

router-id 150.2.2.2

log-adjacency-changes

network 150.2.2.2 0.0.0.0 area 0

network 172.25.2.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 0

3 REPLIES
Cisco Employee

Re: MPLS TE RSVP explicit problem

Franco,

The most obvious reason would be that the explicit path you are using is wrong.

Could you please post the explicit path option and a "show mpls traffic-eng tu " when the tunnel fails to come up.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: MPLS TE RSVP explicit problem

Hi

assuming this is what are tested:

interface Tunnel0

tunnel mpls traffic-eng path-option 1 dynamic

tunnel mpls traffic-eng path-option 2 explicit identifier 2

This configuration should correctly select the dynamic path. The path-option number could be called priority, with path-option 1 as 'best'

Re: MPLS TE RSVP explicit problem

Hi,

Could you post the "show ip explicit-paths" output. I couldn't locate the explicit path identifier 2 config from your running-config. May be you missed to configure the explicit path?

Sample config for R1:

Router(config)#ip explicit-path identifier 2

Router(cfg-ip-expl-path)#next-address 192.168.1.2

Explicit Path identifier 2:

1: next-address 192.168.1.2

Router(cfg-ip-expl-path)#do show ip exp

PATH 2 (strict source route, path complete, generation 3)

1: next-address 192.168.1.2

Router(cfg-ip-expl-path)#

Thanks,

Vijay

342
Views
0
Helpful
3
Replies
CreatePlease to create content