Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MPLS-TE Tunnel up/down

Hi,

 

Trying to build out an xconnect to follow a specific path (a longer path). I cannot get the tunnel to come up. I dont know what I missed. everything else looks ok. All interfaces are up and working, except the tunnel itself.

 

I've included the MPLS portion of the config, if I missed something let me know. I did enable the MPLS-TE in OSPF on the routers inbetween. I have connectivity inbetween. 

 

Router 1:

ip cef

mpls label protocol ldp
mpls traffic-eng tunnels

!

mpls label protocol ldp
mpls traffic-eng tunnels
!

pseudowire-class 5001
 encapsulation mpls
 preferred-path interface Tunnel5001

!

interface Loopback10
 ip address 10.201.1.4 255.255.255.255

!

interface Tunnel5001
 ip unnumbered Loopback10
 tunnel mode mpls traffic-eng
 tunnel destination 10.201.1.2
 tunnel mpls traffic-eng path-option 1 explicit name strict
 tunnel mpls traffic-eng path-selection metric te

!

interface FastEthernet2/0

 xconnect 10.201.1.2 5001 encapsulation mpls pw-class 5001

!

router ospf 100
 router-id 10.201.1.4

mpls traffic-eng router-id Loopback10
 mpls traffic-eng area 0

!

ip route 10.201.1.2 255.255.255.255 Tunnel5001
!
ip explicit-path name strict enable
 next-address 10.201.1.3
 next-address 10.201.1.1
 next-address 10.201.1.2

 

Router 2:

ip cef

mpls label protocol ldp
mpls traffic-eng tunnels

 

!

pseudowire-class 5001
 encapsulation mpls
 preferred-path interface Tunnel5001
!

interface Loopback10
 ip address 10.201.1.2 255.255.255.255
!
interface Tunnel5001
 ip unnumbered Loopback10
 tunnel mode mpls traffic-eng
 tunnel destination 10.201.1.4
 tunnel mpls traffic-eng path-option 1 explicit name strict
 tunnel mpls traffic-eng path-selection metric te

!

interface FastEthernet2/0
 xconnect 10.201.1.4 5001 encapsulation mpls pw-class 5001

!

router ospf 102
 router-id 10.201.1.2

 mpls traffic-eng router-id Loopback10
 mpls traffic-eng area 0

ip route 10.201.1.4 255.255.255.255 Tunnel5001
!
ip explicit-path name strict enable
 next-address 10.201.1.1
 next-address 10.201.1.3
 next-address 10.201.1.4

 

From router 1. Both Router 1 and Router 2 show the samething.

 show mpls l2transport vc detail
Local interface: Fa2/0 up, line protocol up, Ethernet up
  Destination address: 10.201.1.2, VC ID: 5001, VC status: up
    Output interface: Fa1/1, imposed label stack {22}
    Preferred path: Tunnel5001,  no route
    Default path: active
    Next hop: 192.168.102.13
  Create time: 00:10:13, last status change time: 00:10:13
    Last label FSM state change time: 00:10:13
  Signaling protocol: LDP, peer 10.201.1.2:0 up
    Targeted Hello: 10.201.1.4(LDP Id) -> 10.201.1.2, LDP is UP
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last BFD dataplane     status rcvd: Not sent
      Last BFD peer monitor  status rcvd: No fault
      Last local AC  circuit status rcvd: No fault
      Last local AC  circuit status sent: No fault
      Last local PW i/f circ status rcvd: No fault
      Last local LDP TLV     status sent: No fault
      Last remote LDP TLV    status rcvd: No fault
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 22, remote 22
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  Control Word: On (configured: autosense)
  Dataplane:
    SSM segment/switch IDs: 4101/4100 (used), PWID: 1
  VC statistics:
    transit packet totals: receive 0, send 0
    transit byte totals:   receive 0, send 0
    transit packet drops:  receive 0, seq error 0, send 0

 

show int tun 5001
Tunnel5001 is up, line protocol is down
  Hardware is Tunnel
  Interface is unnumbered. Using address of Loopback10 (10.201.1.4)
  MTU 17936 bytes, BW 100 Kbit/sec, DLY 50000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 10.201.1.4, destination 10.201.1.2
  Tunnel protocol/transport Label Switching
  Tunnel transmit bandwidth 8000 (kbps)
  Tunnel receive bandwidth 8000 (kbps)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:27:10
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

 

 

 

 

 

 

 

 

  • MPLS
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Hi, One issue what i can see

Hi,

 

One issue what i can see is, you have mentioned loopback ips in the explicit-path not the interface ip addresses. This can not be strict path and you have to mention next-address as loose (which means router will refer IGP to reach the next-hop)

 

ip explicit-path name strict enable
 next-address 10.201.1.1
 next-address 10.201.1.3
 next-address 10.201.1.4

 

Correct way

 

ip explicit-path name strict enable
 next-address loose 10.201.1.1
 next-address loose 10.201.1.3
 next-address loose 10.201.1.4

 

To troubleshoot TE

- first you can remove the explicit path and try to bring it up with dynamic path, which will help to confirm that configuration is ok on all routers in the path

- i hope you have configured "ip rsvp" on all physical intrfaces.

- If with dynamic path option also link does not come up, please share output of command "show mpls traffic-eng tunnels tunnel5001

 

--Pls dont forget to rate helpful posts--

Regards,

Akash

5 REPLIES
Cisco Employee

Hi, One issue what i can see

Hi,

 

One issue what i can see is, you have mentioned loopback ips in the explicit-path not the interface ip addresses. This can not be strict path and you have to mention next-address as loose (which means router will refer IGP to reach the next-hop)

 

ip explicit-path name strict enable
 next-address 10.201.1.1
 next-address 10.201.1.3
 next-address 10.201.1.4

 

Correct way

 

ip explicit-path name strict enable
 next-address loose 10.201.1.1
 next-address loose 10.201.1.3
 next-address loose 10.201.1.4

 

To troubleshoot TE

- first you can remove the explicit path and try to bring it up with dynamic path, which will help to confirm that configuration is ok on all routers in the path

- i hope you have configured "ip rsvp" on all physical intrfaces.

- If with dynamic path option also link does not come up, please share output of command "show mpls traffic-eng tunnels tunnel5001

 

--Pls dont forget to rate helpful posts--

Regards,

Akash

New Member

Interesting. I was wondering

Interesting. I was wondering how you assigned RSVP to the config... it was not in the cisco document I was following, not even one mention of it. I assume its 'ip rsvp sig hello' for something basic to get it running? Ill need to google that...

 

The strict hop using interfaces, makes sense, Ill give it a try and let you know how it goes.

 

thanks!

Cisco Employee

Hi, Below is example of basic

Hi,

 

Below is example of basic router configuration for TE with OSPF as IGP

 

http://www.cisco.com/c/en/us/support/docs/multiprotocol-label-switching-mpls/mpls/13731-mpls-te-ospf.html

 

 Router 1—MPLS Traffic Engineering Configuration

 ip cef
 mpls traffic-eng tunnels

 interface loopback 0
 ip address 11.11.11.11 255.255.255.255

 

 interface s1/0
 ip address 131.0.0.1 255.255.0.0
 mpls traffic-eng tunnels <<<
 ip rsvp bandwidth 1000
  <<<<


Router 1—OSPF Configuration

 router ospf 0
 network 10.0.0.0.255.255.255 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0

 

Regards,

Akash

New Member

I got it working this morning

I got it working this morning. The IP RSVP statements with the hello signaling needed to be set, and I had to add the mpls traffic-eng tunnel statement to all routers in the path.

Best testing it out, and it seems to work the way I need it to.

 

Thanks Akash!

Cisco Employee

 I am glad that issue is

 

I am glad that issue is fixed. Post is still showing as unanswered question. If this discussion is having solution for the query, marking it to answered will help others to refer this while facing same issue, second encourages me as well to continue providing support on this forum.  

428
Views
8
Helpful
5
Replies