Cisco Support Community


I have a PE-P-PE setup. I am able to receive routing and IP information pertaining to the MPLS VPN that I am trying to create. Inside the VPN, I cannot ping from PE subinterface to PE subinterface. Anybody have similar issues?


Re: MPLS VPN Issues

Can you highlight your setup a little more? Are you using

router bgp

address-family ipv4 vrf YourVRFname

redistribute connected

Can you post a "show ip route vrf YourVRFname"?

Are you sure a complete LSP exists between PE loopbacks? Can you post a "show ip cef " on the P?

Regards, Martin


Re: MPLS VPN Issues

Currently, due to constraints, I have to run the peer between loopbacks through a gre tunnel as one router sits in a different city (waiting on a provider to provision our point to point fiber connection between locations). Here is the bgp info on the remote PE:

router bgp

bgp router-id X.X.X.20

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor x.x.x.19 remote-as 19366

neighbor x.x.x.19 description [LSR]

neighbor x.x.x.19 update-source Loopback0

address-family ipv4 vrf test

redistribute connected

redistribute static

no auto-summary

no synchronization


Here is the sh ip route vrf test:

Gateway of last resort is not set is subnetted, 1 subnets

B [200/0] via x.x.x.19, 00:10:55 is subnetted, 1 subnets

C is directly connected, Loopback1

Here is the sh ip cef of the remote pe loopback:

X.X.X.19/32, version 30, epoch 0, cached adjacency X.X.X.218

0 packets, 0 bytes

tag information set

local tag: 36

via X.X.X.218, GigabitEthernet0/1, 0 dependencies

next hop X.X.X.218, GigabitEthernet0/1

valid cached adjacency

tag rewrite with Gi0/1, X.X.X.218, tags imposed: {}

Here is the show ip cef of the local pe loopback:

X.X.X.20/32, version 199, epoch 0, attached

0 packets, 0 bytes

tag information set

local tag: 139

via Tunnel0, 0 dependencies

valid adjacency

tag rewrite with Tu0, point2point, tags imposed: {}

Please let me know if there is anything else you need. Thanks.

Re: MPLS VPN Issues


there is no subinterface connected in VRF test. So I would assume you ping from Loopback1 ( ?

Also make sure the GRE tunnel passing the traffic is MPLS enabled:

interface Tunnel0

mpls ip


Hope this helps! Please rate all posts


Re: MPLS VPN Issues

I have mpls ip on both sides of the tunnel, but I am still not able to ping from loopback to subinterface. Do I need to put the tunnel interfaces in a vrf and do a vrf-in-vrf setup?

Re: MPLS VPN Issues

Hi Sean,

the tunnel - as far as I understand - provides PE-PE connectivity so there should be no need to take it into the VRF. Is routing enabled on the GRE tunnel? Make sure the tunnel destination is not learned through the tunnel, because this would lead to flapping.

Can you check PE-PE connectivity and verify that it takes the GRE tunnel and not any other path?

The show ip cef ... shows Tunnel0 for one loopback, but GigE for the other Loopack.

can you post sh mpls ldp discovery from all 3 routers involved?

Regards, Martin


Re: MPLS VPN Issues

Some key things for you to note in troubleshooting MPLS VPNs.

1. Is there reachability between the 2 loopback addresses of the 2 PEs. These are the loopbacks used for the iBGP session. Do an extended ping to ping the remote PE loopback address, sourcing from the local loopback address.

2. Is there an unbroken LSP between the 2 loopback address. Do a traceroute, and use show mpls for to verify that that the LSP is unbroken. The key thing to note is that the forwarding table should never show untagged for the loopback address.

3. Are the routes propagated and properly entered into the routing table? Check your import and export route-targets, as well as your redistribution between PE-CE protocol and MP-BGP.

Check those three, they are often the cause of the problem with MPLS VPN.

Community Member

Re: MPLS VPN Issues


This is really helpful to me too. Thanks a great deal.


Community Member

Re: MPLS VPN Issues

I notice your BGP config is missing 'send-community extended" which is needed for BGP to carry VPNv4 information.

CreatePlease to create content