Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPLS VPN QoS not working on 6509/SUP-720

Dear All,

I am using a 6509/SUP-720 and a 7507 as PE routers for a customer VPN.

The CEs are connected to each of the PEs are marking packets with DSCP bits.

On the PEs, I have output service policy to the CEs matching the DSCP bits.

On the 7507, I am being able to match packets from the 6509/SUP-720 with DSCP bits but

not on the 6509/SUP-720 from the 7507.

QoS is globally enabled on the 6509/SUP-720 and the CEs are certainly marking packets.

The 6509/SUP-720 is running 12.2 SXD7.

Is there anything else that I have to enable to get QoS to work on the 6509/SUP-720 ?

I would be really greatefull for any help or input on this.

Extract of my config:

6509/SUP-720

-------------

!

class-map match-all VOICE

match ip dscp ef

match protocol rtp

match mpls experimental topmost 5

class-map match-all ROUTING

match ip dscp cs6

match mpls experimental topmost 3

class-map match-all VOICE-SIGNALLING

match ip dscp af31

match ip dscp cs3

match mpls experimental topmost 4

!

policy-map FROM-PE-CE

class VOICE

priority percent 80

set dscp ef

class VOICE-SIGNALLING

bandwidth percent 10

class ROUTING

bandwidth percent 9

!

interface FastEthernet1/1

ip vrf forwarding via

ip address 15.16.19.34 255.255.255.252

speed 100

duplex full

mls qos trust dscp

max-reserved-bandwidth 100

service-policy output FROM-PE-CE

7507

-----

policy-map PE-TO-CE

class REALTIME

priority percent 50

class CRITICAL-DATA

bandwidth percent 20

random-detect dscp-based

class PREFERRED-DATA

bandwidth percent 15

random-detect dscp-based

class BULK-DATA

bandwidth percent 5

random-detect dscp-based

class class-default

bandwidth percent 10

random-detect

!

class-map match-any VOICE

match ip dscp 46

class-map match-all ROUTING

match ip dscp 48

class-map match-any CALL-SIGNALLING

match ip dscp 26

match ip dscp 24

Current configuration : 280 bytes

!

interface Serial0/0/0.1/2/3/1:0

ip vrf forwarding conn

ip address 192.168.2.157 255.255.255.252

no ip directed-broadcast

no fair-queue

service-policy output PE-TO-CE

Regards,

Zahid

1 ACCEPTED SOLUTION

Accepted Solutions

Re: MPLS VPN QoS not working on 6509/SUP-720

Hello,

your class config being match-ALL could cause the problem:

class-map match-all VOICE

match ip dscp ef

match protocol rtp

match mpls experimental topmost 5

This means the traffic matching has to have DSCP EF, is RTP and has a MPLS label with exp=5. As it is towards the CE I would assume there is no label present any more!? Can you replace the class by:

class-map match-all VOICE

match ip dscp ef

match protocol rtp

Or use match-any for testing purposes. This can be easily reconfigured by issuing:

Router(config)#class match-any VOICE

Router(config)#end

Hope this helps! Please rate all posts.

Regards, Martin

1 REPLY

Re: MPLS VPN QoS not working on 6509/SUP-720

Hello,

your class config being match-ALL could cause the problem:

class-map match-all VOICE

match ip dscp ef

match protocol rtp

match mpls experimental topmost 5

This means the traffic matching has to have DSCP EF, is RTP and has a MPLS label with exp=5. As it is towards the CE I would assume there is no label present any more!? Can you replace the class by:

class-map match-all VOICE

match ip dscp ef

match protocol rtp

Or use match-any for testing purposes. This can be easily reconfigured by issuing:

Router(config)#class match-any VOICE

Router(config)#end

Hope this helps! Please rate all posts.

Regards, Martin

245
Views
5
Helpful
1
Replies
CreatePlease to create content