Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPLS Vrf opsf interfaces not working

P/PE router VRF ospf interfaces unable to receive or advertised routing to and from CE router.

Config attahced.

Routes from PE VRF nortel shld be forwarded to CE router

So are routes from CE 50.50.50.0 network

Any ideas?

3 REPLIES

Re: MPLS Vrf opsf interfaces not working

Hello,

Looks to me as if you did not start the ospf process in the VRF. So adjust the config according to:

interface Serial2/0

description MPLS VRF 1:1 connection to Cisco 2611 PPP

ip vrf forwarding nortel

ip address 200.0.30.1 255.255.255.0

encapsulation ppp

clock rate 128000

interface FastEthernet4/0

description MPLS connection for vrf Nortel 1:1

ip vrf forwarding nortel

ip address 70.70.70.1 255.255.255.0

duplex auto

speed auto

no router ospf 1

router ospf 1 vrf nortel

network 200.0.30.0 0.0.0.255 area 0

network 70.70.70.1 0.0.0.0 area 0 !In case you want OSPF over this interface as well

With the current config I would assume that you do not see an OSPF adjacency on the CE.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: MPLS Vrf opsf interfaces not working

Hi Martin,

using OSPF VRF process has resolved the problem of loosing ospf adjacency, once applied "ip vrf forwarding".

Now, I am getting new problem, Lo0 of the PEs are no longer reachable, regradless the fact OSPF ajacency is established between the P-router to PE-routers and Lo0s are advertised by OSPF VRF process.

Please advise.

Thanks

Cisco Employee

Re: MPLS Vrf opsf interfaces not working

The PEs loopback interface should not belong to any particular VRF but to the global routing table. Can you please post your updated configurations.

Cheers,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
200
Views
0
Helpful
3
Replies
CreatePlease login to create content