Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multi-VRF CE

Hi,

I need to know whether we can use the Cisco 2610 router as Multi-VRF C.E. which will be connected to the Cisco 3745 P.E. router (existing) via 786K Serial Connections.

I need to configure two VRF's (IT & SOM)on the Cisco 2610 (Multi-VRF CE) and Cisco 3745 (P.E.) for the two VPNs.

Can someone please let me know whether this is a workable solutions?

Your help is very much appreciated.

Thanks,

7 REPLIES
Cisco Employee

Re: Multi-VRF CE

The 2610 certainly supports Multi-VRF. According to the Feature Navigator (http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp), you need a minimum of 12.2(4)T with the IP Plus feature set to support this feature.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Multi-VRF CE

Hi,

Thanks for the info.

This is what happened, I was able to configure the C2610 (Multi-VRF CE) with two VRFs pointing towards the C3745 (PE). The protocol between the PE and M-VRF CE is e-BGP. But unfortunately, adjacency between the Multi-VRF CE and PE routers has not been established for both VRFs. Im thinking, maybe this has something to do with the Serial Link because our bandwidth between the PE and Multi-VRF CE is 768K and also we are using the default encapsulation on the serial interface (i.e. HDLC).

I need to know what is the minimum bandwidth requirement between the PE and Multi-VRF CE in which we don't have T1/E1. Will it be possible to use HDLC or we have to change the encapsulation to Frame Relay in order to achieve this?

Can someone please advise me on this?

Your help is appreciated.

Thanks,

Re: Multi-VRF CE

Hi,

What is somewhat strange is your statement: "we are using the default encapsulation on the serial interface (i.e. HDLC)".

Multi-VRF is depending on two things. First the control plane is separated, i.e. you have one separate routing context per VRF. Second you need at least a separate interface per VRF. One interface can only belong to one VRF. You can check this with "sh ip vrf interface" or with "show ip route VRF ". If there is no output then your VRF has no interface and thus no BGP session can be established. In other words: a VRF is much like a separate router - unless it has an interface there will be no communication possible.

In your case Frame relay would be the natural choice. An example config with two VRFs could look like this:

ip vrf VRF1

rd 65000:1

ip vrf VRF2

rd 65000:2

interface Serial0/0

no ip address

encapsulation frame-relay

no keepalive

interface Serial0/0.100

ip vrf forwarding VRF1

ip address 10.1.1.1 255.255.255.252

frame-relay interface-dlci 100

interface Serial0/0.200

ip vrf forwarding VRF1

ip address 10.2.2.1 255.255.255.252

frame-relay interface-dlci 200

router bgp 65000

!

address-family ipv4 vrf VRF1

neighbor 10.1.1.2 remote-as 65100

no auto-summary

no synchronization

exit-address-family

!

address-family ipv4 vrf VRF2

neighbor 10.2.2.2 remote-as 65100

no auto-summary

no synchronization

exit-address-family

The IPs, interfaces, AS numbers, additional commands etc. need to be adjusted to your environment.

Hope this helps! Please use the rating system.

Regards, Martin

Re: Multi-VRF CE

Hi,

1) MPLS would be supported on all Layer 2 encapsulations like PPP,HDLC,FR etc untill the layer 2 encaps support IP addressing and CEF. So HDLC would not be a problem at all.

2) Neither is bandwidth a problem ever. Till you have IP reachbility thing will work fine. As long as the control protocols form adjacency and see each other.

What I suspect could the problem be is the BGP may not be having a router-id inherited or assigned form the global table.

Please confirm the same using this command "show ip bgp" on your CE. In this output you should see the router-id value which does not belong to any VRF. (i:e a Global Router-ID). If you dont have a value belonging to the Global Table your BGP wont come up.

HTH-Cheers,

Swaroop

New Member

Re: Multi-VRF CE

Hi,

Please find below the current config of the Multi-VRF CE.

Multi-VRF CE (C2610XM):

**********************

ip cef

!

ip vrf IT

rd 65500:1

!

ip vrf SOM

rd 65500:2

!

interface Serial0/0

description 768Kbps Link to PE

no ip address

no keepalive

!

interface Serial0/0.1

ip vrf forwarding SOM

ip address 10.10.1.1 255.255.255.252

!

interface Serial0/0.2

ip vrf forwarding IT

ip address 10.10.2.1 255.255.255.252

!

router bgp 65505

no synchronization

bgp log-neighbor-changes

redistribute connected

no auto-summary

!

address-family ipv4 vrf SOM

redistribute connected

redistribute static

neighbor 10.10.1.2 remote-as 65500

neighbor 10.10.1.2 activate

no auto-summary

no synchronization

exit-address-family

!

address-family ipv4 vrf IT

redistribute connected

redistribute static

neighbor 10.10.2.2 remote-as 65500

neighbor 10.10.2.2 activate

no auto-summary

no synchronization

exit-address-family

***************************

With regards to the router-id, shall I create a loopback interface on the M-VRF CE and advertise the loopback on the Global table? Because it is taking the highest IP of the M-VRF CE as router-id which is the Ethernet Interface.

When I checked the BGP neighbor status (VPN4) with "sh ip bgp v a s" from the PE, both the neighbors remained in Active State.

Your additional inputs are highly appreciated.

Thanks,

Re: Multi-VRF CE

Hi,

can you try frame-relay encapsulation, like in my example above? To my knowledge it will not work with HDLC subinterfaces. In addition configure a BGP router ID, f.e.:

router bgp 65505

bgp router-id 10.10.1.1

Then your config should be fine.

Regards, Martin

New Member

Re: Multi-VRF CE

hi,

I would like to inform you that this issue is finally resolved. i configured FR for both VRFs and it is working fine now. so, it is confirmed that M-VRF will work only with ATM and FR encapsulations.

thank you guys for all your support. this forum is very useful for us.

best regards,

523
Views
17
Helpful
7
Replies
CreatePlease login to create content