Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Multicast, MPLS, and iBGP peering

I had a multi-VRF Multicast configuration going using the following document for configuration:

http://www.cisco.com/en/US/technologies/tk648/tk828/tk363/technologies_white_paper0900aecd8012033f.html

I rebooted both routers that peered via iBGP after an IOS upgrade. The BGP peer would come up, LDP neighbor relationship would come up. As soon as that tunnel would come back up, all traffic would stop and the peer would disassociate. No traffic whatsoever would pass. Any recommendations?

5 REPLIES
Silver
Silver

Re: Multicast, MPLS, and iBGP peering

are u using the single bgp loopback for the updates for more than one. please paste the configuration

regards

shivlu

New Member

Re: Multicast, MPLS, and iBGP peering

Im working on a viewable version of the config. It's really huge. Im using multiple loopbacks for bgp peering on the vrf's, but using loop0 for the main bgp peer. Working on the config.

New Member

Re: Multicast, MPLS, and iBGP peering

Here is a brief version of the relevant info on one of the routers- they are both set up the same way:

version 12.4

!

ip vrf CustomerA

rd XXXXX:1

route-target export XXXXX:1001

route-target import XXXXX:1001

mdt default 239.255.255.1

!

ip vrf CustomerB

description VRF for CustomerB Pools

rd XXXXX:4

route-target export XXXXX:1004

route-target import XXXXX:1004

mdt default 239.255.255.2

!

ip multicast-routing distributed

ip multicast-routing vrf CustomerA distributed

ip multicast-routing vrf CustomerB distributed

ip multicast route-limit 200000 20000

ip multicast vrf CustomerA cache-headers

ip multicast vrf CustomerA route-limit 200000 20000

ip multicast vrf CustomerB cache-headers

ip multicast vrf CustomerB route-limit 200000 20000

!

!

interface Loopback0

ip address 10.255.0.8 255.255.255.255

ip pim sparse-dense-mode

!

interface Loopback1

ip vrf forwarding CustomerB

ip address 10.254.0.2 255.255.255.255

ip pim sparse-dense-mode

!

interface Loopback2

ip vrf forwarding CustomerA

ip address 10.253.0.1 255.255.255.255

ip pim sparse-dense-mode

!

interface Serial0/1/0/3:0

bandwidth 1536

ip vrf forwarding CustomerA

ip address 10.105.255.105 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

ip igmp static-group 239.194.0.0

load-interval 30

service-policy output cbwfq-voice20per

!

interface Serial5/0/0:2

bandwidth 1536

ip vrf forwarding CustomerB

ip address 192.168.251.5 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

ip igmp static-group 239.195.0.0

ip igmp static-group 239.195.1.0

load-interval 30

!

router bgp XXXXX

bgp log-neighbor-changes

neighbor 10.255.0.0 remote-as XXXXX

neighbor 10.255.0.0 update-source Loopback0

neighbor 10.255.0.7 remote-as XXXXX

neighbor 10.255.0.7 update-source Loopback0

neighbor 10.255.2.0 remote-as XXXXX

neighbor 10.255.2.0 update-source Loopback0

!

address-family ipv4

redistribute connected

redistribute static

redistribute ospf XXXXX match internal external 1 external 2

neighbor 10.255.0.0 activate

neighbor 10.255.0.0 soft-reconfiguration inbound

neighbor 10.255.0.7 activate

neighbor 10.255.0.7 soft-reconfiguration inbound

neighbor 10.255.2.0 activate

neighbor 10.255.2.0 soft-reconfiguration inbound

no auto-summary

no synchronization

network 10.255.0.8 mask 255.255.255.255

exit-address-family

!

address-family vpnv4

neighbor 10.255.0.0 activate

neighbor 10.255.0.0 send-community both

neighbor 10.255.0.0 next-hop-self

neighbor 10.255.0.7 activate

neighbor 10.255.0.7 send-community both

neighbor 10.255.0.7 next-hop-self

neighbor 10.255.2.0 activate

neighbor 10.255.2.0 send-community both

neighbor 10.255.2.0 next-hop-self

exit-address-family

!

address-family ipv4 vrf CustomerB

redistribute connected

redistribute static

neighbor 10.250.0.115 remote-as 65502

neighbor 10.250.0.115 disable-connected-check

neighbor 10.250.0.115 update-source Loopback1

neighbor 10.250.0.115 activate

neighbor 10.250.0.115 as-override

neighbor 10.250.0.115 soft-reconfiguration inbound

default-information originate

no synchronization

exit-address-family

!

address-family ipv4 vrf CustomerA

redistribute connected

redistribute static

neighbor 10.253.0.4 remote-as 65512

neighbor 10.253.0.4 disable-connected-check

neighbor 10.253.0.4 update-source Loopback2

neighbor 10.253.0.4 activate

neighbor 10.253.0.4 as-override

neighbor 10.253.0.4 soft-reconfiguration inbound

default-information originate

no synchronization

exit-address-family

!

ip pim bidir-enable

ip pim send-rp-announce Loopback0 scope 100

ip pim send-rp-discovery Loopback0 scope 100

ip pim ssm default

ip pim vrf CustomerA send-rp-announce Loopback2 scope 16

ip pim vrf CustomerA send-rp-discovery Loopback2 scope 16

ip pim vrf CustomerB send-rp-announce Loopback1 scope 16

ip pim vrf CustomerB send-rp-discovery Loopback1 scope 16

!

Silver

Re: Multicast, MPLS, and iBGP peering

i am not getting any improper configuration from your post. What i am thinking off that the problem with the RPF only. Please check the RPF is it succeeded or not.

Becaseu you r having one MP-BGP peering ; if u have more than one BGP peering in your cloud then the problem comes.

regards

shivlu

307
Views
0
Helpful
5
Replies
CreatePlease to create content