Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Multicast over MPLS, cpu = 99%

Hi,

I'm trying to send multicast video streams over my MPLS network (IP-VPN) and my remote router is a 2800. When remote users open three channels, the remote router cpu raise to 99%. My remote router is a cisco 2811 (C2800NM-ADVENTERPRISEK9-M, Version 12.3(11)T11).

I tried the same by night (no traffic at all except my streams) and it's the same. Can i tune my 2811 or it's just a smaller router for my needs ?

Here is part of my conf, the process sorted and the interface summary :

ip vrf Intra

rd 65000:50

route-target export 65000:50

route-target import 65000:50

mdt default 239.10.10.1

!

ip multicast-routing

ip multicast-routing vrf Intra

ip ips po max-events 100

mpls label protocol tdp

no ftp-server write-enable

!

interface Loopback0

ip address 10.0.0.10 255.255.255.255

ip pim sparse-dense-mode

!

interface FastEthernet0/0

description Lien vers QO

ip address 10.10.0.76 255.255.255.248

ip pim sparse-dense-mode

duplex auto

speed auto

tag-switching mtu 1508

tag-switching ip

!

interface FastEthernet0/1

ip vrf forwarding Intra

ip address 10.1.100.100 255.255.128.0

ip pim sparse-dense-mode

duplex full

speed 100

!

CPU utilization for five seconds: 99%/21%; one minute: 80%; five minutes: 49%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

83 470492 86784 5421 51.95% 41.36% 23.14% 0 IP Input

7 170452 32813 5194 25.89% 19.96% 10.06% 0 Pool Manager

208 232 1412 164 0.47% 0.13% 0.04% 322 Virtual Exec

63 168 6103 27 0.07% 0.01% 0.00% 0 BGP Router

130 272 135016 2 0.07% 0.02% 0.00% 0 RBSCP Background

5 0 1 0 0.00% 0.00% 0.00% 0 EDDRI_MAIN

6 8076 1375 5873 0.00% 0.06% 0.05% 0 Check heaps

4 68 519 131 0.00% 0.00% 0.00% 0 Tag Control

3 104 888 117 0.00% 0.01% 0.00% 0 OSPF Hello 1

10 0 1 0 0.00% 0.00% 0.00% 0 Crash writer

2 28 2717 10 0.00% 0.00% 0.00% 0 Load Meter

12 0 227 0 0.00% 0.00% 0.00% 0 IPC Dynamic Cach

1 0 3 0 0.00% 0.00% 0.00% 0 Chunk Manager

sh interfaces sum

*: interface is up

IHQ: pkts in input hold queue IQD: pkts dropped from input queue

OHQ: pkts in output hold queue OQD: pkts dropped from output queue

RXBS: rx rate (bits/sec) RXPS: rx rate (pkts/sec)

TXBS: tx rate (bits/sec) TXPS: tx rate (pkts/sec)

TRTL: throttle count

Interface IHQ IQD OHQ OQD RXBS RXPS TXBS TXPS TRTL

------------------------------------------------------------------------

* FastEthernet0/0 26 1755 0 0 20935000 2436 35000 34 707

* FastEthernet0/1 0 80 0 0 17722000 1655 20735000 2165 42

* Loopback0 0 0 0 0 0 0 0 0 0

* Tunnel0 3 0 0 0 3458000 328 0 0 0

NOTE:No separate counters are maintained for subinterfaces

Hence Details of subinterface are not shown

7 REPLIES

Re: Multicast over MPLS, cpu = 99%

Hi,

Can you attached the [show process cpu] output for the 99% router.

Regards,

pravin

Community Member

Re: Multicast over MPLS, cpu = 99%

Hi, You can find it above,

Regards

Re: Multicast over MPLS, cpu = 99%

Hi,

I have see it was looking for the full output.

Regards,

Pravin

Community Member

Re: Multicast over MPLS, cpu = 99%

Here we go

sh processes cpu sorted

CPU utilization for five seconds: 99%/14%; one minute: 52%; five minutes: 19%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

83 848696 253534 3347 56.50% 25.87% 6.73% 0 IP Input

7 321360 45268 7099 28.41% 12.44% 3.23% 0 Pool Manager

2 64 16869 3 0.07% 0.00% 0.00% 0 Load Meter

107 2776 97656 28 0.07% 0.01% 0.00% 0 CEF process

116 104 84311 1 0.07% 0.00% 0.00% 0 RUDPV1 Main Proc

213 1464 17845 82 0.07% 0.00% 0.00% 0 LDP

205 4276 102081 41 0.07% 0.02% 0.00% 0 IGMP Input

8 0 2 0 0.00% 0.00% 0.00% 0 Timers

9 0 1 0 0.00% 0.00% 0.00% 0 OIR Handler

10 0 1 0 0.00% 0.00% 0.00% 0 Crash writer

11 36 2813 12 0.00% 0.00% 0.00% 0 Environmental mo

12 0 1406 0 0.00% 0.00% 0.00% 0 IPC Dynamic Cach

13 0 1 0 0.00% 0.00% 0.00% 0 IPC Zone Manager

14 32 84309 0 0.00% 0.00% 0.00% 0 IPC Periodic Tim

15 68 84309 0 0.00% 0.00% 0.00% 0 IPC Deferred Por

16 0 1 0 0.00% 0.00% 0.00% 0 IPC Seat Manager

17 0 1 0 0.00% 0.00% 0.00% 0 IPC BackPressure

4 460 15674 29 0.00% 0.00% 0.00% 0 Tag Control

19 0 2 0 0.00% 0.00% 0.00% 0 ATM Idle Timer

20 0 2 0 0.00% 0.00% 0.00% 0 AAA high-capacit

21 0 1 0 0.00% 0.00% 0.00% 0 Policy Manager

22 0 2 0 0.00% 0.00% 0.00% 0 DDR Timers

23 4 2 2000 0.00% 0.00% 0.00% 0 Entity MIB API

24 48 20293 2 0.00% 0.00% 0.00% 0 HC Counter Timer

25 0 2 0 0.00% 0.00% 0.00% 0 Serial Backgroun

26 100 73222 1 0.00% 0.00% 0.00% 0 MPLS HC Counter

27 0 2 0 0.00% 0.00% 0.00% 0 SMART

28 56 84309 0 0.00% 0.00% 0.00% 0 GraphIt

6 66060 8562 7715 0.00% 0.05% 0.05% 0 Check heaps

18 5632 16353 344 0.00% 0.00% 0.00% 0 ARP Input

29 0 2 0 0.00% 0.00% 0.00% 0 Dialer event

32 0 1 0 0.00% 0.00% 0.00% 0 Critical Bkgnd

33 656 21123 31 0.00% 0.00% 0.00% 0 Net Background

34 0 78 0 0.00% 0.00% 0.00% 0 Logger

Community Member

Re: Multicast over MPLS, cpu = 99%

35 136 84305 1 0.00% 0.00% 0.00% 0 TTY Background

36 488 84326 5 0.00% 0.00% 0.00% 0 Per-Second Jobs

38 0 1 0 0.00% 0.00% 0.00% 0 Inode Table Dest

39 0 1 0 0.00% 0.00% 0.00% 0 AggMgr Process

40 0 1 0 0.00% 0.00% 0.00% 0 dev_device_inser

41 0 1 0 0.00% 0.00% 0.00% 0 dev_device_remov

42 0 1 0 0.00% 0.00% 0.00% 0 sal_dpc_process

43 0 1 0 0.00% 0.00% 0.00% 0 ARL Table Manage

44 0 2 0 0.00% 0.00% 0.00% 0 ESWPPM

45 0 2 0 0.00% 0.00% 0.00% 0 Eswilp Storm Con

46 0 2 0 0.00% 0.00% 0.00% 0 ESWILPPM

47 0 2 0 0.00% 0.00% 0.00% 0 Eswilp Storm Con

48 248 334386 0 0.00% 0.00% 0.00% 0 Netclock Backgro

49 0 2 0 0.00% 0.00% 0.00% 0 SM Monitor

50 28 14056 1 0.00% 0.00% 0.00% 0 mxt5100

51 0 2 0 0.00% 0.00% 0.00% 0 VNM DSPRM MAIN

52 0 1 0 0.00% 0.00% 0.00% 0 DSPFARM DSP READ

53 0 2 0 0.00% 0.00% 0.00% 0 FLEX DNLD MAIN

5 0 1 0 0.00% 0.00% 0.00% 0 EDDRI_MAIN

3 2888 33344 86 0.00% 0.00% 0.00% 0 OSPF Hello 1

30 0 1 0 0.00% 0.00% 0.00% 0 SERIAL A'detect

31 0 2 0 0.00% 0.00% 0.00% 0 XML Proxy Client

58 0 1 0 0.00% 0.00% 0.00% 0 IGMP Snooping Re

54 0 1 0 0.00% 0.00% 0.00% 0 HDV background

60 0 1 0 0.00% 0.00% 0.00% 0 AAL2CPS TIMER_CU

61 0 1 0 0.00% 0.00% 0.00% 0 CES Line Conditi

62 80 84308 0 0.00% 0.00% 0.00% 0 Crypto Device Up

63 504 153895 3 0.00% 0.00% 0.00% 0 BGP Router

64 0 2 0 0.00% 0.00% 0.00% 0 dot1x

65 0 2 0 0.00% 0.00% 0.00% 0 DTP Protocol

Re: Multicast over MPLS, cpu = 99%

Hi,

Just to confurm is ip cef enabled on the router.

Regards,

Pravin

Community Member

Re: Multicast over MPLS, cpu = 99%

Ip cef is enabled,

Regards

257
Views
0
Helpful
7
Replies
CreatePlease to create content