Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multicast routing and VRF-lite

I want to relay my multicast from one location to another location, we have an IP based network between these two locations having several routers in between them, so instead of enabling multicast routing on all the devices I have created a GRE tunnel between these two locations and the pim dense mode is enabled on GRE tunnel and it works fine. I am able to receive voice and video perfectly on the receivers end.

But now i want to keep my global routing and the multicast traffic seperate in new location and hence I have created a vrf-lite on the router and placed tunnel and local interface in this vrf, but after placing this in vrf, i am unable to receive voice and video on my receivers end.Kindly note i can see the source IP of multicast on my routers, this means no issue with multicast configuration. Do i have to add any other parameters when i am trying to run multicast in vrf-lite. Please help.

6 REPLIES
New Member

Re: Multicast routing and VRF-lite

To my uderstanding, as long as the VRF have the routes of your source and destination you should be able to do the multicast joings.

Try this to verify it is trying to go out over the GRE at the VRF:

sh ip rpf vrf

http://www.cisco.com/en/US/tech/tk828/technologies_white_paper0900aecd8012033f.shtml

New Member

Re: Multicast routing and VRF-lite

Reverse path forwarding is in place. By giving sh ip mroute vrf i can see the mroute for the source. I can join the multicast group from my device but i cant hear voice and see video from my device when the GRE tunnels are placed in VRF, and once I remove the tunnels from VRF I get voice and video. I am using pim-dense mode is that creating any issue coz i have seen few exapmles and they have given it by sparse-dense mode.

New Member

Re: Multicast routing and VRF-lite

The sparse-dense mode allows for the use of either sparse or dense in the same link.

Take a look to the Cisco IOS IP Multicast Configuration Guide

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00805a39cc.html

"An interface configured in sparse-dense mode is treated in either sparse mode or dense mode of operation, depending on the mode in which the multicast group operates. You must decide how to configure your interfaces."

Also, I understand there are some restriction on multicast over a VRF, specifically with the dense mode. Take a look to:

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00805a32b4.html#wp1044895

Have you tried with sparse mode?

Re: Multicast routing and VRF-lite

The PIM mode shouldnt matter for VRF lite.

Do cross verify the config agianst this doc.

You can omit the PE part config as in your case its not running across a MPLS domain.

http://www.cisco.com/en/US/tech/tk828/technologies_white_paper0900aecd8012033f.shtml

HTH-Cheers,

Swaroop

New Member

Re: Multicast routing and VRF-lite

Hello,

Please find the relevant configuration on recivers end router

ip vrf Multicast

rd 1:1

interface Tunnel101

ip vrf forwarding Multicast

ip address 10.254.11.134 255.255.255.252

ip pim dense-mode

tunnel source 10.254.2.3

tunnel destination 10.254.2.1

!

interface Loopback101

ip address 10.254.2.3 255.255.255.255

!

interface GigabitEthernet0/1

description LAN interface

ip vrf forwarding Multicast

ip address 10.100.34.51 255.255.255.0

ip pim dense-mode

!

The only difference in configuration is that the loopback is not assigned to vrf and multicast is not enabled.

Rest all the things are same, Actually loopback is a source address and its reachable with the global routing, only tunnel and local interface is assigned to VRF and multicast is enabled on it.

Please let me know if enabling the multicast on loopbacks will help, if yes then i will make the changes.

Re: Multicast routing and VRF-lite

You need to enable Mcast routing for the VRF in question. This is required for enabling multicast routing for the vrf apart from globally which i believe is already done.

You source and destination of the multicast leg need to be reachable in the VRF routing table and not the global routing table.

Verify this in the routing table of the vrf.

Looking at it from a overall perspective,rather than using the vrf lite, you can simply use a GRE tunnel between the end points to avoid enabling mcast all over the network. AS with the vrf lite you would be hairpinning global table into the vrf table to make it work.

HTH-Cheers,

Swaroop

3420
Views
0
Helpful
6
Replies
CreatePlease login to create content