Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicasting between VRF on same switch

Hello Everyone,

I am working on Multicast scenario, There is one 6513E switch one 2960 switch. Two VRF's are configured in core switch (6513) IPTV-SRV and Villa-VRF

IPTV-SRV vrf has IPTV server and Villa-VRF has IPTV i.e. client.

VLAN 30 is mapped to IPTV-SRV vrf with subnet address 192.168.30.0/24

VLAN 12 is mapped to Villa-VRF with subnet address 192.168.12.0/24

I did the following configuration for VRF but its not working . i am not an expert in multicast design but seems i did most of the configs.

Need help in this regards,

ip vrf IPTV-SRV

rd 30:1

mdt default 232.1.1.1

route-target export 30:1

route-target import 10:1

route-target import 11:1

route-target import 40:1

!

ip vrf Villa-VRF

rd 10:1

mdt default 232.1.1.2

route-target export 10:1

route-target import 200:1

route-target import 30:1

route-target import 40:1

route-target import 100:1

route-target import 70:1

ip multicast-routing

ip multicast-routing vrf Villa-VRF

ip multicast-routing vrf IPTV-SRV

interface Vlan12

description Villa-IPTV-VLAN

ip vrf forwarding Villa-VRF

ip address 192.168.12.1 255.255.255.0

ip helper-address 192.168.30.10

ip pim sparse-dense-mode

interface Vlan30

description IPTV-SRV-VLAN

ip vrf forwarding IPTV-SRV

ip address 192.168.30.1 255.255.255.0

ip pim sparse-dense-mode

router bgp 65000

bgp router-id 1.1.1.1

bgp log-neighbor-changes

  !

address-family ipv4 vrf IPTV-SRV

  redistribute connected

exit-address-family

address-family ipv4 vrf Villa-VRF

  redistribute connected

exit-address-family

ip pim snooping

ip pim vrf Villa-VRF rp-address 192.168.30.10

ip pim vrf IPTV-SRV rp-address 192.168.30.10 override

Everyone's tags (4)
7 REPLIES

Multicasting between VRF on same switch

Need some suggestions from multicast experts on the above configuration.

Thanks in Advance.

Fazal

Hall of Fame Super Gold

Multicasting between VRF on same switch

Duplicate post #1.

Multicasting between VRF on same switch

For quick response i put in both section. but atleast give some reply on any of the post.

Hall of Fame Super Gold

Multicasting between VRF on same switch

For quick response i put in both section.

1.  Making multiple posts of the same issue will NOT make responses faster.

2.  Nearly all the people who posts recommendations/solutions do NOT work for Cisco.  So we do so during our free time.

3.  Cisco employees also do so during their free time.

If you want a fast response, contact Cisco TAC.

Cisco Employee

Multicasting between VRF on same switch

Fazal,

Let me ask you - you have your sender in a different VRF than the recipient, and you still want to do cross-VRF multicast? Is there a particular reason why the sender must be in a different VRF?

I will try to replicate this config in our lab but I am not sure if I get this working. By the way, are the server and subscriber both directly connected to this multilayer switch? If not, is there any MPLS or tunneling involved?

Best regards,

Peter

New Member

Multicasting between VRF on same switch

I think what your missing is having the iBGP loopbacks (or the interface your using for iBGP peers) needs to be in sparse mode. And you need multicact enabled globaly on all PE rouers.

Your also missing Mullticast on the MPLS core. MPLS Multicast cast is two tiered. You need to configure Multicast on the backbone. Best practice is to us SSM. If your trying to enable multicast in the same group on different VRFs I don't think that will work ( but this should be verified). Here is a good Best Practice for Multicast on a MPLS network.

And you need to run it from PE-CE following standatd multicast deisgn rules.

!

!Here this should work for you (put it on all on the PEs)

!

!Define or enable the VRF for multicast

!

ip vrf your-vrf

mdt default 239.232.1.1

mdt data 232.1.1.0 0.0.0.255 threshold 64 (optional for high speed Data tree if used,.)

!

!Enable Multicast globalally on the PE

!

ip multicast-routing

ip multicast-routing vrf your-vrf

ip multicast your-vrf route-limit 1000 (optional for mroute limits)

ip multicast vrf your-vrf cache-headers (optional for optimization, if supported)

!

!Enable sparse mode on the iBGP peer address (here we are using loopbacks(this is very important)

!

interface Loopback0

ip pim sparse-mode

!

!

!All PE-PE interfaces go into PIM SPARSE mode

!

interface GigabitEthernet1/x

description PE-PE interface

mtu 9216

ip pim sparse-mode

!

!Enable PIM SSM mode on all PE routers

!

!

ip pim ssm default

!

!PE-CE interfaces use IP PIM SPARSE-DENSE-MODE

!

Interface x/y

IP PIM SPARSE-DENSE-MODE

Hope that helps....

~Karl

Cisco Employee

Multicasting between VRF on same switch

Fazal,

I think by now you might have found the solution. If not following is the solution.

- mVPN Extranet feature is the answer.

http://www.cisco.com/en/US/docs/ios/12_2sb/feature/guide/extvpnsb.html#wp1055322

- check the supported IOS).

http://www.cisco.com/en/US/docs/ios/12_2sb/feature/guide/extvpnsb.html#wp1053205

I have tested and found to be working

Inyour case following changes need to be done

If used option-1

-------------------------

ip mroute vrf Villa-VRF 255.255.255.255 fallback-lookup vrf IPTV-SRV

ip mroute vrf Villa-VRF 255.255.255.255 fallback-lookup vrf IPTV-SRV   <<<<

if used option-2 - Simpler

--------------------

ip multicast vrf Villa-VRF rpf select vrf IPTV-SRV group-list 1

access-list 1 permit  

Let me know if this helps

regards

Ashish

1357
Views
0
Helpful
7
Replies
CreatePlease to create content