Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multihoming Primary/Backup PE MPLS VPN

Hi there,

I kind of stuck of implementing and configuring Primary/Backup scenario for MPLS VPN enviroment.

Currently, only singe CE router connected to 2 PE router, Primary PE and Backup PE in the same POP.

PE-CE IGP is running OSPF. On CE router prespective, how do I achieve primary/backup scenario and on other remote PE, how does MPLS VPN cloud noticed that there is Primary and Backup PE towords this CE router?

Any configuration or sample out there? Appreciate for the help.

regards,

maher

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Multihoming Primary/Backup PE MPLS VPN

Hello Maher,

I would try to set the interface metric to a higher value for the backup PE. With OSPF->BGP redistribution you should then get a higher MED in BGP making the path less preferable. Example:

interface Serial0/0

description to primary PE

ip ospf cost 100

interface Serial0/1

description to backup PE

ip ospf cost 1000

Alternatively you could modify the MED while redistributiing into BGP:

router bgp 65000

address-family ipv4 vrf VRFname

redistribute ospf 123 vrf VRFname match internal external route-map OSPF2BGP

route-map OSPF2BGP permit 10

set metric 10000

Hope this helps! Please rate all posts.

Regards, Martin

1 REPLY

Re: Multihoming Primary/Backup PE MPLS VPN

Hello Maher,

I would try to set the interface metric to a higher value for the backup PE. With OSPF->BGP redistribution you should then get a higher MED in BGP making the path less preferable. Example:

interface Serial0/0

description to primary PE

ip ospf cost 100

interface Serial0/1

description to backup PE

ip ospf cost 1000

Alternatively you could modify the MED while redistributiing into BGP:

router bgp 65000

address-family ipv4 vrf VRFname

redistribute ospf 123 vrf VRFname match internal external route-map OSPF2BGP

route-map OSPF2BGP permit 10

set metric 10000

Hope this helps! Please rate all posts.

Regards, Martin

357
Views
0
Helpful
1
Replies
CreatePlease to create content