Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Native vlan query

(CE)--Trunk-port-via.wi-max-device--(PE-Switch)--Trunk port--(PE-Router)

In above scenario suppse CE router is unable to create sub-interface so to communicate with PE router I have used

switchport trunk native vlan 834 and it's working

But when I use

encapsulation dot1Q 834 native on router sub-interface it is not working

##########Working config#################

PE-Switch#

interface FastEthernet1/0/5

switchport trunk encapsulation dot1q

switchport trunk native vlan 834

switchport trunk allowed vlan 503,834

switchport mode trunk

speed 100

duplex full

PE-Router#

interface GigabitEthernet1/0/1.834

bandwidth 128

encapsulation dot1Q 834

ip vrf forwarding ABC

ip address 172.34.63.69 255.255.255.252

end

PE-Router#ping vrf ABC 172.34.63.70

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.34.63.70, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

##########Non-Working config#################

PE-Switch#

interface FastEthernet1/0/5

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 503,834

switchport mode trunk

speed 100

duplex full

PE-Router#

interface GigabitEthernet1/0/1.834

bandwidth 128

encapsulation dot1Q 834 native

ip vrf forwarding ABC

ip address 172.34.63.69 255.255.255.252

end

PE-Router#ping vrf ABC 172.34.63.70

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.34.63.70, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Thanks & Regards

Mahesh

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Native vlan query

Hi,

I'm confused with your configuration because the switchport trunk native vlan 834 command is gone in your non-working configuration.

Also is Fas1/0/5 connected to your CE or PE-Router.

Let's say Fas1/0/5 is connected to your CE and 1/0/6 to your PE-Router. A working configuration should be:

PE-Switch#

interface FastEthernet1/0/5

switchport trunk encapsulation dot1q

switchport trunk native vlan 834

switchport trunk allowed vlan 503,834

switchport mode trunk

speed 100

duplex full

!

interface FastEthernet1/0/6

switchport trunk encapsulation dot1q

switchport trunk native vlan 834

switchport trunk allowed vlan 503,834

switchport mode trunk

speed 100

duplex full

PE-Router#

interface GigabitEthernet1/0/1.834

bandwidth 128

encapsulation dot1Q 834 native

ip vrf forwarding ABC

ip address 172.34.63.69 255.255.255.252

end

Be sure your native VLAN is consistant on all your trunk or you could have traffic leaking between VLAN 1 (default native VLAN) and VLAN 834

HTH

Laurent.

2 REPLIES
Cisco Employee

Re: Native vlan query

Hi,

I'm confused with your configuration because the switchport trunk native vlan 834 command is gone in your non-working configuration.

Also is Fas1/0/5 connected to your CE or PE-Router.

Let's say Fas1/0/5 is connected to your CE and 1/0/6 to your PE-Router. A working configuration should be:

PE-Switch#

interface FastEthernet1/0/5

switchport trunk encapsulation dot1q

switchport trunk native vlan 834

switchport trunk allowed vlan 503,834

switchport mode trunk

speed 100

duplex full

!

interface FastEthernet1/0/6

switchport trunk encapsulation dot1q

switchport trunk native vlan 834

switchport trunk allowed vlan 503,834

switchport mode trunk

speed 100

duplex full

PE-Router#

interface GigabitEthernet1/0/1.834

bandwidth 128

encapsulation dot1Q 834 native

ip vrf forwarding ABC

ip address 172.34.63.69 255.255.255.252

end

Be sure your native VLAN is consistant on all your trunk or you could have traffic leaking between VLAN 1 (default native VLAN) and VLAN 834

HTH

Laurent.

New Member

Re: Native vlan query

OK,

Means this is OK for testing purpose. but we should not give this solution to customer. reason is I will be able to define only one vlan as native vlan on one port

anyway man thanks a lot for your valuable time

--Mahesh

170
Views
0
Helpful
2
Replies