Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Not able to reach to Router

In my network I can see ip route to particular destination but not able to ping

Pl. guide

Router#sh ip route vrf ABCD x.x.x.x

outing entry for x.x.x.0/24

Known via "bgp 9730", distance 200, metric 0, type internal

Last update from y.y.y.y 1w2d ago

Routing Descriptor Blocks:

* y.y.y.y (Default-IP-Routing-Table), from y.y.y.194, 1w2d ago

Route metric is 0, traffic share count is 1

AS Hops 0

Router#ping vrf ABCD ip x.x.x.x

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to x.x.x.x, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Regards

Mahesh

20 REPLIES

Re: Not able to reach to Router

Hi,

Pls check two things

1.In the remote PE , see wheter you are able to learn the route of the VRF ABCD connected interface of the router from where you ping . ( Check under your address family ipv4 vrf ABCD , wheter redistribute connected given )

2.If the destination is customer end , check wheter you are learning the route of the connected interface .

If both are fine , check wheter labels are exchanged properly at both sides

Hope this helps

regards

vanesh k

New Member

Re: Not able to reach to Router

See

the router from which I ping is not directly connected with the device I ping..

My Router--ds3 link---->another router---E1 link (172.30.101.58/30)--> router I ping (It is Customer end)

And from My router I am doing ping to 172.30.101.58.

this is the scenario

if need more information kindly tell me

Kindly guide

Regards

Mahesh

Re: Not able to reach to Router

Hi,

To make it clear ,

In " my router " , you will have a vrf ABCD enabled interface right , Pls check wheter that connected interface route is learned in "another router " , bcause a vrf ping would take , the connected ip of "my router " as source . Similary check for the routing in the CE also for the connected interface ip of " my router "

Hope this helps

regards

vanesh k

New Member

Re: Not able to reach to Router

see,

from my router i can telnet to another router and from that router i am able to telnet to CE .. But from my router i am not able to reach to CE.

------------------------------------------

My router Config:

ip vrf ABCD

rd 9730:85

route-target export 9730:51

route-target export 9730:92

route-target import 9730:52

route-target import 9730:53

route-target import 9730:92

address-family ipv4 vrf ABCD

redistribute connected

redistribute static

no auto-summary

no synchronization

exit-address-family

---------------------------------------------

Another router config:

ip vrf ABCD

rd 9730:85

route-target export 9730:51

route-target export 9730:92

route-target import 9730:52

route-target import 9730:53

route-target import 9730:92

address-family ipv4 vrf ABCD

redistribute connected

redistribute static

no auto-summary

no synchronization

exit-address-family

and there is no any static route defined in any of two router.

Pl. guide

Mahesh

New Member

Re: Not able to reach to Router

Dear Vanesh,

TEll me one thing if a vrf is configure in two router ..and both have identical configuration regarding to that VRF. what else is needed to reach to CE (which is connected to another router) from my router

I think i am missing something in config that's why not able to locate the problem

Hope this will useful to u to solve my problem

Mahesh

New Member

Re: Not able to reach to Router

Mahesh,

are you sure you don't need:

ping vrf ABCD 'CE' source 'one of your ABCD i/f'

??

it should work if you specify source since this is vrf-specific ping.

New Member

Re: Not able to reach to Router

Hi Mahesh,

Can you confirm that in ur core mpls ip propagate-ttl is configured or not

Cheers 1

New Member

Re: Not able to reach to Router

It is by default enabled and it is in our compan's policy to keep it as default

regards

Mahesh

Re: Not able to reach to Router

Hi,

Pls check

1.Whether from "another router " you are able to ping the ip

2.If you are able to ping , check wheter the customer is having default route or some specific routes

3.If default route , then need to check in terms of labels , if static route then check wheter the connected route of "my router " is added at cpe end .

regards

vanesh k

New Member

Re: Not able to reach to Router

--Ya from another router i am able to ping

-- customer is able to learn route to another router via OSPF

CE: Routing entry for 172.30.6.0/24

Known via "ospf 100", distance 110, metric 20, type extern 2, forward metric 150

Regards!!

Re: Not able to reach to Router

Hi ,

What abt the route for /30 connected ip of "my router " vrf ABCD interface

regards

vanesh k

New Member

Re: Not able to reach to Router

Dear vanesh,

Now it is clear I am attaching one file for diagram.

Look at that and problem is there

Pl. suggest me necessary config

Regards!!

Re: Not able to reach to Router

Hi

Its simple , I think you are running OSPF between your PE and CE . Do a redistribution of the BGP routes in the ABCD VRF into OSPF

configured for the customer .

It would make the customer routers to learn the routes

Router1(config)# router ospf 2 vrf v1

Router1(config-if)# log-adjacency-changes

Router1(config-if)# redistribute bgp 1 subnets

Hope this helps

regards

vanesh k

New Member

Re: Not able to reach to Router

isn't there any other way instead of configuring sham links?

where should i configure on CE or PE..B'se on PE I have no config related to OSPF.

Regards!!

Re: Not able to reach to Router

Hi mahesh,

Pls donot get confused with sham link , I thouhgt that Router B and CE1 are running OSPF , so I said to redistribute the connected route learned from A via BGP into OSPF .

Pls let me know how B and CE1 route exchange happens. ( Static or any routing protocol )

regards

vanesh k

New Member

Re: Not able to reach to Router

Dear,

CE2# sh ip route 172.30.6.1

Routing entry for 172.30.6.0/24

Known via "ospf 100", distance 110, metric 20, type extern 2, forward metric 150

Last update from 172.30.103.2 on Serial0/2:0, 00:56:38 ago

Routing Descriptor Blocks:

* 172.30.103.2, from 172.30.170.73, 00:56:38 ago, via Serial0/2:0

Route metric is 20, traffic share count is 1

But why no OSPF configured in any of PE's.

Regards!!

Re: Not able to reach to Router

Hi,

From the routing info , the CE1 and CE2 are ruuning OSPF and since 172,30,6.0/24 is a connected interface in CE1 , so its getting redistributed to CE2 as E2 route .

Either CE1 should have a default route pointing to your PE router or a static route for "My router " subnet to the PE router or should run a routing protocol to work.

Pls check and do as per the requirement.

Hope this helps

regards

vanesh k

New Member

Re: Not able to reach to Router

Hi Mahesh,

can you do the VRF trace and check if stucks somewhere ?

Cheers.

New Member

Re: Not able to reach to Router

Mahesh

Just as Vanesh has mentioned the reverse route to the ping source (172.30.3.1/30 router A vrf ABCD interface ) is missing in the CE2. Please put a trace to ip 172.30.3.1/30 from the CE2, to find out where the route is specifically needed.

New Member

Re: Not able to reach to Router

Dear all,

thanks for your valuable input..

Now i can't test any more commands on CE Router ..B'se customer is getting the routes they needed ..But I am not getting b'se it is not in customer's interests.

anyway really very thanks for your support.

I hope in future also i will be given good support to solve problems

Regards

Mahesh

220
Views
4
Helpful
20
Replies
CreatePlease login to create content