Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

OSPF in VRF with same area ID

Hello all,

On an MPLS/VPN PE router, I have configured OSPF as the PE/CE routing protocol.

I configured several OSPF processes (one for each VRF).

But if I have several customers who are using the same OSPF area ID on the CE side, may I configure the same area ID for several OSPF processes on the PE side ? Of course, all of those areas are independent and I don't want to see customer1's routes into the OSPF of customer2 !

In the following example, I have 2 customers. Each customer has got 2 sites and has an OSPF backbone area which is spread accross his 2 sites. For each customer, I want to interconnect his 2 sites and extend OSPF backbone area across MPLS.

The OSPF backbone area of customer1 is different from the one of customer2, even if the ID is the same...

Here is a sample of the PE's configuration :

interface G0/1

ip vrf forwarding customer1

ip address 10.1.1.1 255.255.255.0

!

interface G0/2

ip vrf forwarding customer2

ip address 10.1.2.1 255.255.255.0

!

!

router ospf 1 vrf customer1

network 10.1.1.0 0.0.0.255 area 0

!

router ospf 2 vrf customer2

network 10.1.2.0 0.0.0.255 area 0

Won't I experience problems if I use the same area ID there ?

Thanks for your help !

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: OSPF in VRF with same area ID

Hello Sam,

You won't face any problem because you have configured cust1 and cust2 under vrf instance within ospf.There will not be any

mixing of routes between cust1 and cust2.

In addition to that also configure domain-id (a /32 unique ip address) under ospf process for each customer. The reason if you configure ospf process

id 1 for cust1 at A-End and if you configure process id 2 for same customer on B-end the routes propogated from A-end will be seen as

inter-area at B-end

router ospf 1 vrf customer1

ospf domain-id 1.1.1.1 >>> keep this same for this vrf at every site

network 10.1.1.0 0.0.0.255 area 0

Hope this is helpful

Regards

Mahesh

4 REPLIES

Re: OSPF in VRF with same area ID

Hello Sam,

You won't face any problem because you have configured cust1 and cust2 under vrf instance within ospf.There will not be any

mixing of routes between cust1 and cust2.

In addition to that also configure domain-id (a /32 unique ip address) under ospf process for each customer. The reason if you configure ospf process

id 1 for cust1 at A-End and if you configure process id 2 for same customer on B-end the routes propogated from A-end will be seen as

inter-area at B-end

router ospf 1 vrf customer1

ospf domain-id 1.1.1.1 >>> keep this same for this vrf at every site

network 10.1.1.0 0.0.0.255 area 0

Hope this is helpful

Regards

Mahesh

New Member

Re: OSPF in VRF with same area ID

Mahesh you said this :

"[...] In addition to that also configure domain-id (a /32 unique ip address) under ospf process for each customer. The reason if you configure ospf process id 1 for cust1 at A-End and if you configure process id 2 for same customer on B-end the routes propogated from A-end will be seen as inter-area at B-end [...]"

I guess you mean :

  • If OSPF domain-id is not the same on PE at both ends, the routes will be exported within type-5 external LSA at B-end
  • If OSPF domain-id matches on PE at both ends, the routes will be exported within type-3 inter-area LSA at B-end.

Thanks.

Re: OSPF in VRF with same area ID

Hi Sam

For more detail You can refer the document that i had shared . below is the link .

Here you will get clear picture of OSPF with Domain ID & Process ID.

OSPF with unique process = O IA (OSPF Route)

OSPF with different process = O E2 (OSPF Route)

OSPF with unique Process ID but different domain ID = O E2 (OSPF Route)

OSPF with different process ID but unique domain ID = O IA (OSPF Route)

https://learningnetwork.cisco.com/docs/DOC-8648

Regards

Chetan Kumar

http://chetanress.blogspot.com

Silver

Re: OSPF in VRF with same area ID

Yes you are right you can use; for every customer you can use the same area; this is the main advantage of using MPLS. For domain id you can check the post which tells about to use the domain-id for receiving routes from same customer. By default domain-id is changed for every vrf per PE and you receive one CPE routes to another CPE routes of same vpn as external routes. Please check my post for domain-id:-

http://www.mplsvpn.info/2008/11/why-ospf-vpnv4-routes-look-as-external_07.html

regards

Shivlu Jain

18247
Views
15
Helpful
4
Replies
CreatePlease to create content