Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF Routes are in the OSPF Database but not in the Routing Table

Dear Members,

i have a problem with redistributing OSPF routes in my MPLS VPN. My local routes are redistributed into the MPLS VPN which is running BGP. This is the configuration of the edge router.

!

hostname CU_EDGE01

!

ip vrf CU_A

rd 100:26

route-target export 100:26

route-target import 100:26

!

interface Loopback0

ip address 1.1.1.252 255.255.255.255

ip router isis

!

interface FastEthernet0/0

description LINK TO Customer Router 01 FA0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.26

encapsulation dot1Q 26

ip vrf forwarding CU_A

ip address 172.16.2.5 255.255.255.252

!

interface FastEthernet0/1

description LINK TO P_ROUTER_FA0/0

ip address 1.1.1.2 255.255.255.252

ip router isis

speed 100

full-duplex

mpls ip

!

router ospf 100 vrf CU_A

log-adjacency-changes

redistribute bgp 100 metric 20 subnets

network 172.16.2.4 0.0.0.3 area 0

!

router isis

net 41.0000.0000.0004.00

is-type level-1

!

router bgp 100

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 1.1.1.251 remote-as 100

neighbor 1.1.1.251 update-source Loopback0

!

address-family ipv4

neighbor 1.1.1.251 activate

no auto-summary

no synchronization

exit-address-family

!

address-family vpnv4

neighbor 1.1.1.251 activate

neighbor 1.1.1.251 send-community both

exit-address-family

!

address-family ipv4 vrf CU_A

redistribute ospf 100 vrf CU_A match internal external 1 external 2

no synchronization

exit-address-family

the routes are redistributed in the BGP process as desired. See the output.

CU_EDGE01#show ip bgp vpnv4 all
BGP table version is 9, local router ID is 1.1.1.252
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:26 (default for vrf CU_A)
*>i10.2.2.0/24      1.1.1.251               11    100      0 ?
*> 10.3.0.1/32      172.16.2.6               2         32768 ?
*> 172.16.2.4/30    0.0.0.0                  0         32768 ?
*>i172.16.20.4/30   1.1.1.251                0    100      0 ?
CU_EDGE01#

Also in the OSPF Database i can see the routes.

CU_EDGE01#show ip ospf database

            OSPF Router with ID (172.16.2.5) (Process ID 100)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
172.16.2.5      172.16.2.5      30          0x80000002 0x007AA4 1
172.16.2.6      172.16.2.6      31          0x80000002 0x0072AB 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.2.6      172.16.2.6      31          0x80000001 0x000526

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.2.2.0        172.16.2.5      17          0x80000001 0x005B7B
10.3.0.1        172.16.2.6      66          0x80000001 0x001E4B
172.16.20.4     172.16.2.5      17          0x80000001 0x006FA3

The route from the far end is the 10.2.2.0/24. The down bit is also set.


CU_EDGE01#show ip ospf database summary 10.2.2.0

            OSPF Router with ID (172.16.2.5) (Process ID 100)

                Summary Net Link States (Area 0)

  LS age: 134
  Options: (No TOS-capability, DC, Downward)
  LS Type: Summary Links(Network)
  Link State ID: 10.2.2.0 (summary Network Number)
  Advertising Router: 172.16.2.5
  LS Seq Number: 80000001
  Checksum: 0x5B7B
  Length: 28
  Network Mask: /24
        TOS: 0  Metric: 20

in the routing table of the vrf CU_A i see the routes. My qestion here is, why the route to 10.2.20/24 is a BGP route and not a OSPF route?

CU_EDGE01#show ip route vrf CU_A

Routing Table: CU_A
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
B       172.16.20.4 [200/0] via 1.1.1.251, 00:02:57
C       172.16.2.4 is directly connected, FastEthernet0/0.26
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O IA    10.3.0.1/32 [110/2] via 172.16.2.6, 00:03:05, FastEthernet0/0.26
B       10.2.2.0/24 [200/11] via 1.1.1.251, 00:02:57
CU_EDGE01#

on the local router the routes are also in the OSPF Database

CU_RT1#show ip ospf database

            OSPF Router with ID (172.16.2.6) (Process ID 100)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
172.16.2.5      172.16.2.5      258         0x80000002 0x007AA4 1
172.16.2.6      172.16.2.6      258         0x80000002 0x0072AB 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.2.6      172.16.2.6      258         0x80000001 0x000526

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.2.2.0        172.16.2.5      245         0x80000001 0x005B7B
10.3.0.1        172.16.2.6      293         0x80000001 0x001E4B
172.16.20.4     172.16.2.5      245         0x80000001 0x006FA3

                Router Link States (Area 10)

Link ID         ADV Router      Age         Seq#       Checksum Link count
172.16.2.6      172.16.2.6      298         0x80000001 0x00C9CF 1

                Summary Net Link States (Area 10)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.2.4      172.16.2.6      301         0x80000001 0x00F8BE

                Summary ASB Link States (Area 10)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.2.5      172.16.2.6      261         0x80000001 0x00F2BF
CU_RT1#

but on the routing table for the vrf CU_A i cannot see the route to 10.2.2.0/24

CU_RT1#show ip route vrf CU_A

Routing Table: CU_A
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.2.4 is directly connected, FastEthernet0/0.26
     10.0.0.0/16 is subnetted, 1 subnets
C       10.3.0.0 is directly connected, Loopback103
CU_RT1#

Does anybody has an explaination for the missing OSPF routes?

Thank you very much in advanced

Alex

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: OSPF Routes are in the OSPF Database but not in the Routing

Hi Alex,

The prefix with down bit set will not be put in RIB. This is done by default to prevent loop. Did you have 'capability vrf-lite' configured on CE? You need this command on CE to receive a LSA with down bit, when using multi-vrf.

http://www.cisco.com/en/US/docs/ios/12_0st/12_0st21/feature/guide/ospfvrfl.html#wp1039220

HTH,

Lei Tian

1 REPLY
Cisco Employee

Re: OSPF Routes are in the OSPF Database but not in the Routing

Hi Alex,

The prefix with down bit set will not be put in RIB. This is done by default to prevent loop. Did you have 'capability vrf-lite' configured on CE? You need this command on CE to receive a LSA with down bit, when using multi-vrf.

http://www.cisco.com/en/US/docs/ios/12_0st/12_0st21/feature/guide/ospfvrfl.html#wp1039220

HTH,

Lei Tian

3315
Views
0
Helpful
1
Replies