Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Personal MPLS Lab - Why I can't ping to remote branch loopback interface?

Hi Everyone,

Please advise me why I can't ping the loopback interface of B1 from B2 and I did get the routes from the MPLS cloud. Do refer to the attachment for network diagram and output dump.

I had tried troubleshooting it but to no avail.

Please help me.

Thanks a lot!

Regards,

Ron

  • MPLS
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Personal MPLS Lab - Why I can't ping to remote branch loopba

Your topology and configs look fine.

Going thro your o/p this looks like a typical Label Protocol mismatch.

Your P2 apparently seems to be running TDP and your PE2 is running MPLS/LDP.

Try changing this interface on PE2-R6,

!

interface Serial0/0/0

ip address 192.168.1.17 255.255.255.252

mpls ip

mpls label protocol both

<>

no fair-queue

clock rate 64000

!

HTH-Cheers,

Swaroop

5 REPLIES
New Member

Re: Personal MPLS Lab - Why I can't ping to remote branch loopba

Hi Ron,

I am going through the logs provided. In the meanwhile use the "traceroute vrf command to identify issues in improper label assignment.

Pesaro# traceroute vrf Customer_B 200.0.4.1

Type escape sequence to abort.

Tracing the route to 200.0.4.1

1 10.1.1.21 [MPLS: Labels 25/28 Exp 0] 464 msec 280 msec 308 msec

2 10.1.1.5 [MPLS: Labels 22/28 Exp 0] 236 msec 572 msec 228 msec

3 200.0.4.1 108 msec * 100 msec

Regards,

Pankaj

New Member

Re: Personal MPLS Lab - Why I can't ping to remote branch loopba

Ron,

there appears to be a problem with the label assignment and distribution. Check the status of mpls neighbor relationship (show tag-switching tdp neighbor).

Alternatively, redo the lab with OSPF single area and observe the results.

Regards,

Pankaj

Re: Personal MPLS Lab - Why I can't ping to remote branch loopba

Your topology and configs look fine.

Going thro your o/p this looks like a typical Label Protocol mismatch.

Your P2 apparently seems to be running TDP and your PE2 is running MPLS/LDP.

Try changing this interface on PE2-R6,

!

interface Serial0/0/0

ip address 192.168.1.17 255.255.255.252

mpls ip

mpls label protocol both

<>

no fair-queue

clock rate 64000

!

HTH-Cheers,

Swaroop

New Member

Re: Personal MPLS Lab - Why I can't ping to remote branch loopba

Hi Swaroop,

You are right! I made a mistake on the tdp and ldp.

By the way, is this command "tag-switching ip" not supported in IOS 12.4(9)T1?

Thanks again!

Regards,

Ron

Re: Personal MPLS Lab - Why I can't ping to remote branch loopba

I believe its already obsoleted and replaced with the command "mpls ip" using LDP.

So you can keep using "mpls ip" across and create cross compatibility using the "mpls label protocol both" with older versions which may be apparently running TDP only.

HTH-Cheers,

Swaroop.

182
Views
4
Helpful
5
Replies
This widget could not be displayed.