Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

problem in mVPN setup

Hi,

I am just setting up lab for mVPN to start with PIM-SM Default MDT using Anycast RP on Core.

I have two CR (CR1 and CR2) and 3 PE ( 7600, 7200,12k).

Each PE connected to both CR through layer 2 switch and each CR is connected to each other.

I have both CR runnning MSDP.

Now I configure say mVPN-A ( 239.192.1.1) Default MDT on each PE and what i see is :

1. show ip pim mdt shows Tunnel0 and it is up

2. show ip pim nei -each PE has PIM-Neighbour with both CR

3. show ip pim vrf mVPN-A neighbour on 7600 and 7200 shows 2 neighbour ( one 7600, 12K) for 7200 and 7600 and 12K for 7200.

4. but 12K doesn't show any neighbour under mVPN-A.

5. show ip mroute shows all (S,G) for each PE on 12K.

Can some one suggest me further troubleshooting ?

Thanks,

Chintan

12 REPLIES
Cisco Employee

Re: problem in mVPN setup

Hi Chintan,

It means the 12k has issue to received multicast traffic from the other PEs but the other PEs can receive traffic from the 12k.

I would suggest you to choose one PE (7200 or 7600) and see why the 12k is not receiving multicast traffic from this source.

If there is a (S,G) entry on the 12k, you need to follow the tree up to the source to see if it is not broken somewhere.

One more thing is to try to make it work without MSDP (all PEs point to the same physical RP) to see if it's not the root cause of your issue.

HTH

Laurent.

New Member

Re: problem in mVPN setup

Hi Laurent,

Thanks for the clue , I tried something more here.

I configured one loopback on 12K with MDT Default Group ( 239.192.1.1) static join on that interface to see core Multicast works fine.

Then after, I pinged 239.192.1.1 from 7600 and 7200 and I got replied and then after i also seen 7200 and 7600 as PIM neighbour on MTI ( on VRF).

To verify again, I just shut the loopback ( where 239.192.1.1 is joined statically ) and after expiry period i have both PIM neighbour go down Over MTI back

*Jun 7 10:32:37.412 UTC: %PIM-5-NBRCHG: VRF mVPN-A: neighbor 10.74.90.6 DOWN on interface Tunnel2 non DRshow ip pim vrf mVPN-A neighbor

*Jun 7 10:32:45.412 UTC: %PIM-5-NBRCHG: VRF mVPN-A: neighbor 10.74.90.5 DOWN on interface Tunnel2 non DR

I will try to see with single RP ( without MSDP) and update you on the result.

Meanwhile, Any clue from above behaviour ?

Regards,

Chitnan

New Member

Re: problem in mVPN setup

In fact, running single RP (without MSDP) still have same issue no luck.

Cisco Employee

Re: problem in mVPN setup

Hi Chintan,

What IOS version do you run on the GSR? Could you also just paste the BGP configuration from the GSR.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: problem in mVPN setup

Hi Hritter,

IOS : 12.2(32)SY3

Here is Configuration under VPNV4 for MP-BGP with RR(VPNv4)

address-family vpnv4

neighbor VPNV4-VRR activate

neighbor VPNV4-VRR send-community both

neighbor 10.74.90.9 peer-group VPNV4-VRR

exit-address-family

!

Peer-group VPNV4-VRR is already defined in global.

show ip bgp vpnv4 all

BGP table version is 32, local router ID is 10.74.90.7

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

Route Distinguisher: 8220:1

*>i10.10.40.0/24 10.74.90.6 0 100 0 ?

Route Distinguisher: 8220:2 (default for vrf mVPN-A)

*>i10.10.10.0/30 10.74.90.5 0 100 0 ?

*> 10.10.20.0/24 0.0.0.0 0 32768 ?

*>i10.10.30.0/24 10.74.90.5 0 100 0 ?

*>i10.10.40.0/24 10.74.90.6 0 100 0 ?

Route Distinguisher: 8220:3

*>i10.10.10.0/30 10.74.90.5 0 100 0 ?

*>i10.10.30.0/24 10.74.90.5 0 100 0 ?

10.74.90.5 and 6 are 7200 and 7600 loopback.

Let me know if you need any other info.

REgards,

Chintan

Cisco Employee

Re: problem in mVPN setup

Hi Chintan,

From what you said, it seems the GSR is not joining the shared tree for this mdt group except if you configure an explicit join.Looks like a bug.

You could give a try to a more recent release like SY8.

Could you also check any difference in the mRIB (sh ip mroute) when the explicit join is configured and when it's not ?

Thanks

Laurent.

New Member

Re: problem in mVPN setup

Hi Laurent,

I don't see any significant difference in (show ip mroute) in any case.

Here I have attached the log :

10.74.90.7 - 12K, 10.74.90.6 : 7600, 10.74.90.5 -7200.

Regards,

Chintan

New Member

Re: problem in mVPN setup

Hi Guys,

Finally I got issue resolved and it is kind of Bug ( not published to outside) that 12K needs PIM Neighbourship with CPE to bring PIM Neighbourship with remote PE in mVPN domain over MTI.

The moment i connected CPE and enabled PIM between PE-CE ,I see all my remote PE in MD becomes neighbour of 12K.

This behaviour is no more true in IOS-XR.

Regards,

Chintan

Cisco Employee

Re: problem in mVPN setup

Chintan,

Address-family ipv4 mdt should be enabled on the session to the RR. Even though IPv4 mdt doesn't need to be exchanged. The PE will not try to join the default MDT unless this configured.

This configuration should be added automatically in SY3 when you reload the router. Or you can just add it manually.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: problem in mVPN setup

Hi hritter,

Does address-family ipv4 MDT require for PIM-SM based Default MDT too ??

I have already configured address-family ipv4 MDT and I still have same issue.

interface Loopback10

ip vrf forwarding mVPN-A

ip address 10.10.10.1 255.255.255.252

ip pim sparse-dense-mode

ip igmp join-group 239.193.1.2

It is also worth to say that I also have parallel mVPN for PIM-SSM default but that also have same problem on 12K.

Regards,

Chintan

New Member

Re: problem in mVPN setup

sorry i pasted wrong config in last post

here is ipv4 mdt configuation

!

address-family ipv4 mdt

neighbor VPNV4-VRR activate

neighbor VPNV4-VRR send-community extended

neighbor 10.74.90.9 peer-group VPNV4-VRR

exit-address-family

!

Hall of Fame Super Silver

Re: problem in mVPN setup

Hello Chintan,

you may be facing an IOS version issue on GSR.

However, I don't understand your setup:

>>Each PE connected to both CR through >>layer 2 switch and each CR is >>connected to each other.

>>I have both CR runnning MSDP.

But if the customer routers are connected between them, where is the need for the service provider path/service ?

I would start with two single homed VRF sites something like:

CR1 -PE1 -- GSR -- PE2-- CR2

Hope to help

Giuseppe

620
Views
0
Helpful
12
Replies
CreatePlease login to create content