Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Problem with redistributing VRF routes into the global routing table.

I'm trying to redistribute and OSPF vrf process into the global routing table and getting the following error:

"VRF specified does not match this router"

There are no other routers involved. And all subnets are public addresses.

I would have through that OSPF will go straight into BGP.

I also get the same error when trying to redistribut the OSPF routes into the BGP VRF instance.

ip vrf customer-public-vrf

rd 1111:1391

route-target export 1111:1391

route-target import 1111:1391

!

interface Loopback1391

ip vrf forwarding customer-public-vrf

ip address 10.1.1.22 255.255.255.255

mpls netflow egress

!

interface GigabitEthernet0/1.302

description Cust: customer-ethernet

ip vrf forwarding customer-public-vrf

ip address 10.23.130.41 255.255.255.252

!

router ospf 1391 vrf customer-public-vrf

log-adjacency-changes

redistribute static subnets

network 10.23.130.42 0.0.0.0 area 0

distribute-list route-map customer-ethernet-OSPF-in in

!

!

router bgp 1111

address-family ipv4 vrf customer-public-vrf

redistribute connected

no auto-summary

no synchronization

exit-address-family

!

!

ip route vrf sro-public-vrf 10.2.168.0 255.255.248.0 10.23.130.42

!

2 REPLIES
Community Member

Re: Problem with redistributing VRF routes into the global routi

capability vrf-lite was needed!

Community Member

Re: Problem with redistributing VRF routes into the global routi

It still only lets me redistribute the process into the VRF address-family.

Not the global address-family.

Any thoughts?

674
Views
0
Helpful
2
Replies
CreatePlease to create content