Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Problems setting up MPLS

A Chairde,

Am having problems setting up MPLS between a AS5350 and 7609 , I have used commands stated in this link, enable MPLS incrementally on a network.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/switch_c/xcprt4/xcdtagc.pdf

The commands below are added to each router, and some troubleshooting.

7609

------

ip cef distributed

interface Loopback0

ip address 192.168.254.1 255.255.255.255

tag-switching advertise-tags

!

interface GigabitEthernet3/12

ip address 192.168.230.162 255.255.255.248

mpls label protocol tdp

tag-switching ip

!

AS5350

------

ip cef

mpls label protocol tdp

tag-switching advertise-tags

interface Loopback0

ip address 192.168.254.2 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.230.161 255.255.255.248

duplex auto

speed auto

mpls ip

h323-gateway voip interface

h323-gateway voip id cnibhco111 ipaddr 192.168.230.129 1719

h323-gateway voip h323-id cnibhco112

h323-gateway voip tech-prefix 71401

h323-gateway voip tech-prefix 0030

h323-gateway voip bind srcaddr 192.168.230.161

ip rsvp bandwidth 64 64

--------

cnibhco112#sh tag-switching tdp neighbor

Peer TDP Ident: 192.168.254.1:0; Local TDP Ident 192.168.230.161:0

TCP connection: 192.168.254.1.49842 - 192.168.230.161.711

State: Oper; PIEs sent/rcvd: 18/23; Downstream

Up time: 00:12:54

TDP discovery sources:

FastEthernet0/0, Src IP addr: 192.168.230.162

Addresses bound to peer TDP Ident:

192.168.100.17 192.168.100.25 159.107.212.49 172.16.8.81

192.168.230.130 192.168.230.77 192.168.230.81 192.168.254.1

192.168.210.6 192.168.127.6 192.168.210.106 192.168.127.66

192.168.127.138 192.168.210.146 192.168.210.142 192.168.210.122

192.168.210.17 192.168.230.140 192.168.230.26 192.168.230.74

192.168.230.10 192.168.230.14 192.168.127.130 192.168.127.142

192.168.230.6 192.168.230.70 192.168.230.34 192.168.210.178

192.168.200.25 192.168.210.126 192.168.232.1 192.168.231.1

192.168.200.17 192.168.210.102 190.168.200.245 190.168.200.225

190.168.201.241 192.168.230.98 192.168.210.14 190.168.201.201

190.168.201.209 192.168.210.162 192.168.210.210 190.168.201.205

192.168.230.38 190.168.200.249 190.168.200.217 190.168.200.253

192.168.230.162

cnibhco112#

------------------

cnibhco112#sh tag-switching forwarding-table 192.168.254.1 detail

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

cnibhco112#traceroute 192.168.254.1

Type escape sequence to abort.

Tracing the route to 192.168.254.1

1 192.168.230.162 0 msec 0 msec *

cnibhco112#traceroute 192.168.230.162

Type escape sequence to abort.

Tracing the route to 192.168.230.162

1 192.168.230.162 0 msec 0 msec *

cnibhco112#

2 REPLIES
Bronze

Re: Problems setting up MPLS

ok first things first. Add the command mpls tdp router-id loopback 0 force if you can. Then you must be able to reach the loopbacks of each router i.e. use ospf or something.

New Member

Re: Problems setting up MPLS

Ro,

Thanks for the respone, have been playin, with MPLS for last few hours.

The routing between the loopbacks is now working, can PING 7609 Loopback from AS5350 ,and vice versa. (used static routes).

Having problem with TDP / LDP on routers,

mpls label protocol ldp / tdp command works correctly on both routers, but the

tag-switching tdp router-id Loopback0 force

command works on the 7609, but when I add it onto the AS5350 , the command "mpls ldp router-id Loopback0 force" appears on the startup script.

The opposite is true for the 7609 , you add MPLS LDP command, and TAG-SWITCHING command appears instead.

Any Ideas, as different configs of this leave me with forwarding table with both tags added, but not been able to ping the loopbacks !!!

When I can ping bot loopbacks, the OUTGOING TAG , disapears.....

Problem is LOOPBACK Commands on bot routers default to LDP (AS5350) , or TDP (7609). Any Ideas ...

mpls label protocol tdp

tag-switching tdp router-id Loopback0 force

mpls label protocol tdp

mpls ldp router-id Loopback0 force

----------------------------------------------

cnibhco100#sh tag-switching forwarding-table 192.168.254.2 detail

Local Outgoing Prefix Bytes tag Outgoing Next Ho

tag tag or VC or Tunnel Id switched interface

18 17 192.168.254.0/24 0 Gi3/12 192.168.2

MAC/Encaps=14/18, MRU=1500, Tag Stack{17}

00097CA3293000127FCDBA808847 00011000

No output feature configured

Per-packet load-sharing

cnibhco100#traceroute 192.168.254.2

Type escape sequence to abort.

Tracing the route to 192.168.254.2

1 192.168.230.161 [MPLS: Label 17 Exp 0] 0 msec 0 msec 0 msec

2 192.168.230.162 0 msec 0 msec 0 msec

But no PINGING 192.168.254.2

------------------------------------------

cnibhco112#sh tag-switching forwarding-table 192.168.254.1 detail

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

17 18 192.168.254.0/24 1915668 Fa0/0 192.168.230.162

MAC/Encaps=14/18, MRU=1500, Tag Stack{18}

00127FCDBA8000097CA329308847 00012000

No output feature configured

Per-packet load-sharing

---------------------------------------------

cnibhco100#sh tag-switching forwarding-table 192.168.254.2 detail

Local Outgoing Prefix Bytes tag Outgoing Next Ho

tag tag or VC or Tunnel Id switched interface

18 17 192.168.254.0/24 752551 Gi3/12 192.168.2

MAC/Encaps=14/18, MRU=1500, Tag Stack{17}

00097CA3293000127FCDBA808847 00011000

No output feature configured

Per-packet load-sharing

WHEN BOTH LOCAL AND OUTGOING TAG, CANNOT PING EITHER WAY !!!

HAVE LABEL PROTOCOL AND LOOPBACK FORCE on AS5350

HAVE LABEL PROTOCOL ON 7609

-----------------------------------------------------------

WHEN ADD LOOPBACK FORCE on 7609 , CAN PING BOTH LOOPBACKS,

BUT OUTGOING TAG DISAPEARS

cnibhco112#PING 192.168.254.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.254.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

cnibhco112#sh tag-switching forwarding-table 192.168.254.1 detail

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

17 Untagged 192.168.254.0/24 598678 Fa0/0 192.168.230.162

MAC/Encaps=0/0, MRU=1504, Tag Stack{}

No output feature configured

Per-packet load-sharing

cnibhco112#

mpls label protocol tdp

tag-switching tdp router-id Loopback0 force

357
Views
5
Helpful
2
Replies
CreatePlease to create content