Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Redistributed RIP default route into EIGRP /PE not being updated problems

I'm having problems with redistributed RIP routes into EIGRP not being updated by the other PE's. Scenario! Site A has a internet connection which is announcing a default route into a firwall running RIP then passing that default route to a CE running RIP/redistributing into EIGRP. We are running EIGRP within the MPLS cloud. Now Site B is setup identically doing the same thing in a different City all together. The problem that I'm experiencing is if we take down the internet connection in Site A the switch over for the default route switches over fine but if we bring the internet connection back up only the PE that's attached to the CE where we are redistributing RIP/EIGRP gets updated with the changes. The other PE's next to site A are not being updated with the change. If I check the routing table in the other PE's it still holds on to the default route from Site B. Vice versa if I take down Site B's Internet connection. If anyone could help I would greatly appreciate it.

7 REPLIES
Silver

Re: Redistributed RIP default route into EIGRP /PE not being upd

I think the problem is when you are redistributing EIGRP into BGP you are not forcing a metric on the PE. Somehow I have seen this block triggered updates in EIGRP. Can you confirm that on the MPLS VPN PE you are redistribuing with a metric ?

Community Member

Re: Redistributed RIP default route into EIGRP /PE not being upd

Get a confirmation from your MPLS provider if the route is received by the remote PE. It is a good place to begin troubleshooting.

Community Member

Re: Redistributed RIP default route into EIGRP /PE not being upd

I have just checked the address family configuration and I don't have the metric set. I have a quick question would i use the metric of 0 or ???/just take default. Any help would help.

address-family ipv4 vrf xxx

redistribute connected

redistribute eigrp 1

default-information originate

no auto-summary

no synchronization

exit-address-family

Silver

Re: Redistributed RIP default route into EIGRP /PE not being upd

Yeah you can set any metric while redistributing cause it will not change the metrics at all :-) as MP-BGP will transparently carry the EIGRP metrices received from the remote PE (the metrics are carried using extended communities).

Just asking you to set a dummy metric and check cause this was a problem I had seen some time back and setting metrics helped.

Community Member

Re: Redistributed RIP default route into EIGRP /PE not being upd

Remember to set the metric while redistributing routes from MP-BGP to EIGRP (PE-CE).

eg

router eigrp 1

no auto-summary

!

address-family ipv4 vrf VPNA

redistribute bgp 1234 metric 1 1 1 1 1

network 10.0.0.0 0.0.0.255

no auto-summary

autonomous-system 2

exit-address-family

To the best of my knowledge EIGRP doesn't support "transparent metric" when used as the PE-CE protocol. This feature is available with RIP v2.

I hope this helps.

Re: Redistributed RIP default route into EIGRP /PE not being upd

Since your other PE's are not reflecting the right path its more a issue on the MPBGP. But still to sanitize things, pls run this checklist.

1) Assign a Metric when redistributing RIP--> EIGRP on CEA and CEB.

2) Assign a Metric when redistributing EIGRP --> MPBGP on PEA and PEA.

Since the other PE's are not reflecting the correct path, dont transparently pass

the EIGRP metric into MPBGP, assign an equal metric of lets say "2" on PEA and PEB

when you residtribute EIGRP into MPBGP.

When you do this all the other PE's in your network will prefer the closest IGP path

for the default route.

3) Assign a metric when you resitribute MPBGP into EIGRP on both the PE's (A and B)

If you confirm positively on these above points and have taken care of the same it should work.

HTH-Cheers,

Swaroop

Community Member

Re: Redistributed RIP default route into EIGRP /PE not being upd

Hi thanks for the input. I did exactly as you explained and MPBGP still for some reason holds onto the default route of site B. I've tried tweeking with the metric and still no luck. For some reason the directly connected PE to site A is not passing the info to the other PE's as a preferred path.

I've even tried to raise the metric on Site B with a higher number and it still won't kick back when Site A comes back online. Any other thoughts?

438
Views
0
Helpful
7
Replies
CreatePlease to create content