Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Redistribution of "global" OSPF into a VRF

Im' trying to redistribute several routes learned via OSPF into a VRF. This VRF use EIGRP as routing protocol.

I'm not able to see any entry in the vrf table.

Have anybody done a similar things or can point me to samples and tips ?

Thanks

Marco

This is what I have done:

ip vrf 1

rd 1000:1

route-target export 1000:1

route-target import 1000:1

!

ip vrf 2

rd 1001:2

route-target export 1001:2

route-target import 1001:2

interface FastEthernet0/0

description connessione al porta 4/12

no ip address

duplex full

speed 100

!

interface FastEthernet0/0.1

description VLAN 1 per test

encapsulation dot1Q 34

ip vrf forwarding 1

ip address 192.168.230.1 255.255.255.248

ip nat inside

standby 1 ip 192.168.230.6

standby 1 priority 110

standby 1 track GigabitEthernet6/0.2

interface FastEthernet0/0.2

description VLAN 2 per test SNASW

encapsulation dot1Q 35

ip vrf forwarding 2

ip address 192.168.230.57 255.255.255.248

interface GigabitEthernet6/0.1

description vlan TEST_NAT

encapsulation dot1Q 42

ip address 192.168.230.9 255.255.255.248

standby 2 ip 192.168.230.14

standby 2 priority 110

!

interface GigabitEthernet6/0.2

description vlan NAT

encapsulation dot1Q 43

ip address 192.168.230.17 255.255.255.248

standby 3 ip 192.168.230.22

standby 3 priority 110

standby 3 track FastEthernet0/0.1

!

router eigrp 2000

auto-summary

!

address-family ipv4 vrf 2

network 192.168.230.56 0.0.0.3

no auto-summary

autonomous-system 1001

exit-address-family

!

address-family ipv4 vrf 1

network 192.168.230.0 0.0.0.3

no auto-summary

autonomous-system 1000

exit-address-family

no eigrp log-neighbor-changes

!

router ospf 1000

log-adjacency-changes

passive-interface FastEthernet0/0.1

passive-interface GigabitEthernet6/0.1

network 192.168.230.16 0.0.0.7 area 100.100.100.100

4 REPLIES
Silver

Re: Redistribution of "global" OSPF into a VRF

I do not see any redistribute statements in your config. Still the better way to reach out of the vrf is to use static routes like

ip route vrf test 0.0.0.0 0.0.0.0 20.x.x.x global (To reach outside the vrf test)

ip route 10.0.0.0 255.0.0.0 Ethernet0/0 10.10.10.6 (Back route into vrf)

New Member

Re: Redistribution of "global" OSPF into a VRF

Well thanks; effectively I found also after several tests that this seems to be the unique method to distribute global networks into a vrf.

Marco

New Member

Re: Redistribution of "global" OSPF into a VRF

From your example it is difficult to see which network is running EIGRP as there are no network statement under the EIGRP process plus your AS numbers under the interfaces do not match you EIGRP "AS" number i.e. 1000 vs 2000.

Apart from this I would suggest you exchange routes between VRF's by doing the relevant import and export between the VRF's i.e. For VRF 1 to see routes from VRF 2 and visa versa add the following to the vrf config :

ip vrf 1

rout-target import 1000:2

ip vrf 2

route-target import 1000:1

If the two routing processes are within the same VRF make use of the redistribution command .

New Member

Re: Redistribution of "global" OSPF into a VRF

Hi,

I don't understand very well your question, because I really don't know if you are trying to configure VPN's over MPLS but, maybe this can help you.

When you are configuring VPN's over MPLS:

- Supported by VPN aware routing protocols: eBGP, OSPF, RIPv2, Static Routes. The EIGRP is not a supported VPN, vrf Protocol.

- When you are configuring VPN's over MPLS you have to configure BGP and the address family for BGP.

- Also you have to be very careful when you are assigning OSPF to a vrf.

An example:

router ospf 1000 vrf Customer_ABC

network 192.168.230.16 0.0.0.7 area z

redistribute bgp xxx

router bgp xxx

address-family ipv4 vrf Customer_ABC

redistribute ospf 1000

There's more to configure in bgp, like neighbors address family vpnv4, etc.

Sorry if this don't help you or if you already knew this.

Regards,

Hector

1897
Views
3
Helpful
4
Replies
CreatePlease to create content