Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

REP common link over VPLS

Hi,

I'm looking for some guidance on how to configure a REP common link over VPLS.  I've read a bunch of docs that more or less elude to the fact that it should be supported, but no combination of documents thus far have clearly outlined what the prerequisites are in terms of software, ES vs. ES+ hardware or relevant configuration glue to make this work.

http://www.cisco.com/en/US/docs/ios/lanswitch/configuration/guide/lsw_cfg_rep.html#wp1316104

http://www.cisco.com/en/US/docs/routers/7600/install_config/ES20_config_guide/baldpref.html

Cisco Live 2010 session BRKSPG-2205 (Deploying and Designing with Resilient Ethernet Protocol) page 79

I've got two 7600/SUP720/SRE5 boxes with a chain of ME3400s connecting the two over 6724 LAN based linecard ports.  I've also got an ES port between each 7600 to carry the SVI based EoMPLS foo between the two, and this is where I'd like to establish the VPLS common link (hopefully the below ASCII diagram will show up OK):

[ 7600-1 ]--(6724-GE)--[ ME3400-1 ]--[ ME3400-2 ]--(6724-GE)--[ 7600-2 ]

   |                                                               |

   |                                                               |

   +---------------------------(ES20-GE)-------------------------- +

In terms of config, I've got the 6724 chain side configured as a REP segment and the REP admin VLAN is 1/default.  I haven't been able to find the configuration glue needed to make REP aware that the common link for the segment is the VPLS pseudowire between the two 7600s:

! 7600-1

!

interface loopback 0

ip address 2.2.2.2 255.255.255.255

ip router isis 21949

!

interface GigabitEthernet8/22

description Facing ME3400-1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

rep segment 19 edge primary

!

interface GigabitEthernet7/0/19

description Facing 7600-2

mtu 9216

ip address 1.1.1.2 255.255.255.254

no ip redirects

ip router isis 21949

mpls ip

mls qos trust dscp

bfd interval 250 min_rx 250 multiplier 4

clns mtu 9199

ethernet vlan color-block all

!

interface Vlan1

no ip address

xconnect vfi REP-PROTECT

!

l2 vfi REP-PROTECT manual

vpn id 2194900101

bridge-domain 1 vlan

neighbor 2.2.2.3 encapsulation mpls

!

! 7600-2

!

interface loopback 0

ip address 2.2.2.3 255.255.255.255

ip router isis 21949

!

interface GigabitEthernet8/22

description Facing ME3400-2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

rep segment 19 edge

!

interface GigabitEthernet7/0/19

description Facing 7600-1

mtu 9216

ip address 1.1.1.3 255.255.255.254

no ip redirects

ip router isis 21949

mpls ip

mls qos trust dscp

bfd interval 250 min_rx 250 multiplier 4

clns mtu 9199

ethernet vlan color-block all

!

l2 vfi REP-PROTECT manual

vpn id 2194900101

bridge-domain 1 vlan

neighbor 2.2.2.2 encapsulation mpls

!

REP topology looks OK:

7600-1#show rep top

REP Segment 19

BridgeName       PortName   Edge Role

---------------- ---------- ---- ----

7600-1           Gi8/22     Pri  Open

3400-1           Gi0/2           Open

3400-1           Gi0/1           Open

3400-2           Gi0/1           Open

3400-2           Gi0/2           Open

7600-2           Gi8/22     Sec  Alt

VFI is up:

7600-1#show vfi name REP-PROTECT

Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No

VFI name: REP-PROTECT, state: up, type: multipoint

VPN ID: 2194900101

Bridge-Domain 1 attachment circuits:

   Vlan1 

Neighbors connected via pseudowires:

Peer Address     VC ID        S

2.2.2.3          2194900101   Y

However in a REP segment failure, the pseudowire seems to be pretty much useless acting as a common link for the failed segment.

Is anyone running a config like this?  Am I missing something obvious (or not so obvious?)?

Thanks in advance.

Everyone's tags (6)
584
Views
0
Helpful
0
Replies