Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Silver

RIP Supernetting Problem

I am simulating a lab of RIPV2 with no auto-summary. Point to point links are using 192.168.0.0/23 pool ip addresses. On every router I am creating a loopback with 192.168.2.1/23 & on another router creating a loopback 192.168.4.1/23. But rip databases are not exchanged.

I am getting error

"Jan 19 00:10:16.095: RIP: ignore the request received from unlisted network"

regards

shivlu jain

1 REPLY
Cisco Employee

Re: RIP Supernetting Problem

Hi Shivlu,

I tested it and it's working:

CE (12.0(33)S1):

interface Loopback10

ip address 192.168.2.3 255.255.255.254

no ip directed-broadcast

!

interface Ethernet0/0

description to PE2

no ip address

no ip directed-broadcast

!

interface Ethernet0/0.10

encapsulation dot1Q 10

ip address 192.168.1.1 255.255.255.254

!

router rip

version 2

network 192.168.1.0

no auto-summary

PE:

AS1-PE2#sir rip

...

Gateway of last resort is 192.168.2.5 to network 0.0.0.0

192.168.2.0/24 is variably subnetted, 6 subnets, 3 masks

R 192.168.2.2/31 [120/1] via 192.168.1.1, 00:00:04, Ethernet1/0.10

AS1-PE2#ping 192.168.2.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.2.3, timeout is 2 seconds:

!!!!!

HTH

Thanks

Laurent.

401
Views
0
Helpful
1
Replies
CreatePlease to create content