Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Route Leaking from VRF´s into the Global table

Hi I am currently looking for a solution for injecting routes into the global routing table from a vrf so that a lookup can occur from the global routing table. The standard procedure for route leaking requires a destination ip address that does not belong to the router itself therefore creating a default route from the vrf to the global loopback address isn´t possible.

Performing the following config:

ip route vrf red 0.0.0.0 0.0.0.0 192.168.1.1 global

assuming that that 192.168.1.1 is the next hop address a router in the global table works.

However when trying to get a local route table look up this functionality is not possible.

Does anybody happen to know a work around that would allow this to happen.

Kind Regards,

Josh Halley

4 REPLIES
New Member

Re: Route Leaking from VRF´s into the Global table

Hi,josh

Does PE can reach the address 192.168.1.1? I mean the address must has a label in MPLS VPN core.

New Member

Re: Route Leaking from VRF´s into the Global table

Hi,

The PE can reach the 192.168.1.1 as it is part of its global (IGP) routing table. So when trying to reach this ip address directly there are no problems with reachability. What I actually want to do is perform the lookup on the same device that is performing the route leaking rather than an external router. As shown in the example below.

interface ethernet0

ip vrf forwarding

ip address 10.1.1.1 255.255.255.0

interface loopback0

ip addresss 172.1.1.1 255.255.255.0

Ip route vrf red 0.0.0.0 0.0.0.0 loopback0 Global

ip route 172.1.1.0 255.255.255.0 ethernet0

This example however doesn´t work, does anybody know of a way to get this functioning?

New Member

Re: Route Leaking from VRF´s into the Global table

Hi Josh....

a long time ago that you posted this message..

We have the same problem, and till now no solution...

did you solve this issue, and if yes, would you please tell me the way?

cheers

rene

New Member

Re: Route Leaking from VRF´s into the Global table

Hi Rene,

unfortunately I didn´t find any normal solution to this issue. One hack/work around however would be to create a transit /30 vlan on a switch and connect two interfaces from the same physical router into that vlan. Configuring the first interface in the vrf and the other interface in the global table.

ie:

interface FastEthernet0/0

ip vrf forwarding red

ip address 192.168.0.1 255.255.255.252

interface FastEthernet0/1

ip address 192.168.0.2 255.255.255.252

ip route vrf red 0.0.0.0 0.0.0.0 192.168.0.2

This however isn´t really a nice solution to the problem as you either require two seperate physical interfaces or two trunk interfaces on your router where you can configure the same vlan id.

Anyway hope this solution works for you or you manage to find a better one.

Kind Regards,

Josh

1143
Views
0
Helpful
4
Replies
CreatePlease to create content