Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Routed-Pseudowire / SVI interface state

Here's my network scenario.

The downstream device is a Cisco ME3600 (provider edge) where my customer connects.  Upstream is a Cisco 7600 with ES+ line cards.

From the customer connecting interface, I xconnect to the upstream 7600:

-----------------------------------------------------------------

[ME3600]

!

interface Loopback0

ip address 10.2.2.2 255.255.255.0

!

interface GigabitEthernet0/1

description CUSTOMER XYZ

port-type nni

no switchport

mtu 9216

no ip address

  xconnect 10.1.1.1 2001 encapsulation mpls

!

The 7600 interface is configured as follows:

[7600]

!

interface Loopback0

ip address 10.1.1.1 255.255.255.0

!

interface Vlan2001

description CUSTOMER XYZ - SVI

mtu 9216

ip address 192.168.1.1 255.255.255.0

  xconnect 10.2.2.2 2001 encapsulation mpls

!

-----------------------------------------------------------------

This works fine and dandy - however I am trying to establish a method whereby I can make the state of the SVI follow the state of the VC.  Whether or not the VC status is up or down, the SVI (Vlan2001) will go into an UP/UP state as soon as the "xconnect" is applied.  This can cause other various issues that I won't go into at this time.

I have looked into Ethernet CFM, OAM, IP SLA and BFD but haven't grasped exactly how either will accomplish this, due impart probably to my inevitable misunderstanding of much of what I have read.

Any ideas would be highly appreciated.

Everyone's tags (4)
2 REPLIES

Routed-Pseudowire / SVI interface state

HI John

As per my understanding the state of the SVI is not dependent on xonnect but on any one available up/up Ethernet L2 Port on which the corresponding L2 VLAN is allowed..I don't think personally "xconnect" statement has anything to do with SVI State..If we compare it with a LAN enviornment the SVI stays UP/UP without xconnect depending on any one available L2 Port belonging to the same VLAN.

Now coming to the part of the SVI State following the VC State I think Cisco Event Applet Manager can be useful to help us..Below is  a good link for same..

http://www.cisco.com/en/US/docs/ios/netmgmt/configuration/guide/nm_eem_policy_cli.html

Hope this provides some insight to your query.

Regards

Varma

Community Member

Routed-Pseudowire / SVI interface state

Varma, I appreciate your response.  I understand your belief that the SVI interface would be in an UP state assuming it was a member VLAN of a trunk port, for example.  However, that is not the case.  In this scenario, VLAN 2 is not.  There are actually no dot1q ports on the 7600.  I am using MPLS and TE-Tunnels (there is a core in the middle comprised of Cat6500s).  On the 7600 specifically, the configuration is as simple as:

config t

vlan 2

exit

interface vlan 2

ip address

xconnect

end

I have seen eemp used in some example and I didn't even think of that.  I will give that thought a thorough read.

Thank you for the idea!

2841
Views
0
Helpful
2
Replies
CreatePlease to create content