Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

routerid loopback0 force

A Chairde,

Have MPLS CLI Issue between an AS5350 and 7609 Routers.

The "mpls label protocol tdp/ldp" command works correctly on both routers.

but ....

"tag-switching tdp router-id Loopback0 force" command works on the 7609, but when I add it onto the AS5350 , the command "mpls ldp router-id Loopback0 force" appears on the startup script.

The opposite is true for the 7609 , you add MPLS LDP command, and TAG-SWITCHING command appears instead.

Any Ideas, as different configs of this leave me with forwarding table with both tags added, but not been able to ping the loopbacks !!!

When I can ping both loopbacks, the OUTGOING TAG

is absent.....

Problem is LOOPBACK Commands on both routers default to LDP (AS5350) , or TDP (7609). Any Ideas ...

mpls label protocol tdp

tag-switching tdp router-id Loopback0 force

mpls label protocol tdp

mpls ldp router-id Loopback0 force

cnibhco112#PING 192.168.254.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.254.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

cnibhco112#sh tag-switching forwarding-table 192.168.254.1 detail

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

17 Untagged 192.168.254.0/24 598678 Fa0/0 192.168.230.162

MAC/Encaps=0/0, MRU=1504, Tag Stack{}

No output feature configured

Per-packet load-sharing

14 REPLIES
Silver

Re: routerid loopback0 force

I dont think the commands should be an issue. AFAIK Cisco has been saying it will phase the tag-switching commands for some time. The issue i feel lies elsewhere. Could you give the outout of

sh mpls ldp discovery

sh mpls interfaces

Regds

New Member

Re: routerid loopback0 force

Att,

Thanks for prompt reply.

Commands as requested are below.

From AS5350 , the commands setup for MPLS are.

Its loopback is 192.168.254.2

mpls label protocol ldp

mpls ldp router-id Loopback0 force

------------------------------------------

commands are:

cnibhco112#ping 192.168.254.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.254.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

cnibhco112#ping 192.168.254.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.254.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

cnibhco112#traceroute 192.168.254.1

Type escape sequence to abort.

Tracing the route to 192.168.254.1

1 192.168.230.162 0 msec 0 msec *

cnibhco112#

----------------------------------------

7609 , Loopback = 192.168.254.1

mpls label protocol ldp

tag-switching tdp router-id Loopback0 force (tried to put in MPLS LDP, and got this !!!)

--------------------------------------------

cnibhco100#ping 192.168.254.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.254.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

-------------------------------------

cnibhco100#ping 192.168.254.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.254.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

====================================

====================================

-------------------------------

cnibhco112#sh mpls ldp discovery

Local LDP Identifier:

192.168.254.2:0

Discovery Sources:

Interfaces:

FastEthernet0/0 (ldp): xmit/recv

LDP Id: 192.168.254.1:0

cnibhco112#sh mpls interfaces

Interface IP Tunnel Operational

FastEthernet0/0 Yes (ldp) No Yes

-----------------------------------

cnibhco100#sh mpls ldp discovery

Local LDP Identifier:

192.168.254.1:0

Discovery Sources:

Interfaces:

GigabitEthernet3/12 (ldp): xmit/recv

LDP Id: 192.168.254.2:0

cnibhco100#sh mpls interfaces

Interface IP Tunnel Operational

GigabitEthernet3/12 Yes (ldp) No Yes

--------------------------

Silver

Re: routerid loopback0 force

Iam just wondering why arent you able to ping 254.2 from the 7609. Is there a Static Route or an IGP running between them ? as the ldp discovery , you are working on LDP so it is essentially a reachability issue.

Silver

Re: routerid loopback0 force

Yes, except if the routers tries to use a labeled packet to reach the other router, rather than a pop tag. I'm wondering whats up with the mpls forwarding table.

Can you give us the show ip route and the show mpls for when the pings are not going.

New Member

Re: routerid loopback0 force

Att, Olo,

Thanks for replies.

The routes setup are static and BGP between the routers.

Am getting errors on 7609 ,

ldp-5-nbrchg: LDP Neighbor 192.168.254.2:0 is DOWN

ldp-5-nbrchg: LDP Neighbor 192.168.254.2:0 is UP

---------------------------------------------------

interface Loopback0

ip address 192.168.254.2 255.255.255.255

neighbor 192.168.254.1 remote-as 65534

neighbor 192.168.254.1 update-source Loopback0

neighbor 192.168.254.1 activate

neighbor 192.168.254.1 send-community

ip route 192.168.254.0 255.255.255.0 192.168.230.162

cnibhco112#SH IP ROUte

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.230.162 to network 0.0.0.0

192.168.230.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.230.136/30 is directly connected, FastEthernet0/1

C 192.168.230.160/29 is directly connected, FastEthernet0/0

192.168.254.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.254.2/32 is directly connected, Loopback0

S 192.168.254.0/24 [1/0] via 192.168.230.162

S* 0.0.0.0/0 [1/0] via 192.168.230.162

cnibhco112#

tib entry: 192.168.254.0/24, rev 8

local binding: tag: 17

remote binding: tsr: 192.168.254.1:0, tag: 18

tib entry: 192.168.254.1/32, rev 25091

remote binding: tsr: 192.168.254.1:0, tag: imp-null

tib entry: 192.168.254.2/32, rev 6

local binding: tag: imp-null

-------------------------------------

cnibhco112#SH IP ROUT

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.230.162 to network 0.0.0.0

192.168.230.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.230.136/30 is directly connected, FastEthernet0/1

C 192.168.230.160/29 is directly connected, FastEthernet0/0

192.168.254.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.254.2/32 is directly connected, Loopback0

S 192.168.254.0/24 [1/0] via 192.168.230.162

S* 0.0.0.0/0 [1/0] via 192.168.230.162

------------------

==================

tib entry: 192.168.254.0/24, rev 98

local binding: tag: 18

remote binding: tsr: 192.168.254.2:0, tag: 17

tib entry: 192.168.254.1/32, rev 100

local binding: tag: imp-null

tib entry: 192.168.254.2/32, rev 1879

remote binding: tsr: 192.168.254.2:0, tag: imp-null

------------------------------------

192.168.254.0/24 is variably subnetted, 2 subnets, 2 masks

S 192.168.254.0/24 [1/0] via 192.168.230.161

C 192.168.254.1/32 is directly connected, Loopback0

Re: routerid loopback0 force

NOTE: your bgp configurations is not complete, u need to add neighbor 192.168.254.1 ebgp-multihop to the following lines because the neighbor address is not dir/connected

neighbor 192.168.254.1 remote-as 65534

neighbor 192.168.254.1 update-source Loopback0

neighbor 192.168.254.1 activate

neighbor 192.168.254.1 send-community

ip route 192.168.254.0 255.255.255.0 192.168.230.162

show ip bg su will give you the session status

Re: routerid loopback0 force

I believe that the ping is successfully via static or dynamic routing protocols, so could you provide us with your MPLS configurations from both sides to double check or use the following example with both routers:

1st Make sure both routers loopbacks is reachable from each other

Ip cef

tag-switching ip /

mpls label protocol tdp

tag-switching tdp router-id loopback 0

interface x/x

tag-switching ip

!

show ip cef 192.168.254.2  then take the imposed label number

router#show tag-switching forwarding-table tags 17 detail

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

16 17 192.168.254.2 0 x/x

I hope that help,

Best Regards,

Mounir Mohamed

Re: routerid loopback0 force

Also the following commands is usful

debug tag tdp transport -to check the TDP session est

debug tag tdp bindings - to cehck te LIB exchanges

Silver

Re: routerid loopback0 force

Try non-recursive routing like

ip route 192.168.254.0 255.255.255.0 fa0/0 192.168.200.162 (change the IPs as per ur need) and check if it works.

Re: routerid loopback0 force

Dear,

I think the TDP go up/down due to recursive routing lookup problem everything gone be working well if you changed the loopback ip address to avoid any routing problem also the BGP routes is not stored in the LIB tabels because the LSR's assing the BGP next-hope label

Best Regards,

Mounir Mohamed

Silver

Re: routerid loopback0 force

If you change the static route from the /24 to /32, you should be able to ping.

It is advisable to use routing protocols to setup the IGP for MPLS, this way one will be sure that RIB (hence the FIB, and the LFIB) would be identical. By using the /24 route on both routers, they have both assigned labels to these routes, which are not implicit null. To reach the other loopback, the packet sent as labelled, which is also label-switched back. If I'm right, a traceroute should show a loop between the 2 routers. This is also the reason for the flapping LP neighbours, as the LDP comes up when the LFIB has not been built but looses connection after, then uses RIB to regain connection.

So, either use /32 host routes, or use a routing protocol.

Hope this helps out.

Silver

Re: routerid loopback0 force

Bingo, yes completely missed that. That should solve the issue. Did clear a few doubts of mine too. Thx a lot.

New Member

Re: routerid loopback0 force

Olo, Att, Mounir,

Thanks for all your replies, you are correct, the problem is related to routing, but if I put in :

ip route 10.10.10.0 255.255.255.255 FastEthernet0/0 192.168.230.162

I still get:

cnibhco112#ping 10.10.10.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

--------------------------------------------------

The routing protocol on my network is BGP, This is my setup. ts confusing, if you look at IP ROUTE , there are no BGP Paths, but BGP commands look like it is propagating BGP thru system.BGP RID in SUMMARY command points to 192.168.254.2 !!!!!!

=====================================================

cnibhco112#sh run | begin router bgp

router bgp 65534

bgp log-neighbor-changes

neighbor 10.10.10.1 remote-as 65534

neighbor 10.10.10.1 update-source Loopback0

neighbor 192.168.230.137 remote-as 65534

neighbor 192.168.230.162 remote-as 65534

!

address-family ipv4

redistribute static

neighbor 10.10.10.1 activate

neighbor 10.10.10.1 send-community

neighbor 192.168.230.137 activate

neighbor 192.168.230.137 send-community

neighbor 192.168.230.162 activate

neighbor 192.168.230.162 send-community

auto-summary

synchronization

network 10.10.10.0

network 190.168.0.0

network 192.168.230.0

exit-address-family

!

ip classless

ip route 10.10.10.0 255.255.255.255 FastEthernet0/0 192.168.230.162

=====================================================

Some commands relating to BGP routing.

cnibhco112#sh ip route

Gateway of last resort is not set

192.168.230.0/29 is subnetted, 1 subnets

C 192.168.230.160 is directly connected, FastEthernet0/0

10.0.0.0/32 is subnetted, 2 subnets

C 10.10.10.2 is directly connected, Loopback0

S 10.10.10.0 [1/0] via 192.168.230.162, FastEthernet0/0

cnibhco112#sh ip bgp summary

BGP router identifier 192.168.254.2, local AS number 65534

BGP table version is 4, main routing table version 4

70 network entries using 8190 bytes of memory

71 path entries using 3692 bytes of memory

25/1 BGP path/bestpath attribute entries using 3100 bytes of memory

1 BGP rrinfo entries using 24 bytes of memory

8 BGP AS-PATH entries using 192 bytes of memory

20 BGP community entries using 480 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 15678 total bytes of memory

BGP activity 1995/1925 prefixes, 24638/24567 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

10.10.10.1 4 65534 399 88 0 0 0 22:32:11 Active

192.168.230.137 4 65534 3128 3133 0 0 0 22:33:00 Active

192.168.230.162 4 65534 32918 4484 4 0 0 3d02h 70

Silver

Re: routerid loopback0 force

I guess that you have changed your loopback addresses to 10.10.10.x.

Your static route is still wrong

ip route 10.10.10.0 255.255.255.255 FastEthernet0/0 192.168.230.162

It should be

ip route 10.10.10.1 255.255.255.255 FastEthernet0/0 192.168.230.162

at one end

I'm actually surprised that the router took it like that.

Also, for MPLS to work well, you need your IGP working well, and BGP cannot serve as you IGP.

570
Views
5
Helpful
14
Replies
CreatePlease to create content