Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

RSVP-TE, MPLS , tunnel still establishes though constraint(BW) not met

 

 

Hi everybody

I am studying TE using RSVP, MPLS . Below is my simple topology :

 

 

R1 f0/0----199.199.199.0/24--f0/0-R2-f0/1--198.198.198.0/24-f0/1 R3--f0/0-200.200.200.0/24 -SW


R1 config:

mpls traffic-eng tunnels

 


interface Loopback0
 ip address 1.1.1.1 255.255.255.255


interface Tunnel0
 ip unnumbered Loopback0
 tunnel destination 3.3.3.3
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth  20
 tunnel mpls traffic-eng path-option 10 dynamic
 no routing dynamic

 

 


interface FastEthernet0/0
 ip address 199.199.199.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth

interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto


router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 199.199.199.0 0.0.0.255 area 0


+++++++++++++++++++++++++++++++++++++++


R2 config:

mpls traffic-eng tunnels

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!

interface FastEthernet0/0
 ip address 199.199.199.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth

 

 

interface FastEthernet0/1
 ip address 198.198.198.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 198.198.198.0 0.0.0.255 area 0
 network 199.199.199.0 0.0.0.255 area 0


++++++++++++++++++++++++++++++++++++++++

 


R3 config:

mpls traffic-eng tunnels


interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 200.200.200.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 198.198.198.3 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth

 


router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 198.198.198.0 0.0.0.255 area 0
 network 200.200.200.0 0.0.0.255 area 0

+++++++++++++++++++++++++++++++++++++++++++++++++++

 


We are not defining any constraints for the tunnel0 to be formed as show below:

 

 

R1#show mpls traffic-eng tunnels

Name: R1_t0                               (Tunnel0) Destination: 3.3.3.3
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected

    path option 10, type dynamic (Basis for Setup, path weight 20)

  Config Parameters:
    Bandwidth: 20       kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  disabled  LockDown: disabled  Loadshare: 20       bw-based
    auto-bw: disabled

  InLabel  :  -
  OutLabel : FastEthernet0/0, 19
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 3.3.3.3, Tun_Id 0, Tun_Instance 3
    RSVP Path Info:
      My Address: 199.199.199.1
      Explicit Route: 199.199.199.2 198.198.198.2 198.198.198.3 3.3.3.3
      Record Route:  NONE
      Tspec: ave rate=20 kbits, burst=1000 bytes, peak rate=20 kbits

 


Tunnel is established,

Next we are going to change the rsvp bandwidth reservation from default to 1 kb under f0/0 on R2, then we will define bandwidth constraint for tunnel 0 establishment to be 20 Kbs.

i.e


R1:

R1(config)#interface Tunnel0
R1(config-if)#tunnel mpls traffic-eng bandwidth  20
R1(config-if)#shutdown
R1(config-if)#
*Mar  1 00:38:32.303: %LINK-5-CHANGED: Interface Tunnel0, changed state to administratively down
*Mar  1 00:38:33.303: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down

 

 


R2

R2(config)#interface f0/0
R2(config-if)#ip rsvp bandwidth 1


Now when enable tunnel 0 by using no shut, tunnel should not form because we define bandwidth constraint of 20 K for tunnel 0, the maximum rsvp bandwidth under f0/0 on R2 is 1 Kbs

let see if that is true.

 


*Mar  1 00:38:33.303: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R1(config-if)#no shut
R1(config-if)#
*Mar  1 00:42:53.563: %LINK-3-UPDOWN: Interface Tunnel0, changed state to up
*Mar  1 00:42:54.563: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
R1(config-if)#end
R1#s
*Mar  1 00:43:07.663: %SYS-5-CONFIG_I: Configured from console by console

 

 


R1#show mpls traffic-eng tunnels

Name: R1_t0                               (Tunnel0) Destination: 3.3.3.3
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected

    path option 10, type dynamic (Basis for Setup, path weight 20)

  Config Parameters:
    Bandwidth: 20       kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  disabled  LockDown: disabled  Loadshare: 20       bw-based
    auto-bw: disabled

  InLabel  :  -
  OutLabel : FastEthernet0/0, 19
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 3.3.3.3, Tun_Id 0, Tun_Instance 4
    RSVP Path Info:
      My Address: 199.199.199.1
      Explicit Route: 199.199.199.2 198.198.198.2 198.198.198.3 3.3.3.3
      Record Route:  NONE
      Tspec: ave rate=20 kbits, burst=1000 bytes, peak rate=20 kbits
    RSVP Resv Info:


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

Above we can see the tunnel 0 is established eventhough the bandwidth constraint of 20 Kbs is required along the path, and f0/0 on R2 can only allow 1 kbs for tunnel 0

Does anybody know why?

 

I appreciate your help.

Have a great weekend.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Hi,On the headend (and on R2)

Hi,

On the headend (and on R2), can you check if the TE topology is populated with the RSVP bandwidth details?.

I think when R2 receive PATH message with bandwidth as 20 kbps, it should send PATH-ERR back and the tunnel should not come up.

What version is it btw?.

 

-Nagendra

3 REPLIES
Cisco Employee

Hi,On the headend (and on R2)

Hi,

On the headend (and on R2), can you check if the TE topology is populated with the RSVP bandwidth details?.

I think when R2 receive PATH message with bandwidth as 20 kbps, it should send PATH-ERR back and the tunnel should not come up.

What version is it btw?.

 

-Nagendra

Bronze

Hi NagendraThanks for your

Hi Nagendra

Thanks for your response, I even forced the tunnel down, but yet tunnel still comes back up

 

Below is the requested info,

 

R1(config)#interface tunnel 0
R1(config-if)#shutdown

 

R1(config-if)#no shut
R1(config-if)#end
R1#
*Mar  1 00:30:57.007: %LINK-3-UPDOWN: Interface Tunnel0, changed state to up

 

R1#show mpls traffic-eng topology
My_System_id: 1.1.1.1, Globl Link Generation 8
Signalling error holddown: 10 sec

IGP Id: 1.1.1.1, MPLS TE Id:1.1.1.1 Router Node
      link[0 ]:DR Intf Address: 199.199.199.1, gen:7
          frag_id 0, Intf Address:199.199.199.1
          TE metric:10, IGP metric:10, attribute_flags:0x0
          physical_bw: 10000 (kbps), max_reservable_bw_global: 7500 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool       Sub Pool
               Total Allocated   Reservable        Reservable
               BW (kbps)         BW (kbps)         BW (kbps)
               ---------------   -----------       ----------
        bw[0]:            0             7500                0
        bw[1]:            0             7500                0
        bw[2]:            0             7500                0
        bw[3]:            0             7500                0
        bw[4]:            0             7500                0
        bw[5]:            0             7500                0
        bw[6]:            0             7500                0
        bw[7]:            0             7500                0

IGP Id: 2.2.2.2, MPLS TE Id:2.2.2.2 Router Node
      link[0 ]:DR Intf Address: 199.199.199.1, gen:8
          frag_id 0, Intf Address:199.199.199.2
          TE metric:10, IGP metric:10, attribute_flags:0x0
          physical_bw: 10000 (kbps), max_reservable_bw_global: 1 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool       Sub Pool
               Total Allocated   Reservable        Reservable
               BW (kbps)         BW (kbps)         BW (kbps)
               ---------------   -----------       ----------
        bw[0]:            0                1                0
        bw[1]:            0                1                0
        bw[2]:            0                1                0
        bw[3]:            0                1                0
        bw[4]:            0                1                0
        bw[5]:            0                1                0
        bw[6]:            0                1                0
        bw[7]:            0                1                0

      link[1 ]:DR Intf Address: 198.198.198.2, gen:8
          frag_id 1, Intf Address:198.198.198.2
          TE metric:10, IGP metric:10, attribute_flags:0x0
          physical_bw: 10000 (kbps), max_reservable_bw_global: 7500 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool       Sub Pool
               Total Allocated   Reservable        Reservable
               BW (kbps)         BW (kbps)         BW (kbps)
               ---------------   -----------       ----------
        bw[0]:            0             7500                0
        bw[1]:            0             7500                0
        bw[2]:            0             7500                0
        bw[3]:            0             7500                0
        bw[4]:            0             7500                0
        bw[5]:            0             7500                0
        bw[6]:            0             7500                0
        bw[7]:           20             7480                0

IGP Id: 3.3.3.3, MPLS TE Id:3.3.3.3 Router Node
      link[0 ]:DR Intf Address: 198.198.198.2, gen:4
          frag_id 0, Intf Address:198.198.198.3
          TE metric:10, IGP metric:10, attribute_flags:0x0
          physical_bw: 10000 (kbps), max_reservable_bw_global: 7500 (kbps)
          max_reservable_bw_sub: 0 (kbps)

                                 Global Pool       Sub Pool
               Total Allocated   Reservable        Reservable
               BW (kbps)         BW (kbps)         BW (kbps)
               ---------------   -----------       ----------
        bw[0]:            0             7500                0
        bw[1]:            0             7500                0
        bw[2]:            0             7500                0
        bw[3]:            0             7500                0
        bw[4]:            0             7500                0
        bw[5]:            0             7500                0
        bw[6]:            0             7500                0
        bw[7]:            0             7500                0

IGP Id: 198.198.198.2, Network Node
      link[0 ]:Nbr IGP Id: 2.2.2.2, gen:2

      link[1 ]:Nbr IGP Id: 3.3.3.3, gen:2

IGP Id: 199.199.199.1, Network Node
      link[0 ]:Nbr IGP Id: 1.1.1.1, gen:1

      link[1 ]:Nbr IGP Id: 2.2.2.2, gen:1

=============================================================

 


R1#show version
Cisco IOS Software, 3700 Software (C3745-ADVENTERPRISEK9_SNA-M), Version 12.4(25), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.

 

+++++++++++++++++++++++++++++++++

R2#show version
Cisco IOS Software, 3700 Software (C3745-ADVENTERPRISEK9_SNA-M), Version 12.4(25), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Tue 21-Apr-09 14:41 by prod_rel_team

 

 


interface FastEthernet0/0
 ip address 199.199.199.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 1
 ip rsvp resource-provider none
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

 

Thanks

 

 

have a great evening

 

 

In BW, wireshark capture between R1 and R2, does show that R2 sends RSVP message in response to Path maessage, this RSVP mesage shows the token bucket rate as 2500bytes/sec ( which is 2 kbsec, the same rate R1 demands in Path message)

 

For some reason, R2 is not sending an error message to R1 eventhough f0/0 on R2 ,has ip rsvp bandwidth 1

 

 

 

Bronze

Hi everybodyI found the

Hi everybody

I found the answer , putting it here for anyone with the similar question:

 

Below is my topology:

 

R1 f0/0---12.12.12.0/24-f0/0-R2-f0/1-----13.13.13.0/24--f0/1 R4

 

R1 has following config:

( showing pertinent)

interface Tunnel0
 ip unnumbered Loopback0
 tunnel destination 4.4.4.4
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth  20
 tunnel mpls traffic-eng path-option 10 dynamic
 no routing dynamic
!
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 mpls traffic-eng tunnels
 mpls traffic-eng administrative-weight 12
 ip rsvp bandwidth


++++++++++++++++++++++

 

R2:

interface FastEthernet0/0
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet0/1
 ip address 24.24.24.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth


++++++++++++++++++

interface FastEthernet0/1
 ip address 24.24.24.4 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth


++++++++++++++++++++++++++

 

 

Not shown, OSPF with TE enabled, each router has loopback 0 i.e R1 has 1.1.1.1, R2 has 2.2.2.2, R4 has 4.4.4.4

 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

 

Ingress LSR R1 has to from a LSP, ingress LSR checks  OSPF TE topology and runs CSPF.

Ingress R1 finds the following path  meeting the constraint( 20 Kbs along the path) and form the tunnel as shown below :( That is after trasmitting the Path and receiving the RSVP message)

 

R1#show mpls traffic-eng tunnels

( output omitted for brevity)

 

Name: R1_t0                               (Tunnel0) Destination: 4.4.4.4
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected

 

 

  RSVP Path Info:
      My Address: 12.12.12.1
      Explicit Route: 12.12.12.2 24.24.24.2 24.24.24.4 4.4.4.4

++++++++++++++++++++++++++++++++++++++++++

1) If I change the maximum reservable bandwidth under f0/0 R2 to 10 kbs, will tunnel 0 form ?

yes, tunnel will form because ingress LSR (R1) when it checks the potential path in TE topology for a LSP, it is looking at reservable bandwidth available on all outgoing interfaces on a potential path and . In our example, R1 first sees that f0/0  on itself  and, f0/1 on R2 can support 20 Kbs

 

Important thing to note R1 is not looking at F0/0 on R2 as it is not a outgoing interface on R2 for a potential LSP.

So If we change reservable bandwidth to 11 kbs under f0/0 on R2, it will not  prevent tunnel 0 from coming up as shown below:

 

R2(config)#interface f0/0
R2(config-if)#ip rsvp bandwidth 10

 

R1(config)#interface tunnel 0
R1(config-if)#shutdown
R1(config-if)#
*Mar  1 01:56:42.507: %LINK-5-CHANGED: Interface Tunnel0, changed state to administratively down
*Mar  1 01:56:43.507: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R1(config-if)#no shut
R1(config-if)#end
R1#s
*Mar  1 01:56:56.571: %LINK-3-UPDOWN: Interface Tunnel0, changed state to up
*Mar  1 01:56:56.755: %SYS-5-CONFIG_I: Configured from console by console
*Mar  1 01:56:57.571: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
R1#show mpls traff
R1#show mpls traffic-eng tunnel

Name: R1_t0                               (Tunnel0) Destination: 4.4.4.4
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected

 

 

Similarly If we change the RSVP bandwidth under f0/1 on R4, it will too not prevent tunnel 0 from coming up as shown below:

 

R4(config)#interface f0/1
R4(config-if)#ip rsvp ban
R4(config-if)#ip rsvp bandwidth 10

 

 

R1(config)#interface tunnel 0
R1(config-if)#shut
R1(config-if)#shutdown
R1(config-if)#
*Mar  1 02:00:03.011: %LINK-5-CHANGED: Interface Tunnel0, changed state to administratively down
*Mar  1 02:00:04.011: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R1(config-if)#no shut
R1(config-if)#
*Mar  1 02:00:12.119: %LINK-3-UPDOWN: Interface Tunnel0, changed state to up
*Mar  1 02:00:13.119: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
R1(config-if)#end
R1#show
*Mar  1 02:00:15.679: %SYS-5-CONFIG_I: Configured from console by console
R1#show mpls traf
R1#show mpls traffic-eng tun
R1#show mpls traffic-eng tunnels

Name: R1_t0                               (Tunnel0) Destination: 4.4.4.4
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected

 

+++++++++++++++++++++++++++++++++++++++++++++++++++++

 

 

Now If I change RSVP bandwidth on any outgoing interface along the LSP  path , (by outgoing i mean f0/0 on R1, f0/1 on R2,  to 10 kbs), it will prevent tunnel 0 from coming up.

Lets see:

R1(config)#interface f0/0
R1(config-if)#ip rsvp bandw
R1(config-if)#ip rsvp bandwidth 10
R1(config-if)#end
R1#
*Mar  1 02:03:32.487: %SYS-5-CONFIG_I: Configured from console by console
R1#
R1#s
*Mar  1 02:03:49.259: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down

 

Lets bring the tunnel back up by setting the ip rsvp bandwidth to default:

 

R1(config)#interface f0/0
R1(config-if)#ip rsvp band
R1(config-if)#ip rsvp bandwidth
R1(config-if)#end
R1#
*Mar  1 02:04:36.799: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up

 

 

Similarly, If we change the ip rsvp bandwidth under f0/1 on R2 ( f0/1 is outgoing interface for the potential LSP)

 

R2(config)#interface f0/1
R2(config-if)#ip rsvp bandwidth 10

 

 

We expect tunnel 0 on R1 to go down. Indeed it does:

 

*Mar  1 02:06:29.259: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
R1#

 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

 

In  nutshell,ingress LSR R1 when checking TE topology to see if a certain path can support a LSP for a given constraint which is 20 Kbs in our case,R1 will check all the outgoing interfaces on each node to see if they have any reservable bandwidth left to support 20 Kbs, if yes, R1 will go ahead and computes the EOR ( which is the ip addresses of  each interfaces on the path) and then sends a Path message. Important thing to note that Path message is not sent to check if a particular node along the path can support 20 Kbs, ( R1 already determined that when computing EOD from TE topology), rather Path message is sent to indicates R1's desire to form a LSP, and to see if nodes along the path are willing to set aside the resources requested by R1 in path message.

 

Thanks guys and have a great day.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

124
Views
0
Helpful
3
Replies