Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

rsvp-te over l3 vpn service

consider:

r1 -- r2 -- r4 -- r5

\ /

r3

where r1,r5 are PEs and r2,r3,r4 are Ps. r3 is a backup router in case r2-r4 path is down (the picture doesn't show up properly).

assume r1's ip route table picks r2-r4 path to go to r5. my dillema is:

- in straight mpls rsvp-te setup, everything works fine, tunnel established, rsvp pkts are labelled properly

- in l3-vpn, i want to enable rsvp-te to use r2-r3-r4 path

- after configuring tunnel0 and map it to vrf-1 in r1, i no longer see the rsvp packet being exchanged between r1-r2 (the pkts become unlabelled now).

am i doing it correctly? are tunnel0 mapped to vrf_1 and assigning it to unnumbered loopback0 enough?

interface Tunnel0

ip vrf forwarding vrf_1

ip unnumbered Loopback0

tunnel destination 12.2.12.2

tunnel mode mpls traffic-eng

tunnel vrf vrf_1

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 7 7

tunnel mpls traffic-eng bandwidth 100

tunnel mpls traffic-eng path-option 10 dynamic

tunnel mpls traffic-eng record-route

tia!

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: rsvp-te over l3 vpn service

This is not going to work indeed. This is how is usually done.

- setup the tunnel without "autoroute announce".

- add an additional loopback address on remote PE.

- set a static route to that new loopback address through the tunnel interface on the local router.

- Use the "bgp next-hop loopback X" command under the VRF configuration on the remote PE to change the BGP next hop address for updates for this particular VRF.

This way only the traffic for this VRF will be forwarded via the tunnel interface.

here's a config example:

r1:

ip route 10.1.1.5 255.255.255.255 Tu0

r5:

ip vrf vrf_1

...

bgp next-hop lo 1

int lo1

ip address 10.1.1.5 255.255.255.255

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
1 REPLY
Cisco Employee

Re: rsvp-te over l3 vpn service

This is not going to work indeed. This is how is usually done.

- setup the tunnel without "autoroute announce".

- add an additional loopback address on remote PE.

- set a static route to that new loopback address through the tunnel interface on the local router.

- Use the "bgp next-hop loopback X" command under the VRF configuration on the remote PE to change the BGP next hop address for updates for this particular VRF.

This way only the traffic for this VRF will be forwarded via the tunnel interface.

here's a config example:

r1:

ip route 10.1.1.5 255.255.255.255 Tu0

r5:

ip vrf vrf_1

...

bgp next-hop lo 1

int lo1

ip address 10.1.1.5 255.255.255.255

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
328
Views
4
Helpful
1
Replies
CreatePlease to create content