Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Running RIP between CPE and PE but rip database on CPE has no vrf routes

I am running RIP between CPE and PE and it is working - I can see the RIP routes in the VRF routing table. However I cannot see the RIP routes on the CPE, which I need to be able to do.

PE RIP Config

router rip

address-family ipv4 vrf ABC

redistribute static metric 1
redistribute bgp 12345

network XX.0.0.0
no auto-summary
exit-address-family

CPE RIP Config

router rip
version 2
redistribute connected metric 1 route-map Connected
network XX.0.0.0
no auto-summary

!

!

route-map Connected permit 10
description *** Interfaces to be advertised to MPLS Network ***
match interface Vlan1
!
route-map Connected deny 100
description *** Deny Statement ***

Thanks in advance for your help

Regards

DK

Everyone's tags (3)
2 REPLIES
New Member

Re: Running RIP between CPE and PE but rip database on CPE has n

Hi DK,

You need to put the "metric #" command in your redistribute bgp configuration under the vrf SAFI in the RIP config on the PE router. This is done to prevent BGP MED (metric) from being used as the RIP metric, which as you would know, has a hop limit of 16.

router rip

address-family ipv4 vrf ABC

redistribute static metric 1

redistribute bgp 12345 metric 1

network XX.0.0.0
no auto-summary
exit-address-family

Try that and you should then see your VPN routes showing on the CE when the RIP process refreshes.

HTH

Joe.

New Member

Re: Running RIP between CPE and PE but rip database on CPE has n

Hi Joe,

Thanks for the feedback, I got to the bottom of this - the routes were not being accepted by the CPE because RIP was seeing the PE as a bad update source

*May  3 22:03:17.260: RIP: ignored v2 update from bad source X.X.X.X on Dialer0

I used no validate-update-source on the CPE and now the routes are being accepted.

Thanks for your help

Regards

DK

1125
Views
0
Helpful
2
Replies