Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SoO and EIGRP for PE-CE, again

Hello,

In a MPLS L3VPN a have a site where two PEs and two CEsare sitting on a LAN where EIGRP runs.

I've set up SoO (same community applied on both PEs)

PE1

!

interface Vlan970

vrf forwarding ap1

ip vrf sitemap SoO

ip address 61.2.100.7 255.255.255.0

!

router bgp 2

!

address-family ipv4 vrf ap1

  redistribute eigrp 2002

exit-address-family

!

router eigrp 2008

!

address-family ipv4 vrf ap1

  redistribute bgp 2 metric 10000 10 1 255 1500

  network 61.2.100.0 0.0.0.255

  autonomous-system 2002

exit-address-family

PE2

interface Vlan970

vrf forwarding ap1

ip vrf sitemap SoO

ip address 61.2.100.8 255.255.255.0

!

router bgp 2

!

address-family ipv4 vrf ap1

  redistribute eigrp 2002

exit-address-family

!

router eigrp 2008

!

address-family ipv4 vrf ap1

  redistribute bgp 2 metric 10000 10 1 255 1500

  network 61.2.100.0 0.0.0.255

  autonomous-system 2002

exit-address-family

Here's what I get as output of sh ip ro vrf ap1:

PE1

C        61.2.100.0/24 is directly connected, Vlan970

L        61.2.100.7/32 is directly connected, Vlan970

D        61.2.103.0/24 [90/130816] via 61.2.100.2, 00:24:01, Vlan970          OK: behind local CE, known via EIGRP internal

B        61.2.104.0/24 [200/171] via 50.50.0.16, 02:28:40                           OK: remote site, known via remote PE               

PE2

C        61.2.100.0/24 is directly connected, Vlan970

L        61.2.100.8/32 is directly connected, Vlan970

D        61.2.103.0/24 [90/130816] via 61.2.100.2, 00:25:22, Vlan970          OK: behind local CE, known via EIGRP internal

D EX     61.2.104.0/24 [170/258816] via 61.2.100.7, 00:25:07, Vlan970     KO: I thought this route would come from iBGP...

I'm sure I'm missing something real simple, hope you can advie me.

Andrea

4 REPLIES

SoO and EIGRP for PE-CE, again

hello,

can you post output from

PE2# sh ip bgp vpnv4 vrf ap1

PE2# sh ip bgp vpnv4 vrf ap1 rib-failure

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
New Member

SoO and EIGRP for PE-CE, again

Blau Grana,

Here you are:

sh ip bgp vpnv4 vrf ap1

     Network          Next Hop            Metric LocPrf Weight Path

Route Distinguisher: 11:11 (default for vrf ap1)

* i 61.2.100.0/24  50.50.0.7                0    100      0 ?

*>                   0.0.0.0                  0         32768 ?

* i 61.2.103.0/24  50.50.0.7           130816    100      0 ?

*>                   61.2.100.2        130816         32768 ?

*>  61.2.104.0/24  161.27.100.7        258816         32768 ?

* i                  50.50.0.16             171    100      0 ?

sh ip bgp vpnv4 vrf ap1 rib-failure

  Network            Next Hop                      RIB-failure   RIB-NH Matches

Best Regards

Andrea

SoO and EIGRP for PE-CE, again

Are you sure you gave us correct info? it seems to me that two outputs, from routing and bgp table do not correlate. can you check that please and also include some sketch of topology.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
New Member

SoO and EIGRP for PE-CE, again

Hello,

here you are with the layout, the 50.50.0.16 is the BGP loopback of the remote PE.

AP

424
Views
0
Helpful
4
Replies
CreatePlease to create content