Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Static route inside VRF - forwarding problems

Hi,

 

I have simple static route inside my VRF:

 

router static
 vrf VRF-B
  address-family ipv4 unicast
   192.168.2.5/32 GigabitEthernet0/0/0/5.2 192.168.25.5
  !
 !
!

next-hop is ping-able:

 

P/0/0/CPU0:02-PE2#ping vrf VRF-B 192.168.25.5
Tue Aug 26 21:17:44.510 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.25.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

 

but the static route not:

 

RP/0/0/CPU0:02-PE2#ping vrf VRF-B 192.168.2.5  
Tue Aug 26 21:18:31.176 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.5, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

CEF looks OK:

 

RP/0/0/CPU0:02-PE2#show ip cef vrf VRF-B 192.168.25.5/32 detail  
Tue Aug 26 21:19:16.933 UTC
192.168.25.5/32, version 0, internal 0x4080001 0x0 (ptr 0xacc291a4) [1], 0x0 (0xacc225b0), 0x0 (0x0)
 Updated Aug 26 21:12:03.552 
 local adjacency 192.168.25.5
 Prefix Len 32, traffic index 0, Adjacency-prefix, precedence n/a, priority 0
  gateway array (0xacbd324c) reference count 1, flags 0x0, source aib (2), 0 backups
                [2 type 3 flags 0x10101 (0xacbf30e4) ext 0x0 (0x0)]
  LW-LDI[type=3, refc=1, ptr=0xacc225b0, sh-ldi=0xacbf30e4]
   via 192.168.25.5, GigabitEthernet0/0/0/5.2, 5 dependencies, weight 0, class 0 [flags 0x0]
    path-idx 0 NHID 0x0 [0xacb46ab8 0x0]
    next hop 192.168.25.5
    local adjacency


    Load distribution: 0 (refcount 2)

    Hash  OK  Interface                 Address
    0     Y   GigabitEthernet0/0/0/5.2  192.168.25.5   

 

I have captured the traffic on the wire, and I see, that when ping to my static route is initiated, there is ARP request for NH (ARP was empty initially):

 

23:12:40.823185  In arp who-has 192.168.25.5 tell 192.168.25.2
23:12:40.823213 Out arp reply 192.168.25.5 is-at 00:50:56:8b:5f:99

 

but, there is no following Echo Request :-(

 

What could be the problem?

 

 

  • MPLS
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Hi,Can you give a simple

Hi,

Can you give a simple topology details involved?. Where do you have 192.168.2.5?. Is it configured on the nexthop router?.

 

Did you check if you have return path?. From 192.168.25.5, are you able to reach/ping 192.168.2.5?. If yes, can you try with source as 192.168.2.5 (explicitly specified)?.

 

Thanks,

Nagendra

2 REPLIES
Cisco Employee

Hi,Can you give a simple

Hi,

Can you give a simple topology details involved?. Where do you have 192.168.2.5?. Is it configured on the nexthop router?.

 

Did you check if you have return path?. From 192.168.25.5, are you able to reach/ping 192.168.2.5?. If yes, can you try with source as 192.168.2.5 (explicitly specified)?.

 

Thanks,

Nagendra

New Member

OK. It was my fault

OK. It was my fault (misconfiguration).

 

On CE I had VRF-lite, and the loopback with address in question (192.168.2.5) was not in that VRF. Now is working :-).

 

Thanks

76
Views
0
Helpful
2
Replies
This widget could not be displayed.