Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Cisco Employee

TE over ospf virtual-link does not work

Hi Expert,

I want to practise the TE over ospf virtual-link. The topo is like this one:

R1 R2

| |

R3---R4

| |

R5 R6

all links are in area 0 except link between R3 and R4.

rt5_1#ro

router ospf 1

router-id 1.1.1.1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

!

interface Tunnel16

ip unnumbered Loopback0

tunnel destination 6.6.6.6

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 5 5

tunnel mpls traffic-eng bandwidth 5

tunnel mpls traffic-eng path-option 10 dynamic

...

....

rt5_2#ro

router ospf 1

router-id 2.2.2.2

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

!

....

rt5_3#ro

router ospf 1

router-id 3.3.3.3

log-adjacency-changes

area 1 virtual-link 4.4.4.4

network 3.3.3.3 0.0.0.0 area 0

network 10.10.13.0 0.0.0.255 area 0

network 10.10.34.0 0.0.0.255 area 1

network 10.10.35.0 0.0.0.255 area 0

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

mpls traffic-eng interface

Ethernet1/0/1 area 0

....

rt5_4#ro

router ospf 1

router-id 4.4.4.4

log-adjacency-changes

area 1 virtual-link 3.3.3.3

network 4.4.4.4 0.0.0.0 area 0

network 10.10.24.0 0.0.0.255 area 0

network 10.10.34.0 0.0.0.255 area 1

network 10.10.46.0 0.0.0.255 area 0

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

mpls traffic-eng interface Ethernet1/1 area 0

....

rt5_5#ro

router ospf 1

router-id 5.5.5.5

log-adjacency-changes

network 5.5.5.5 0.0.0.0 area 0

network 10.10.35.0 0.0.0.255 area 0

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

!

....

rt5_7#ro

router ospf 1

router-id 6.6.6.6

log-adjacency-changes

network 6.6.6.6 0.0.0.0 area 0

network 10.10.46.0 0.0.0.255 area 0

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

!

...

--------

The tunnel 16 on R1 from R6 does not come up .

rt5_1#sh mpls traffic-eng tunnels t16

Name: rt5_1_t16 (Tunnel16) Destination: 6.6.6.6

Status:

Admin: up Oper: down Path: not valid Signalling: Down

path option 10, type dynamic

Config Parameters:

Bandwidth: 5 kbps (Global) Priority: 5 5 Affinity: 0x0/0xFFFF

Metric Type: TE (default)

AutoRoute: enabled LockDown: disabled Loadshare: 5 bw-based

auto-bw: disabled

Shortest Unconstrained Path Info:

Path Weight: UNKNOWN

Explicit Route: UNKNOWN

History:

Tunnel:

Time since created: 1 hours, 7 minutes

Path Option 10:

Last Error: PCALC:: No path to destination, 6.6.6.6

.....

Does anyone the cause of the problem?

thanks,

7 REPLIES

Re: TE over ospf virtual-link does not work

Hello,

the tunnel is setup between two routers in area 0 (R1 and R6) and you enabled MPLS TE only in area 0:

router ospf 1

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

So I assume the condition of your tunnel is not depending on the virtual link at all (R1-R3-R5-R6 is all area 0, right?). Have you checked RSVP settings on all relevant interfaces? Each router should be configured with at least:

ip cef

mpls traffic-eng tunnel

interface Ethernet0/0/0

!adjust to your hardware, repeat for each interface

ip address 10.10.0.1 255.255.255.0

mpls ip

mpls traffic-eng tunnels

mpls mtu 1512

ip rsvp bandwidth 7500 7500

router ospf 1

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

Hope this helps! PLease rate all posts.

Regards, Martin

Cisco Employee

Re: TE over ospf virtual-link does not work

Hi Martin,

The topology is not so clear in my first post.

Here is the correct one:

R1 R2

| |

R3---R4

| |

R5 R6

All links are in area 0 except the link between R3-R4, which is in area1, and this area is the virtul link.

Yes, I double checked my config and every router has

rsvp and cef, and mpls traffic-eng config.

I can see the following out on every router:

rt5_3#sh mpls traffic-eng tunnels b

Signalling Summary:

LSP Tunnels Process: running

Passive LSP Listener: running

RSVP Process: running

Forwarding: enabled

thanks,

guoming

Cisco Employee

Re: TE over ospf virtual-link does not work

Hi Martin,

The double links between R1 and,R3, R3 and R5 is not correct.There is one link between R1 and R3, R3 and R5. Also there is one link between R2-R4, and R4-R6.

thanks,

guoming

Re: TE over ospf virtual-link does not work

Hello,

the topology is not clear to me. Do you have a contiguous area0 or not?

Can you post a "show mpls traffic-eng topology brief" on router R1 and R6 (if different)?

Regards, Martin

Cisco Employee

Re: TE over ospf virtual-link does not work

Hi,

There is one virutal link between R3 and R4.

rt5_1#sh mpls traffic-eng topology

....

IGP Id: 3.3.3.3, MPLS TE Id:3.3.3.3 Router Node (ospf 1 area 0)

link[0]: Broadcast, DR: 10.10.35.5, nbr_node_id:24, gen:224

frag_id 1, Intf Address:10.10.35.3

TE metric:10, IGP metric:10, attribute flags:0x0

link[1]: Broadcast, DR: 10.10.13.1, nbr_node_id:25, gen:224

frag_id 0, Intf Address:10.10.13.3

TE metric:10, IGP metric:10, attribute flags:0x0

link[2]: Broadcast, DR: 10.10.34.3, nbr_node_id:-1, gen:224

frag_id 3, Intf Address:10.10.34.3

TE metric:10, IGP metric:invalid, attribute flags:0x0

sh mpls traffic-eng topology brief

.....

IGP Id: 3.3.3.3, MPLS TE Id:3.3.3.3 Router Node (ospf 1 area 0)

link[0]: Broadcast, DR: 10.10.35.5, nbr_node_id:31, gen:106

frag_id 1, Intf Address:10.10.35.3

TE metric:10, IGP metric:10, attribute flags:0x0

link[1]: Broadcast, DR: 10.10.13.1, nbr_node_id:32, gen:106

frag_id 0, Intf Address:10.10.13.3

TE metric:10, IGP metric:10, attribute flags:0x0

link[2]: Broadcast, DR: 10.10.34.3, nbr_node_id:-1, gen:106

frag_id 3, Intf Address:10.10.34.3

TE metric:10, IGP metric:invalid, attribute flags:0x0

IGP Id: 4.4.4.4, MPLS TE Id:4.4.4.4 Router Node (ospf 1 area 0)

link[0]: Broadcast, DR: 10.10.46.6, nbr_node_id:34, gen:104

frag_id 0, Intf Address:10.10.46.4

TE metric:10, IGP metric:invalid, attribute flags:0x0

link[1]: Broadcast, DR: 10.10.24.2, nbr_node_id:19, gen:104

frag_id 1, Intf Address:10.10.24.4

TE metric:10, IGP metric:10, attribute flags:0x0

link[2]: Broadcast, DR: 10.10.34.3, nbr_node_id:-1, gen:104

frag_id 2, Intf Address:10.10.34.4

TE metric:10, IGP metric:invalid, attribute flags:0x0

IGP Id: 5.5.5.5, MPLS TE Id:5.5.5.5 Router Node (ospf 1 area 0)

link[0]: Broadcast, DR: 10.10.35.5, nbr_node_id:31, gen:94

thanks,

guoming

Re: TE over ospf virtual-link does not work

Hello,

as there is really only one virtual link between R3 and R4, then the tunnel is not depending on it. Just shut down the interface between R3 and R4 and monitor the tunnel. The tunnel should come up if everything is confiured correctly because the remaining network is all area 0.

If the tunnel does not come up with area 1 removed, then the problem has nothing to do with the virtual link at all. Do normal MPLS TE trouble shooting to achieve a working tunnel between R1 and R6. Once the tunnel is up then enable the R3-R4 interface and the OSPF virtual link again to check, whether it has any effect on your MPLS TE environment.

Hope this helps! Pllease rate all posts.

Regards, Martin

Cisco Employee

Re: TE over ospf virtual-link does not work

Although your diagram is bit unclear, I'll try the best.

have you noticed that PCALC error ?, no path to 6.6.6.6

I would chase this way;

sh ip rou 6.6.6.6

sh ip cef 6.6.6.6/24

sh mpls traffic-eng topology path destination 6.6.6.6

Then deb rsvp stuff

Regards

Sanjeewa

305
Views
0
Helpful
7
Replies
CreatePlease to create content