Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trivial MPLS Deployment

Hi all,

I'm trying to set up the simplest possible MPLS deployment: a statically-configured MPLS hop between two routers.

Unfortunately, all the documentation seems to come in at a more complex level. Can anybody help me?

I've tried a couple of potential tunnel configurations:

interface Tunnel0

ip unnumbered GigabitEthernet0/1

tunnel destination 192.168.0.1

tunnel mode mpls traffic-eng

tunnel tsp-hop 1 192.168.0.1 lasthop

no routing dynamic

!

interface Tunnel1

ip unnumbered Loopback0

mpls ip

tunnel destination 192.168.0.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name pathtest

no routing dynamic

!

ip explicit-path name pathtest enable

next-address 192.168.0.1

But both these tunnels appear as operationally down and so I can't route on them.

Any hints would be hugely appreciated!

5 REPLIES
New Member

Re: Trivial MPLS Deployment

hello

did you enable 'mpls traffic-eng tunne' globally?

on each physical interface in the path?

could you post complete config?

post 'sh mpls traff tunnel' output, 'sh mpls traff topo'

etienne

Re: Trivial MPLS Deployment

Hi,

You configuration looks all ok.

Run through the checks as below:

1) Enable your IGP for MPLS TE info propogation.

2) Enable Label Switching on the directly connected interfaces. (mpls ip in interface mode) (<--Required)

3) Enable RSVP by entering ip rsvp bandwidth XXX on each concerned interface. (<-- This is optional)

4) Enable MPLS TE on the interfaces ('mpls traffic-eng tunnels' in interface mode) <----

5) Configure the TE tunnels as below. ( This is same as what you have already configured, path option you can leave it to dynamic or specify a explict)

To summarize the config should be as below.

!

ip cef

mpls traffic-eng tunnels

!

!

interface Tunnel0

ip unnumbered loopback0

tunnel destination 2.2.2.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 explicit name PATH

no clns route-cache

end

!

router ospf 1

router-id 1.1.1.1

log-adjacency-changes

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

!

interface mediatype x/x

mpls ip

mpls traffic-eng tunnels

!

<-- Tunnel IP could be unnumbered with any other interface IP instead of loopback provided the interface is in a Up/Up state., but loopback is a bestpractise.

Here is a link as a reference for basic level of TE configuration.

http://www.cisco.com/en/US/tech/tk436/tk428/technologies_configuration_example09186a0080093fcb.shtml

HTH-Cheers,

Swaroop

Cisco Employee

Re: Trivial MPLS Deployment

Hi,

Besides etiennes comments also make sure that the tunnel destination matches the endpoints MPLS TE router ID and your interfaces are RSVP enabled.

f.e.:

R1

mpls traffic-eng tunnels

interface Loopback0

ip address 192.168.0.1 255.255.255.255

interface Serial0

ip address 10.1.1.1 255.255.255.252

mpls traffic-eng tunnels

ip rsvp bandwidth

router ospf 10

mpls traffic-eng router-id loopback0

mpls traffic-eng area 0

network 0.0.0.0 0.0.0.0 area 0

R2

mpls traffic-eng tunnels

interface Tunnel100

ip unnumbered Loopback0

tunnel destination 192.168.0.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 dynamic

tunnel mpls traffic-eng bandwidth 1

no routing dynamic

interface Loopback0

ip address 192.168.0.2 255.255.255.255

interface Serial0

ip address 10.1.1.2 255.255.255.252

mpls traffic-eng tunnels

ip rsvp bandwidth

router ospf 10

mpls traffic-eng router-id loopback0

mpls traffic-eng area 0

network 0.0.0.0 0.0.0.0 area 0

Your config should look similar, if anything is missing, tunnels will not come up.

Hope this helps! Please rate all posts.

Regards, Martin

Re: Trivial MPLS Deployment

Hey Martin, didnt see your reply before, as i was already in the answer message window :-)

Anyways

Cheers,

Swaroop

New Member

Re: Trivial MPLS Deployment

Thank you all for your reponses.

I have done some further research and eventually found that I was looking at this from entirely the wrong direction. I actually needed to have discovered the "mpls static ..." commands!

All is resolve now.

Thanks once again!

154
Views
0
Helpful
5
Replies
CreatePlease to create content