Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Using Different VLANs within a MPLS VRF

Hi,

My company has a couple of clients that have similar network requirements that need to transverse our IP/MPLS core. We are looking at the possibility of grouping these clients within the same VRF and use VLANs to separate their traffic.

I would need advice on the best possible way to achieve this.

3 REPLIES

Re: Using Different VLANs within a MPLS VRF

If you need to group your clients into a single VRF, all you need to do is to just define the VRF on the PE under the interface towards the CE.

Vlans can be defined on the switch as you would do in a normal campus network.

If you need to have seperation throughout, you can use vrf lite at the campus and use different vrfs for each client

Narayan

Cisco Employee

Re: Using Different VLANs within a MPLS VRF

Olubunmi,

Bear in mind that even if these customers are on different vlans, they will still have access to each others network at layer 3 as they will be terminating in the same VRF. Probably not something you want.

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Silver

Re: Using Different VLANs within a MPLS VRF

ip vrf abc

rd 1:1

rt both 1:1

interface GigabitEthernet0/3.204

encapsulation dot1Q 204

ip vrf forwarding abc

ip address 10.16.170.69 255.255.255.252

end

interface GigabitEthernet0/3.205

encapsulation dot1Q 204

ip vrf forwarding abc

ip address 10.16.170.69 255.255.255.252

end

regards

shivlu

282
Views
0
Helpful
3
Replies