cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7746
Views
0
Helpful
1
Replies

vlan MTU, interface vlan mtu and hardware mtu

benoit.lecompt
Level 1
Level 1

Hello,

I use two 7600 as P routers.

These are configured with routed interfaces:

interface Gi2/1

mtu 1520

interface Gi2/1.15

no switchport

ip address 1.2.3.4 255.255.255.0

mpls ip

Now want to use SVI:

vlan 1145

mtu 1520

!

interface vlan 1145

ip address 1.2.3.4 255.255.255.0

tag-switching ip

mtu 1520

!

conf t

interface Gi2/1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1145

switchport mode trunk

switchport nonegotiate

mtu 9216

no ip address

speed nonegotiate

no shutdown

!

I understand mtu 9216 as the hardware mtu.

1520-sized ICMP packets with df-bit are ok with:

vlan 1145

mtu 1520

interface vlan 1145

mtu 1520

and also ok with:

vlan 1145

mtu 1500

interface vlan 1145

mtu 1520

but not OK if the mtu on interface vlan 1145 is not 1520.

So, what is the difference between the mtu 1520 command under interface vlan 1145 and the mtu 1520 command under vlan 1145 configuration ?

Is there any issues (performances) using 7600 as P router with SVI ?

Thanks

1 Reply 1

william.caban
Level 5
Level 5

When you set the vlan mtu you are configuring the maximum PDU that the specific vlan will be able to transit. When you set the mtu on an SVI you are configuring the max PDU you are able to receive in your Layer3 from that vlan.

"A packet's MTU is not checked on the ingress side of an SVI. However, it is checked on the egress side of an SVI. If the packet's MTU is larger than the egress SVI's MTU, the packet is fragmented by software (if the DF bit is not set)."

http://www.cisco.com/warp/public/473/175.html

HTH

-W

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: