Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

VPLS between ASR1000 and 7600

Hello.

I'm trying to create VPLS between two ASR1004 routers and one 7600 with ES+ card.

IGP/BGP and LDP connections between all routers are OK.

Configuration is the following:

Cisco 7600: (IP 12.12.12.12)

l2 vfi TEST manual
vpn id 777
neighbor 8.8.8.8 encapsulation mpls
neighbor 2.2.2.2 encapsulation mpls

interface Vlan777
no ip address
xconnect vfi TEST
end

interface GigabitEthernet1/12  // Link to switch1
description LINK to SW1

switchport
switchport trunk encapsulation dot1q
switchport mode trunk
end


And the ASR's config: (IP 8.8.8.8/2.2.2.2)

l2 vfi TEST manual
vpn id 777

bridge-domain 777
neighbor 12.12.12.12 encapsulation mpls
neighbor 8.8.8.8 encapsulation mpls


 

interface GigabitEthernet0/0/0 // Link to switch2
description DOWNLINK to SW2
load-interval 30
speed 1000
no negotiation auto
no clns route-cache
service instance 777 ethernet
encapsulation dot1q 777

bridge-domain 777


 

Then I created SVI interfaces on both switches, connected to 7600 and ASR1K (SW1 and SW2), but ping between them in the vlan 777 was failed.

sh xconnect all from the ASR:

UP pri vfi TEST UP mpls 12.12.12.12:777 UP
UP pri vfi TEST UP mpls 8.8.8.8:777 UP

What's wrong in this configuration?

 



 



 



 

1 REPLY
Community Member

I've solved the problem.

I've solved the problem.

Just added

rewrite ingress tag pop 1 symmetric

to the CE facing interface

and also

mpls no-split-horizon

to l2 vfi section

208
Views
0
Helpful
1
Replies
CreatePlease to create content