Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

VPLS problem

Hi dear all

Currently we are facing an issue in a VPLS network and I will appreciate your help if you know the solution, thanks in advance.

We have the following topology :

vpls.png

All routers (PA,PB,PC) have Sup32-8GE-3B without  any extra line cards . We configure VPLS on all routers. All routers  have the following running configuration . Also verifications show that  everything is ok .
1.    Is it possible to configure VPLS on Sup32-GE-3B without any extra line cards?
2.    Why configuration has been done but :
         a.    There is not communication between 3 Cust-A sites (L2 connectivity).
         b.    The following error message displayed when add “IP MPLS” command for uplinks.
MPLS CONFIG on LAN NOT RECOMMENDED: Cross-connect is currently  configured on interface vlans   and WAN interfaces are facing the MPLS  core. By configuring MPLS on LAN interfaces, AToM on vlan interfaces may  be non functional.

PA-7609#sh run

Building configuration...

Current configuration : 4030 bytes

!

! Last configuration change at 14:54:05 UTC Thu Jul 29 2010

! NVRAM config last updated at 14:07:27 UTC Thu Jul 29 2010

!

upgrade fpd auto

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service counters max age 5

!

hostname PA-7609

!

boot-start-marker

boot system sup-bootdisk:c7600s3223-advipservicesk9-mz.122-33.SRB7.bin

boot-end-marker

!

enable secret 5 $1$FIyH$5AHHV2qA0noZemUJhZBCL0

!

no aaa new-model

platform vfi dot1q-transparency

ip subnet-zero

!

!

ip vrf forwarding

!

no ip domain-lookup

!

!

ipv6 mfib hardware-switching replication-mode ingress

vtp mode transparent

mls ip multicast flow-stat-timer 9

mls flow ip interface-full

no mls flow ipv6

no mls acl tcam share-global

mls cef error action reset

mpls label protocol ldp

!

!        

spanning-tree mode pvst

spanning-tree extend system-id

system flowcontrol bus auto

diagnostic cns publish cisco.cns.device.diag_results

diagnostic cns subscribe cisco.cns.device.diag_commands

!

!

redundancy

mode rpr

main-cpu

  auto-sync running-config

!

vlan internal allocation policy ascending

vlan dot1q tag native

vlan access-log ratelimit 2000

!

vlan 100

pseudowire-class mpls

encapsulation mpls

!

l2 router-id 10.1.1.1

l2 vfi VPLS1 autodiscovery

vpn id 100

!

!

!

!

!

!

!

interface Loopback1

ip address 10.1.1.1 255.255.255.255

!

interface GigabitEthernet5/1

no ip address

shutdown

!

interface GigabitEthernet5/2

no ip address

shutdown

!

interface GigabitEthernet5/3

no ip address

shutdown

!

interface GigabitEthernet5/4

no ip address

shutdown

!

interface GigabitEthernet5/5

no ip address

shutdown

!

interface GigabitEthernet5/6

no ip address

shutdown

!

interface GigabitEthernet5/7

no ip address

shutdown

!

interface GigabitEthernet5/8

no ip address

shutdown

!

interface GigabitEthernet5/9

no ip address

shutdown

!

interface GigabitEthernet6/1

ip address 192.168.0.1 255.255.255.252

mpls ip

!

interface GigabitEthernet6/2

ip address 172.16.0.1 255.255.255.252

mpls ip

!

interface GigabitEthernet6/3

ip address 192.168.1.18 255.255.255.252

mpls ip 

!

interface GigabitEthernet6/3.200

encapsulation dot1Q 300

!

interface GigabitEthernet6/4

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100

switchport mode trunk

!

interface GigabitEthernet6/5

no ip address

shutdown

!

interface GigabitEthernet6/6

no ip address

!

interface GigabitEthernet6/7

no ip address

!

interface GigabitEthernet6/8

no ip address

!

interface GigabitEthernet6/9

ip address 200.200.200.1 255.255.255.0

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

no ip address

xconnect vfi VPLS1

!

router ospf 1

log-adjacency-changes

network 10.1.1.0 0.0.0.255 area 0

network 172.16.0.0 0.0.0.255 area 0

network 192.168.0.0 0.0.0.255 area 0

!

router bgp 1

no bgp default ipv4-unicast

bgp log-neighbor-changes

bgp update-delay 1

neighbor 10.1.1.2 remote-as 1

neighbor 10.1.1.2 update-source Loopback1

neighbor 10.1.1.3 remote-as 1

neighbor 10.1.1.3 update-source Loopback1

!

address-family ipv4

no synchronization

no auto-summary

exit-address-family

!

address-family l2vpn vpls

neighbor 10.1.1.2 activate

neighbor 10.1.1.2 send-community extended

neighbor 10.1.1.3 activate

neighbor 10.1.1.3 send-community extended

exit-address-family

!

ip classless

!

!

no ip http server

no ip http secure-server

!

!

!

mpls ldp router-id Loopback1

bridge 1 protocol vlan-bridge

!

control-plane

!

!

line con 0

stopbits 1

line vty 0 4

session-timeout 60  output

privilege level 15

password 7 12485744532B4F

login

line vty 5 15

session-timeout 60 output

privilege level 15

password 7 12485744532B4F

login

line vty 16

privilege level 15

password 7 055A545C606C0D

login

!

ntp master 1

mac-address-table synchronize

no mac-address-table learning vlan 2 module 5

mac-address-table learning vlan 100 module 5

no mac-address-table learning vlan 2 module 6

mac-address-table learning vlan 100 module 6

!

End

PB-7609#sh run

Building configuration...

Current configuration : 3683 bytes

!

upgrade fpd auto

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service counters max age 10

!

hostname PB-7609

!

boot-start-marker

boot system sup-bootdisk:c7600s3223-advipservicesk9-mz.122-33.SRB7.bin

boot-end-marker

!

enable secret 5 $1$1YCM$KJ9TC73PD.1v2x8jrVS3S/

!

no aaa new-model

ip subnet-zero

!

!

no ip domain-lookup

!

!

ipv6 mfib hardware-switching replication-mode ingress

mls ip multicast flow-stat-timer 9

mls flow ip interface-full

no mls flow ipv6

no mls acl tcam share-global

mls cef error action reset

mpls label protocol ldp

!

!

spanning-tree mode pvst

spanning-tree extend system-id

system flowcontrol bus auto

diagnostic cns publish cisco.cns.device.diag_results

diagnostic cns subscribe cisco.cns.device.diag_commands

!

!        

redundancy

mode rpr

main-cpu

  auto-sync running-config

!

vlan internal allocation policy ascending

vlan dot1q tag native

vlan access-log ratelimit 2000

pseudowire-class mpls

encapsulation mpls

!

l2 router-id 10.1.1.2

l2 vfi VPLS1 autodiscovery

vpn id 100

!

!

!

!

!

!

!

interface Loopback1

ip address 10.1.1.2 255.255.255.255

!

interface GigabitEthernet5/1

no ip address

shutdown

!

interface GigabitEthernet5/2

no ip address

shutdown

!

interface GigabitEthernet5/3

no ip address

shutdown

!

interface GigabitEthernet5/4

no ip address

shutdown

!        

interface GigabitEthernet5/5

no ip address

shutdown

!

interface GigabitEthernet5/6

no ip address

shutdown

!

interface GigabitEthernet5/7

no ip address

shutdown

!

interface GigabitEthernet5/8

no ip address

shutdown

!

interface GigabitEthernet5/9

no ip address

shutdown

!

interface GigabitEthernet6/1

ip address 192.168.0.2 255.255.255.252

mpls ip

!

interface GigabitEthernet6/2

ip address 172.16.0.5 255.255.255.252

mpls ip

!

interface GigabitEthernet6/3

no ip address

shutdown

!

interface GigabitEthernet6/4

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100

switchport mode trunk

l2protocol-tunnel cdp

l2protocol-tunnel stp

l2protocol-tunnel vtp

no cdp enable

spanning-tree bpdufilter enable

!

interface GigabitEthernet6/5

no ip address

shutdown

!

interface GigabitEthernet6/6

no ip address

shutdown

!

interface GigabitEthernet6/7

no ip address

!

interface GigabitEthernet6/8

no ip address

!

interface GigabitEthernet6/9

ip address 200.200.200.2 255.255.255.0

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

no ip address

xconnect vfi VPLS1

!

router ospf 1

log-adjacency-changes

network 10.1.1.0 0.0.0.255 area 0

network 172.16.0.0 0.0.0.255 area 0

network 192.168.0.0 0.0.0.255 area 0

!

router bgp 1

no bgp default ipv4-unicast

bgp log-neighbor-changes

bgp update-delay 1

neighbor 10.1.1.1 remote-as 1

neighbor 10.1.1.1 update-source Loopback1

neighbor 10.1.1.3 remote-as 1

neighbor 10.1.1.3 update-source Loopback1

!

address-family ipv4

no synchronization

no auto-summary

exit-address-family

!

address-family l2vpn vpls

neighbor 10.1.1.1 activate

neighbor 10.1.1.1 send-community extended

neighbor 10.1.1.3 activate

neighbor 10.1.1.3 send-community extended

exit-address-family

!

ip classless

!

!

no ip http server

no ip http secure-server

!

!

!

mpls ldp router-id Loopback1

!

control-plane

!

!

line con 0

stopbits 1

line vty 0 4

session-timeout 60  output

privilege level 15

password 7 12485744532B4F

login

line vty 5 15

session-timeout 60  output

privilege level 15

password 7 12485744532B4F

login   

line vty 16

privilege level 15

password 7 1543595F450A68

login

!

mac-address-table synchronize

mac-address-table learning vlan 100 module 5

mac-address-table learning vlan 100 module 6

!

End

PC-7609#sh run

Building configuration...

Current configuration : 3896 bytes

!

upgrade fpd auto

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service counters max age 10

!

hostname PC-7609

!

boot-start-marker

boot system sup-bootdisk:c7600s3223-advipservicesk9-mz.122-33.SRB7.bin

boot-end-marker

!

enable secret 5 $1$cL//$YpRw8OQfCv2vYXZIvORkU.

!

no aaa new-model

ip subnet-zero

!

!

no ip domain-lookup

!

!

ipv6 mfib hardware-switching replication-mode ingress

vtp mode transparent

mls ip multicast flow-stat-timer 9

mls flow ip interface-full

no mls flow ipv6

no mls acl tcam share-global

mls cef error action reset

mpls ldp explicit-null

mpls label protocol ldp

!

!

spanning-tree mode pvst

spanning-tree extend system-id

system flowcontrol bus auto

diagnostic cns publish cisco.cns.device.diag_results

diagnostic cns subscribe cisco.cns.device.diag_commands

!

!

redundancy

mode sso

main-cpu

  auto-sync running-config

!

vlan internal allocation policy ascending

vlan dot1q tag native

vlan access-log ratelimit 2000

!

vlan 100

pseudowire-class mpls

encapsulation mpls

!

l2 router-id 10.1.1.3

l2 vfi VPLS1 autodiscovery

vpn id 100

!

!

!

!

!

!

!

interface Loopback1

ip address 10.1.1.3 255.255.255.255

!

interface GigabitEthernet5/1

no ip address

shutdown

!

interface GigabitEthernet5/2

no ip address

shutdown

!

interface GigabitEthernet5/3

no ip address

shutdown

!        

interface GigabitEthernet5/4

no ip address

shutdown

!

interface GigabitEthernet5/5

no ip address

shutdown

!

interface GigabitEthernet5/6

no ip address

shutdown

!

interface GigabitEthernet5/7

no ip address

shutdown

!

interface GigabitEthernet5/8

no ip address

shutdown

!

interface GigabitEthernet5/9

no ip address

shutdown

!

interface GigabitEthernet6/1

ip address 172.16.0.2 255.255.255.252

mpls ip

!

interface GigabitEthernet6/2

ip address 172.16.0.6 255.255.255.252

mpls ip

!

interface GigabitEthernet6/3

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100

switchport mode trunk

l2protocol-tunnel cdp

l2protocol-tunnel stp

l2protocol-tunnel vtp

no cdp enable

spanning-tree bpdufilter enable

!

interface GigabitEthernet6/4

ip address 192.168.1.9 255.255.255.252

mpls ip

!

interface GigabitEthernet6/5

no ip address

no cdp enable

!

interface GigabitEthernet6/6

no ip address

!

interface GigabitEthernet6/7

no ip address

!

interface GigabitEthernet6/8

no ip address

!

interface GigabitEthernet6/9

ip address 200.200.200.3 255.255.255.0

speed 10

duplex half

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

no ip address

xconnect vfi VPLS1

!

router ospf 1

log-adjacency-changes

network 10.1.1.0 0.0.0.255 area 0

network 172.16.0.0 0.0.0.255 area 0

network 192.168.0.0 0.0.0.255 area 0

!

router bgp 1

no bgp default ipv4-unicast

bgp log-neighbor-changes

bgp update-delay 1

neighbor 10.1.1.1 remote-as 1

neighbor 10.1.1.1 update-source Loopback1

neighbor 10.1.1.2 remote-as 1

neighbor 10.1.1.2 update-source Loopback1

!

address-family ipv4

no synchronization

no auto-summary

exit-address-family

!

address-family l2vpn vpls

neighbor 10.1.1.1 activate

neighbor 10.1.1.1 send-community extended

neighbor 10.1.1.2 activate

neighbor 10.1.1.2 send-community extended

exit-address-family

!

ip classless

!

!

no ip http server

no ip http secure-server

!

!

!

mpls ldp router-id Loopback1

bridge 1 protocol vlan-bridge

!

control-plane

!

!

line con 0

stopbits 1

line vty 0 4

session-timeout 60  output

privilege level 15

password 7 12485744532B4F

login

line vty 5 15

session-timeout 60  output

privilege level 15

password 7 12485744532B4F

login

line vty 16

privilege level 15

password 7 075E731F0F295A

login

!

mac-address-table synchronize

no mac-address-table learning vlan 4

mac-address-table learning vlan 100 module 5

no mac-address-table learning vlan 4 module 6

mac-address-table learning vlan 100 module 6

!

end

Verification

PA-7609#sh mpls ldp neighbor

    Peer LDP Ident: 200.200.200.2:0; Local LDP Ident 200.200.200.1:0

        TCP connection: 200.200.200.2.11362 - 200.200.200.1.646

        State: Oper; Msgs sent/rcvd: 136/137; Downstream

        Up time: 01:40:27

        LDP discovery sources:

          GigabitEthernet6/1, Src IP addr: 192.168.0.2

          Targeted Hello 10.1.1.1 -> 10.1.1.2, active, passive

        Addresses bound to peer LDP Ident:

         200.200.200.2   192.168.0.2     172.16.0.5      10.1.1.2       

    Peer LDP Ident: 200.200.200.3:0; Local LDP Ident 200.200.200.1:0

        TCP connection: 200.200.200.3.64421 - 200.200.200.1.646

        State: Oper; Msgs sent/rcvd: 137/130; Downstream

        Up time: 01:40:26

        LDP discovery sources:

          Targeted Hello 10.1.1.1 -> 10.1.1.3, active, passive

          GigabitEthernet6/2, Src IP addr: 172.16.0.2

        Addresses bound to peer LDP Ident:

          200.200.200.3   172.16.0.2      172.16.0.6      10.1.1.3  

PA-7609#sh ip bgp l2vpn vpls all

BGP table version is 18, local router ID is 10.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,  r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

Route Distinguisher: 1:100

*> 1:100:10.1.1.1/96                     0.0.0.0                            32768 ?

*>i1:100:10.1.1.2/96                     10.1.1.2                 0    100      0 ?

*>i1:100:10.1.1.3/96                     10.1.1.3                 0    100      0 ?

PA-7609#show xconnect all

Legend: XC ST=Xconnect State, S1=Segment1 State, S2=Segment2 State

UP=Up, DN=Down, AD=Admin Down, IA=Inactive, NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2

------+---------------------------------+--+---------------------------------+--

UP     vfi  VPLS1                        UP mpls 10.1.1.2:100                 UP

UP     vfi  VPLS1                        UP mpls 10.1.1.3:100                 UP

UP     ac   Vl100 100(Eth VLAN)          UP vfi  VPLS1                    UP

PA-7609#sh mac-address-table  dynamic 

Legend: * - primary entry

        age - seconds since last seen

        n/a - not available

  vlan   mac address     type    learn     age              ports

------+----------------+--------+-----+----------+--------------------------

No entries present.

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: VPLS problem

Hi,

If you need to run VPLS then you core facing card need to do imposition/disposition. I doubt if the sup32 gig ports can do so. For VPLS to work on 7600 any one of following card is needed.

PWAN2 (OSM)

ES+ (ES40)

ES20

SIP-400

SIP-600

If you have say a lan card like 6748 or 6724 towards core and try to bring up VPLS, it will allow you to provision but VC might not come up. The other message you are getting is normal when you try to enable mpls on a lan card. I think this can be safely ignored.

Thanks,

Madhu

2 REPLIES
Bronze

Re: VPLS problem

Hi,

If you need to run VPLS then you core facing card need to do imposition/disposition. I doubt if the sup32 gig ports can do so. For VPLS to work on 7600 any one of following card is needed.

PWAN2 (OSM)

ES+ (ES40)

ES20

SIP-400

SIP-600

If you have say a lan card like 6748 or 6724 towards core and try to bring up VPLS, it will allow you to provision but VC might not come up. The other message you are getting is normal when you try to enable mpls on a lan card. I think this can be safely ignored.

Thanks,

Madhu

New Member

Re: VPLS problem

Many thanks Madhu, your comment was very useful.

1516
Views
0
Helpful
2
Replies
CreatePlease to create content