Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VPN tag not generated

Hello group,

Recenlty I'm having some problem in my production PE routers. At times, the PE is not generating any MPLS VPN tag. When this happens, a syslog comes saying:

"Jun 30 10:16:16.169: %TFIB-4-FIBCBLK: Missing MPLS Forwarding Information Base table for tableid 65535 during Route Tag Change event"

On the PE, 'show ip cef vrf xxx prefix' does not show any local tag [attached].

So, on the upstream PE no MPLS-VPN tag is there except for the top most label for downstream PE.

To resolve this probelm, I enable and disable cef on the VPN interface by 'no ip cef/ ip cef' command. Then it works fine.

The IOS version is: c3745-js-mz.122-15.T14

Might be, someone in the group find any reason to this type of problem.

Regards,

Dabraj Sarkar

Grameenphone Ltd

6 REPLIES
Silver

Re: VPN tag not generated

Looks more like a code issue. Did you try changing the IOS ? Maybe you can try adding the route as a non-recursive route and see if it helps

Community Member

Re: VPN tag not generated

Dear Gautam,

Thanks for the response. Could you please explain non-recursive route in this context? I'm running static routing between PE-CE. Does non-recursive route mean that to configure exit interface along with next hop IP in the static route definition?

I'm trying to change the IOS. Any suggestion regarding stable S-train codes?

Regards,

Dabraj

Silver

Re: VPN tag not generated

yes thats right. It was just a suggestion. You could try that.

Not sure i can help much S-train for 3700. 12.3 (18) Sp services should be fine i think.

Community Member

Re: VPN tag not generated

Hi Gautam,

I'll have a research on the code. Let me check the recursive routing issue.

Best regards,

Dabraj

Bronze

Re: VPN tag not generated

Dabraj,

Is this just a lab environment? I wouldnt really recommend running a live environment with a 3745. As already stated as well your code to me is very suspicious. Firstly you are running an enterprise based code but wanting to do SP features. I would change to either an "S" train or lookout a good old Telco train which done the trick for me in my lab setups.

Community Member

Re: VPN tag not generated

Dear McCallum,

Thanks for the response. It could be supicious but its true. My PEs are 3745 and in production for almost two years! Could you please recommend an S train code for this platform. The flash size is 64 MB and RAM is 256 MB.

Regards,

Dabraj

266
Views
15
Helpful
6
Replies
CreatePlease to create content