Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VRF lite routing between two

Hi,

In the following diagram taken from http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/20ew/configuration/guide/vrf.html

VRF-Lite network.JPG

BGP is used between the CE (S8) and the router, text is saying that configuration for PE to CE (SW9) should be similar. Does that means that we should defined another neighbors connected to a different Autonomous System on PE and used the PE as a BGP transit.

More important, is there any advantage of using  BGP here or we could used EIGRP to redistribute OSPF route from  S8 VPN 1 to S9 VPN 1.

Thanks for your help

Stephane

4 REPLIES
Cisco Employee

Re: VRF lite routing between two

Stephane,

In this example, you could have used any routing protocol to carry the routes between CE and PE routers. However, if an IGP protocol was used then a separate instance for each VRF would need to be run both on the CE and PE routers. That could be perceived as a disadvantage - configuring and running possibly many instances of an IGP protocol. And if you think of the added complexity if, say, S8 spoke OSPF while S9 spoke EIGRP and PE needed to run both OSPF and EIGRP over the same VRF and perform mutual redistribution... you get the point.

Using BGP will allow you to carry routes from all VRFs in a single BGP process between CE and PE routers. Especially the PE will benefit greatly - instead of running multiple IGP instances (possibly even different protocols), it will run just a single BGP process. BGP also has its advantages with its large set of route manipulation and filtering tools.

Best regards,

Peter

Community Member

Re: VRF lite routing between two

Hi Peter,


Thanks for your help, as usual this is quite appreciate. I think I got the point, Only one BGP process will be required on the PE router even if this process will announce diffrerent route on different vlan following the association between vrf and vlan. Like you say, running OSPF between SW8 to PE and EIGRP between  SE9 and PE would required the PE to run one OSPF instance for the two VRF connect to S8 and one EIGRP instance for the two VRF connect to S9 and perform the redistribution.

Question: Does this solution would scale for few others PE if we run full mesh iBGP.

Thanks again

Stephane

Cisco Employee

Re: VRF lite routing between two

Hello Stephane,

Thank you very much for your kind words.

Regarding the scalability question: I am not sure if I understand the question correctly. If you are asking how scalable is using the iBGP full mesh in this network with a couple of added PEs then I would say it boils down to the scalability of the iBGP itself. In a small, preferably stable network with just a few BGP speakers, running iBGP full mesh is just fine. As the network grows larger, the iBGP full mesh becomes limiting, so usually a route reflector is deployed to decrease the complexity of BGP configuration and peering.

Please feel welcome to ask further.

Best regards,

Peter

Community Member

Re: VRF lite routing between two

Hi Peter,

I think my question has more to do with my lack of knowledge of VRF lite.

mp-BGP should be used for a MPLS network. It should transported the MPLS mux label and the RT associated with the VRF.

In a case of a VRF-lite, I think that the BGP route will be associated to specific VRF  based on the relation between the logical sub-interface and the VRF as follows:

Router(config)# interface Fast Ethernet3/0.20
Router(config-if)# encapsulation dot1q 20
Router(config-if)# ip vrf forwarding v2
Router(config-if)# ip address 83.0.0.3 255.255.255.0
Router(config-if)# exit


Router(config)# router bgp 100
Router(config-router)# address-family ipv4 vrf v2
Router(config-router-af)# neighbor 83.0.0.8 remote-as 800
Router(config-router-af)# neighbor 83.0.0.8 activate
Router(config-router-af)# network 3.3.2.0 mask 255.255.255.0 (Loopback)
Router(config-router-af)# exit

I am not sure about the feasibility of such an arrangement if a backbone consists of 3 or 4 PE router. Could we used full mesh iBGP where the trunk are define the same on all PE or could we have a Route Reflector arrangement.

Thanks

Stephane

1082
Views
4
Helpful
4
Replies
CreatePlease to create content