Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VRF lite with OSPF

I'd like to use VRF lite on Cat. 3750 in a way to have two OSPF idependent process.

For test purpose I created only one VRF (here the VRF config):

!

ip routing

!

ip vrf A1

rd 1:1

!

!

interface Vlan1

ip vrf forwarding A1

ip address 10.1.9.1 255.255.255.0

!

vlan 11

exit

!

interface vlan 11

ip vrf forwarding A1

ip address 10.1.10.2 255.255.255.0

no shut

!

!

router ospf 1 vrf A1

log-adjacency-changes

network 10.1.9.0 0.0.0.255 area 1

network 10.1.10.0 0.0.0.255 area 1

!

VLAN 11 is phisically connected to the Backbone.

The routes of the VRF A1 table is inclomplete only intra-area (area 1) routes are present and no Inter area, i.e. Area 2 routes.

....

There is some limitation for multiarea OSPF when use VRF lite ?

....

4 REPLIES
Cisco Employee

Re: VRF lite with OSPF

you need to configure the "capability vrf-lite" command under "router ospf 1 vrf A1".

Let me know if I answered your question,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: VRF lite with OSPF

.. perfect it work ! thank's ...

...

When I use VRF-lite for router virtualisation and Campus segmentation why should I configure Route Distinguisher ?

Cisco Employee

Re: VRF lite with OSPF

In this context, the RD is not really required but certain releases of IOS require that RD be defined.

You can basically use anything as long as it doesn't conflict with another VRF on the same box.

Let me know If I answered your question,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: VRF lite with OSPF

Yes, this really solve my doubt about it. Thank's again.

636
Views
14
Helpful
4
Replies
CreatePlease login to create content